- updated to 1.3.0

This commit is contained in:
Dan Horák 2017-12-04 14:53:25 +01:00
parent c2401c921c
commit 251edf3688
6 changed files with 14 additions and 41 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/qclib-1.2.0.tgz
/qclib-1.3.0.tgz

View File

@ -1,11 +0,0 @@
--- qclib-1.2.0/Makefile 2016-11-30 09:23:28.946521117 -0500
+++ qclib-1.2.0/Makefile.old 2016-11-30 09:36:59.556521117 -0500
@@ -6,7 +6,7 @@
# bugfix: Bugfixes only
VERM = 1
VERSION = $(VERM).2.0
-CFLAGS = -g -Wall -O2
+CFLAGS ?= -g -Wall -O2
CFILES = query_capacity.c query_capacity_data.c query_capacity_sysinfo.c query_capacity_ocf.c \
query_capacity_hypfs.c query_capacity_sthyi.c
OBJECTS = $(patsubst %.c,%.o,$(CFILES))

View File

@ -1,19 +0,0 @@
--- qclib-1.2.0.old/Makefile 2016-06-03 03:14:01.000000000 -0400
+++ qclib-1.2.0/Makefile 2016-11-08 08:38:37.926521117 -0500
@@ -37,7 +37,7 @@
$(AR) rcs $@ $^
libqc.so.$(VERSION): $(OBJECTS)
- $(LINK) -shared $^ -o $@
+ $(LINK) -Wl,-soname,libqc.so.$(VERM) -shared $^ -o $@
qc_test: qc_test.c libqc.a
$(CC) $(CFLAGS) -static $< -L. -lqc -o $@
@@ -49,6 +49,7 @@
./$<
test-sh: qc_test-sh
+ ln -srf libqc.so.$(VERSION) libqc.so.$(VERM)
LD_LIBRARY_PATH=. ./$<
doc: html

View File

@ -1,14 +1,15 @@
--- qclib-1.2.0/Makefile.old 2016-12-01 08:09:00.446521117 -0500
+++ qclib-1.2.0/Makefile 2016-12-15 04:47:43.746521117 -0500
diff -up qclib-1.3.0/Makefile.docdir qclib-1.3.0/Makefile
--- qclib-1.3.0/Makefile.docdir 2017-10-24 07:02:42.000000000 +0200
+++ qclib-1.3.0/Makefile 2017-12-04 14:15:08.000000000 +0100
@@ -6,6 +6,7 @@
# bugfix: Bugfixes only
VERM = 1
VERSION = $(VERM).2.0
VERSION = 1.3.0
VERM = $(shell echo $(VERSION) | cut -d '.' -f 1)
+DOCDIR ?= /usr/share/doc/packages/
CFLAGS ?= -g -Wall -O2
CFILES = query_capacity.c query_capacity_data.c query_capacity_sysinfo.c query_capacity_ocf.c \
query_capacity_hypfs.c query_capacity_sthyi.c
@@ -68,16 +69,16 @@
@@ -69,16 +70,16 @@ install: libqc.a libqc.so.$(VERSION)
ln -sr $(DESTDIR)/usr/lib64/libqc.so.$(VERSION) $(DESTDIR)/usr/lib64/libqc.so.$(VERM)
ln -sr $(DESTDIR)/usr/lib64/libqc.so.$(VERSION) $(DESTDIR)/usr/lib64/libqc.so
install -Dm 644 query_capacity.h $(DESTDIR)/usr/include/query_capacity.h

View File

@ -1,15 +1,13 @@
Name: qclib
Version: 1.2.0
Release: 4%{?dist}
Version: 1.3.0
Release: 1%{?dist}
Summary: Library for extraction of system information for Linux on z Systems
License: BSD
URL: http://www.ibm.com/developerworks/linux/linux390/qclib.html
Source0: http://public.dhe.ibm.com/software/dw/linux390/ht_src/%{name}-%{version}.tgz
# Soname will be set upstream in later release
# https://bugzilla.redhat.com/show_bug.cgi?id=1306280
Patch0: %{name}-1.2.0-soname.patch
Patch1: %{name}-1.2.0-cflags.patch
Patch2: %{name}-1.2.0-docdir.patch
Patch0: %{name}-1.3.0-docdir.patch
ExclusiveArch: s390 s390x
BuildRequires: glibc-static
BuildRequires: doxygen
@ -82,6 +80,9 @@ make test-sh test
%{_libdir}/libqc*.a
%changelog
* Mon Dec 04 2017 Dan Horák <dan[at]danny.cz> - 1.3.0-1
- updated to 1.3.0
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (qclib-1.2.0.tgz) = 5879379d0c0db542a44170b8aebfa12266dd9fc3f38800580efe786a149fb167859a1f8ebe8b23c11a0069697bc43a31c702eefcfb6edf5f99faba002a38e582
SHA512 (qclib-1.3.0.tgz) = aaed6ed7414da7a5d5295ad9c024cb9a9f6792339bad8917b643ed6be53ce92e1fc248c2df17cd451b87c640f6cfc8572de195884e39ff85f876ea258f6c04a1