import qatzip-1.0.7-1.el9

This commit is contained in:
CentOS Sources 2022-05-17 04:50:08 -04:00 committed by Stepan Oksanichenko
commit 8fc7600b29
5 changed files with 152 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/qatzip-1.0.7.tar.gz

1
.qatzip.metadata Normal file
View File

@ -0,0 +1 @@
68952cc3974023fcbfba40e81aa1648b44c0e086 SOURCES/qatzip-1.0.7.tar.gz

View File

@ -0,0 +1,14 @@
--- utils/qzip.c.orig
+++ utils/qzip.c
@@ -469,9 +469,8 @@ int makeOutName(const char *in_name, const char *out_name,
* parent directory. */
void mkPath(char *path, const char *dirpath, char *file)
{
- if (strlen(dirpath) + strlen(file) + 1 < MAX_PATH_LEN) {
- snprintf(path, MAX_PATH_LEN, "%s/%s", dirpath, file);
- } else {
+ if (snprintf(path, MAX_PATH_LEN, "%s/%s", dirpath, file) >= MAX_PATH_LEN) {
+ /* truncation occurred */
assert(0);
}
}

View File

@ -0,0 +1,24 @@
--- configure.orig 2022-02-08 17:54:38.857757054 +0100
+++ configure 2022-02-08 18:09:34.392172703 +0100
@@ -142,15 +142,15 @@ includedir=${includedir:-$prefix/include
mandir=${mandir:-$prefix/share/man}
# define CFLAGS and LDFLAGS if no environment variables defined
-if test -z ${CFLAGS}; then
- CFLAGS='-Wall -Werror -std=gnu99 -pedantic -fstack-protector -fPIE -fPIC -fno-strict-overflow -fno-delete-null-pointer-checks -fwrapv'
+if test -z "${CFLAGS}"; then
+ CFLAGS="-Wall -Werror -std=gnu99 -pedantic -fstack-protector-strong -fPIE -fPIC -fno-strict-overflow -fno-delete-null-pointer-checks -fwrapv"
else
- CFLAGS+=" -Wall -Werror -std=gnu99 -pedantic -fstack-protector -fPIE -fPIC"
+ CFLAGS+=" -Wall -Werror -std=gnu99 -pedantic -fstack-protector-strong -fPIE -fPIC"
fi
-if test -z ${LDFLAGS}; then
- LDFLAGS='-fstack-protector -fPIC -pie -z relro -z now -Wl,-z,noexecstack'
+if test -z "${LDFLAGS}"; then
+ LDFLAGS="-fstack-protector-strong -fPIC -pie -z relro -z now -Wl,-z,noexecstack"
else
- LDFLAGS+=" -fstack-protector -fPIC -pie -z relro -z now -Wl,-z,noexecstack"
+ LDFLAGS+=" -fstack-protector-strong -fPIC -pie -z relro -z now -Wl,-z,noexecstack"
fi
# try to build 32 or 64 bit system binary

112
SPECS/qatzip.spec Normal file
View File

@ -0,0 +1,112 @@
# SPDX-License-Identifier: MIT
%global githubname QATzip
%global libqatzip_soversion 1
Name: qatzip
Version: 1.0.7
Release: 1%{?dist}
Summary: Intel QuickAssist Technology (QAT) QATzip Library
License: BSD
URL: https://github.com/intel/%{githubname}
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
BuildRequires: gcc >= 4.8.5
BuildRequires: zlib-devel >= 1.2.7
BuildRequires: qatlib-devel >= 21.08.0
# The purpose of the package is to support hardware that only exists on x86_64 platforms
# https://bugzilla.redhat.com/show_bug.cgi?id=1987280
ExclusiveArch: x86_64
Patch0: 1-fix-snprintf-truncation.patch
Patch1: 2-add-strong-stack-prot.patch
%description
QATzip is a user space library which builds on top of the Intel
QuickAssist Technology user space library, to provide extended
accelerated compression and decompression services by offloading the
actual compression and decompression request(s) to the Intel Chipset
Series. QATzip produces data using the standard gzip* format
(RFC1952) with extended headers. The data can be decompressed with a
compliant gzip* implementation. QATzip is designed to take full
advantage of the performance provided by Intel QuickAssist
Technology.
%package libs
Summary: Libraries for the qatzip package
%description libs
This package contains libraries for applications to use
the QATzip APIs.
%package devel
Summary: Development components for the libqatzip package
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
%description devel
This package contains headers and libraries required to build
applications that use the QATzip APIs.
%prep
%autosetup -p0 -n %{githubname}-%{version}
%build
%set_build_flags
./configure \
--bindir=%{_bindir} \
--sharedlib-dir=%{_libdir} \
--includedir=%{_includedir} \
--mandir=%{_mandir} \
--prefix=%{_prefix} \
--enable-symbol
%make_build
%install
%make_install
rm -vf %{buildroot}%{_mandir}/*.pdf
# Check section is not available for these functional and performance tests require special hardware.
%files
%license LICENSE*
%{_mandir}/man1/qzip.1*
%{_bindir}/qzip
%files libs
%license LICENSE*
%{_libdir}/libqatzip.so.%{libqatzip_soversion}
%{_libdir}/libqatzip.so.%{version}
%files devel
%doc docs/QATzip-man.pdf
%{_includedir}/qatzip.h
%{_libdir}/libqatzip.so
%changelog
* Wed Feb 09 2022 Vladis Dronov <vdronov@redhat.com> - 1.0.7-1
- Rebuild for qatzip v1.0.7
- Fix snprintf truncation check (bz 2046925)
- Add -fstack-protector-strong build option (bz 2044889)
* Wed Oct 20 2021 Vladis Dronov <vdronov@redhat.com> - 1.0.6-5
- Add OSCI testing harness (bz 1874207)
* Mon Sep 13 2021 zm627 <zheng.ma@intel.com> - 1.0.6-3
- Rebuild for qatzip v1.0.6
* Sun Sep 12 2021 zm627 <zheng.ma@intel.com> - 1.0.6-2
- Upload new qatzip source package and rebuild
* Sun Sep 12 2021 zm627 <zheng.ma@intel.com> - 1.0.6-1
- Update to latest qatlib and qatzip upstream release
* Sun Sep 12 2021 zm627 <zheng.ma@intel.com> - 1.0.5-3
- Add ExcludeArch ticket number
* Sun Sep 12 2021 zm627 <zheng.ma@intel.com> - 1.0.5-2
- Rebuilt for qatlib v21.08
* Tue Jul 13 2021 Ma Zheng <zheng.ma@intel.com> - 1.0.5-1
- Initial version of RPM Package