update to 0.24
Conflicts: .gitignore
This commit is contained in:
parent
65b704c5d6
commit
f1ca9d4f38
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,2 @@
|
||||
pyxdg-0.19.tar.gz
|
||||
/pyxdg-0.23.tar.gz
|
||||
/pyxdg-0.24.tar.gz
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up pyxdg-0.16/xdg/DesktopEntry.py.BAD pyxdg-0.16/xdg/DesktopEntry.py
|
||||
--- pyxdg-0.16/xdg/DesktopEntry.py.BAD 2008-10-30 14:22:37.000000000 -0400
|
||||
+++ pyxdg-0.16/xdg/DesktopEntry.py 2008-10-30 14:22:52.000000000 -0400
|
||||
@@ -181,7 +181,7 @@ class DesktopEntry(IniFile):
|
||||
else:
|
||||
#OnlyShowIn and NotShowIn
|
||||
if self.content[group].has_key("OnlyShowIn") and self.content[group].has_key("NotShowIn"):
|
||||
- self.errors.append("Group may either have OnlyShowIn or NotShowIn, but not both")
|
||||
+ self.errors.append("Group may either have OnlyShowIn or NotShowIn, but not both")
|
||||
|
||||
def checkKey(self, key, value, group):
|
||||
# standard keys
|
@ -1,20 +0,0 @@
|
||||
diff -up pyxdg-0.23/xdg/Menu.py.869877 pyxdg-0.23/xdg/Menu.py
|
||||
--- pyxdg-0.23/xdg/Menu.py.869877 2012-07-25 18:59:15.000000000 -0400
|
||||
+++ pyxdg-0.23/xdg/Menu.py 2012-10-26 10:24:26.122225592 -0400
|
||||
@@ -889,8 +889,14 @@ def __mergeLegacyDir(dir, prefix, filena
|
||||
return m
|
||||
|
||||
def __parseKDELegacyDirs(filename, parent):
|
||||
- output = subprocess.check_output(['kde-config', '--path', 'apps'],
|
||||
- universal_newlines=True).splitlines()
|
||||
+ try:
|
||||
+ output = subprocess.check_output(['kde-config', '--path', 'apps'],
|
||||
+ universal_newlines=True).splitlines()
|
||||
+ except OSError:
|
||||
+ # print("Error executing kde-config. Error was ", OSError)
|
||||
+ # Oh well, we tried.
|
||||
+ output = []
|
||||
+
|
||||
try:
|
||||
for dir in output[0].split(":"):
|
||||
__parseLegacyDir(dir,"kde", filename, parent)
|
11
pyxdg.spec
11
pyxdg.spec
@ -5,14 +5,13 @@
|
||||
%endif
|
||||
|
||||
Name: pyxdg
|
||||
Version: 0.23
|
||||
Release: 2%{?dist}
|
||||
Version: 0.24
|
||||
Release: 1%{?dist}
|
||||
Summary: Python library to access freedesktop.org standards
|
||||
Group: Development/Libraries
|
||||
License: LGPLv2
|
||||
URL: http://freedesktop.org/Software/pyxdg
|
||||
Source0: http://www.freedesktop.org/~lanius/%{name}-%{version}.tar.gz
|
||||
Patch0: pyxdg-0.23-gracefully-handle-kde-config-fail.patch
|
||||
Source0: http://people.freedesktop.org/~takluyver/%{name}-%{version}.tar.gz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildArch: noarch
|
||||
# These are needed for the nose tests.
|
||||
@ -37,7 +36,6 @@ package contains a Python 3 version of PyXDG.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .869877
|
||||
|
||||
%if 0%{?with_python3}
|
||||
rm -rf %{py3dir}
|
||||
@ -93,6 +91,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%endif #with_python3
|
||||
|
||||
%changelog
|
||||
* Wed Nov 7 2012 Tomas Bzatek <tbzatek@redhat.com> - 0.24-1
|
||||
- update to 0.24
|
||||
|
||||
* Fri Oct 26 2012 Tom Callaway <spot@fedoraproject.org> - 0.23-2
|
||||
- gracefully handle kde-config fails
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user