Merge branch 'master' of ssh://pkgs.fedoraproject.org/pyxdg

Conflicts:
	.gitignore
	pyxdg.spec
	sources
This commit is contained in:
Tom Callaway 2013-02-28 15:14:18 -05:00
commit e89f0bf41e
4 changed files with 7 additions and 36 deletions

2
.gitignore vendored
View File

@ -1,3 +1 @@
pyxdg-0.19.tar.gz
/pyxdg-0.23.tar.gz
/pyxdg-0.25.tar.gz

View File

@ -1,12 +0,0 @@
diff -up pyxdg-0.16/xdg/DesktopEntry.py.BAD pyxdg-0.16/xdg/DesktopEntry.py
--- pyxdg-0.16/xdg/DesktopEntry.py.BAD 2008-10-30 14:22:37.000000000 -0400
+++ pyxdg-0.16/xdg/DesktopEntry.py 2008-10-30 14:22:52.000000000 -0400
@@ -181,7 +181,7 @@ class DesktopEntry(IniFile):
else:
#OnlyShowIn and NotShowIn
if self.content[group].has_key("OnlyShowIn") and self.content[group].has_key("NotShowIn"):
- self.errors.append("Group may either have OnlyShowIn or NotShowIn, but not both")
+ self.errors.append("Group may either have OnlyShowIn or NotShowIn, but not both")
def checkKey(self, key, value, group):
# standard keys

View File

@ -1,20 +0,0 @@
diff -up pyxdg-0.23/xdg/Menu.py.869877 pyxdg-0.23/xdg/Menu.py
--- pyxdg-0.23/xdg/Menu.py.869877 2012-07-25 18:59:15.000000000 -0400
+++ pyxdg-0.23/xdg/Menu.py 2012-10-26 10:24:26.122225592 -0400
@@ -889,8 +889,14 @@ def __mergeLegacyDir(dir, prefix, filena
return m
def __parseKDELegacyDirs(filename, parent):
- output = subprocess.check_output(['kde-config', '--path', 'apps'],
- universal_newlines=True).splitlines()
+ try:
+ output = subprocess.check_output(['kde-config', '--path', 'apps'],
+ universal_newlines=True).splitlines()
+ except OSError:
+ # print("Error executing kde-config. Error was ", OSError)
+ # Oh well, we tried.
+ output = []
+
try:
for dir in output[0].split(":"):
__parseLegacyDir(dir,"kde", filename, parent)

View File

@ -11,8 +11,7 @@ Summary: Python library to access freedesktop.org standards
Group: Development/Libraries
License: LGPLv2
URL: http://freedesktop.org/Software/pyxdg
Source0: http://www.freedesktop.org/~lanius/%{name}-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: http://people.freedesktop.org/~takluyver/%{name}-%{version}.tar.gz
BuildArch: noarch
# These are needed for the nose tests.
BuildRequires: python-nose, hicolor-icon-theme
@ -94,6 +93,12 @@ rm -rf $RPM_BUILD_ROOT
* Thu Feb 28 2013 Tom Callaway <spot@fedoraproject.org> - 0.25-1
- update to 0.25
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.24-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Wed Nov 7 2012 Tomas Bzatek <tbzatek@redhat.com> - 0.24-1
- update to 0.24
* Fri Oct 26 2012 Tom Callaway <spot@fedoraproject.org> - 0.23-2
- gracefully handle kde-config fails