0.27
This commit is contained in:
parent
c64f23c910
commit
1d002cfce9
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,4 @@
|
|||||||
/pyxdg-0.25.tar.gz
|
/pyxdg-0.25.tar.gz
|
||||||
/pyxdg-0.26.tar.gz
|
/pyxdg-0.26.tar.gz
|
||||||
|
/pyxdg-0.27.tar.gz
|
||||||
|
/pyxdg-test-example.tar.gz
|
||||||
|
@ -1,18 +0,0 @@
|
|||||||
diff -up pyxdg-0.26/xdg/Menu.py.fixOnlyShowIn pyxdg-0.26/xdg/Menu.py
|
|
||||||
--- pyxdg-0.26/xdg/Menu.py.fixOnlyShowIn 2018-11-01 11:34:26.222123436 -0400
|
|
||||||
+++ pyxdg-0.26/xdg/Menu.py 2018-11-01 11:36:39.459203908 -0400
|
|
||||||
@@ -298,11 +298,11 @@ class Menu:
|
|
||||||
entry.Show = NO_EXEC
|
|
||||||
self.Visible -= 1
|
|
||||||
elif xdg.Config.windowmanager:
|
|
||||||
- if (entry.DesktopEntry.OnlyShowIn != [] and (
|
|
||||||
- xdg.Config.windowmanager not in entry.DesktopEntry.OnlyShowIn
|
|
||||||
+ if (entry.DesktopEntry.getOnlyShowIn() != [] and (
|
|
||||||
+ xdg.Config.windowmanager not in entry.DesktopEntry.getOnlyShowIn()
|
|
||||||
)
|
|
||||||
) or (
|
|
||||||
- xdg.Config.windowmanager in entry.DesktopEntry.NotShowIn
|
|
||||||
+ xdg.Config.windowmanager in entry.DesktopEntry.getNotShowIn()
|
|
||||||
):
|
|
||||||
entry.Show = NOT_SHOW_IN
|
|
||||||
self.Visible -= 1
|
|
33
pyxdg.spec
33
pyxdg.spec
@ -1,29 +1,27 @@
|
|||||||
%bcond_without tests
|
|
||||||
|
|
||||||
Name: pyxdg
|
Name: pyxdg
|
||||||
Version: 0.26
|
Version: 0.27
|
||||||
Release: 12%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Python library to access freedesktop.org standards
|
Summary: Python library to access freedesktop.org standards
|
||||||
License: LGPLv2
|
License: LGPLv2
|
||||||
URL: http://freedesktop.org/Software/pyxdg
|
URL: http://freedesktop.org/Software/pyxdg
|
||||||
Source0: https://pypi.python.org/packages/source/r/PyXDG/%{name}-%{version}.tar.gz
|
Source0: %pypi_source
|
||||||
# https://gitlab.freedesktop.org/xdg/pyxdg/merge_requests/2
|
# Upstream did not include the test/examples directory in the source tarball
|
||||||
Patch0: pyxdg-0.26-fix-OnlyShowIn.patch
|
# This tarball is a copy of the directory from https://cgit.freedesktop.org/xdg/pyxdg/
|
||||||
Patch1: pyxdg-0.26-getType-fix.patch
|
Source1: pyxdg-test-example.tar.gz
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
# These are needed for the nose tests.
|
# These are needed for the nose tests.
|
||||||
BuildRequires: hicolor-icon-theme
|
BuildRequires: hicolor-icon-theme
|
||||||
BuildRequires: shared-mime-info
|
BuildRequires: shared-mime-info
|
||||||
|
|
||||||
%description
|
%description
|
||||||
PyXDG is a python library to access freedesktop.org standards
|
PyXDG is a python library to access freedesktop.org standards.
|
||||||
|
|
||||||
%package -n python%{python3_pkgversion}-pyxdg
|
%package -n python%{python3_pkgversion}-pyxdg
|
||||||
Summary: Python3 library to access freedesktop.org standards
|
Summary: Python3 library to access freedesktop.org standards
|
||||||
BuildRequires: python%{python3_pkgversion}-devel
|
BuildRequires: python%{python3_pkgversion}-devel
|
||||||
%if %{with check}
|
%if %{with check}
|
||||||
# These are needed for the nose tests.
|
# These are needed for the nose tests.
|
||||||
BuildRequires: python%{python3_pkgversion}-nose
|
BuildRequires: python%{python3_pkgversion}-nose
|
||||||
%endif
|
%endif
|
||||||
%{?python_provide:%python_provide python%{python3_pkgversion}-pyxdg}
|
%{?python_provide:%python_provide python%{python3_pkgversion}-pyxdg}
|
||||||
|
|
||||||
@ -32,9 +30,7 @@ PyXDG is a python library to access freedesktop.org standards. This
|
|||||||
package contains a Python 3 version of PyXDG.
|
package contains a Python 3 version of PyXDG.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q -a 1
|
||||||
%patch0 -p1 -b .fixOnlyShowIn
|
|
||||||
%patch1 -p1 -b .getType
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%py3_build
|
%py3_build
|
||||||
@ -42,12 +38,10 @@ package contains a Python 3 version of PyXDG.
|
|||||||
%install
|
%install
|
||||||
%py3_install
|
%py3_install
|
||||||
|
|
||||||
%if %{with check}
|
|
||||||
%check
|
%check
|
||||||
# icon-test currently fails
|
# icon-test currently fails
|
||||||
# https://bugs.freedesktop.org/show_bug.cgi?id=104846
|
# https://bugs.freedesktop.org/show_bug.cgi?id=104846
|
||||||
nosetests-%{python3_version} || :
|
nosetests-%{python3_version} || :
|
||||||
%endif
|
|
||||||
|
|
||||||
%files -n python%{python3_pkgversion}-pyxdg
|
%files -n python%{python3_pkgversion}-pyxdg
|
||||||
%license COPYING
|
%license COPYING
|
||||||
@ -56,6 +50,9 @@ nosetests-%{python3_version} || :
|
|||||||
%{python3_sitelib}/pyxdg-*.egg-info
|
%{python3_sitelib}/pyxdg-*.egg-info
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 13 2021 Tom Callaway <spot@fedoraproject.org> - 0.27-1
|
||||||
|
- update to 0.27
|
||||||
|
|
||||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.26-12
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.26-12
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
3
sources
3
sources
@ -1 +1,2 @@
|
|||||||
SHA512 (pyxdg-0.26.tar.gz) = f5306e6e15af07df2599017500fc8ad83e722e5d5c6e4fda014aab1d77df92a3c3199a5be7a889faaecab72861e9910be9d80142d29856eb7a11f6ab9a923bd2
|
SHA512 (pyxdg-0.27.tar.gz) = acb24153a4e3e0d8333f1c965c024b15d44f623497b561fc0e9be60d4411441af1dc61f11dcfb22587a510451237a341440bf7ff77a6ab6446dceb83b3c380e2
|
||||||
|
SHA512 (pyxdg-test-example.tar.gz) = be077b663b5b94c93655d8622db06d3582a81fc4180038e52b45144f9a6c173d4ff5bf450f9ef56b76652f845e0283c527122fdaa84e35f834523ae205c5ab59
|
||||||
|
Loading…
Reference in New Issue
Block a user