diff --git a/00137-skip-distutils-tests-that-fail-in-rpmbuild.patch b/00137-skip-distutils-tests-that-fail-in-rpmbuild.patch
deleted file mode 100644
index 0457093..0000000
--- a/00137-skip-distutils-tests-that-fail-in-rpmbuild.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -up Python-3.2.2/Lib/distutils/tests/test_bdist_rpm.py.skip-distutils-tests-that-fail-in-rpmbuild Python-3.2.2/Lib/distutils/tests/test_bdist_rpm.py
---- Python-3.2.2/Lib/distutils/tests/test_bdist_rpm.py.skip-distutils-tests-that-fail-in-rpmbuild	2011-09-03 12:16:40.000000000 -0400
-+++ Python-3.2.2/Lib/distutils/tests/test_bdist_rpm.py	2011-09-10 05:04:56.328852558 -0400
-@@ -23,6 +23,7 @@ setup(name='foo', version='0.1', py_modu
- 
- """
- 
-+@unittest._skipInRpmBuild("don't try to nest one rpm build inside another rpm build")
- class BuildRpmTestCase(support.TempdirManager,
-                        support.EnvironGuard,
-                        support.LoggingSilencer,
-diff -up Python-3.2.2/Lib/distutils/tests/test_build_ext.py.skip-distutils-tests-that-fail-in-rpmbuild Python-3.2.2/Lib/distutils/tests/test_build_ext.py
diff --git a/python3.spec b/python3.spec
index 0e0277d..30d1b12 100644
--- a/python3.spec
+++ b/python3.spec
@@ -285,10 +285,6 @@ Patch111: 00111-no-static-lib.patch
 # these unittest hooks in their own "check" phases)
 Patch132: 00132-add-rpmbuild-hooks-to-unittest.patch
 
-# 00137 #
-# Some tests within distutils fail when run in an rpmbuild:
-Patch137: 00137-skip-distutils-tests-that-fail-in-rpmbuild.patch
-
 # 00155 #
 # Avoid allocating thunks in ctypes unless absolutely necessary, to avoid
 # generating SELinux denials on "import ctypes" and "import uuid" when
@@ -689,7 +685,6 @@ sed -r -i s/'_PIP_VERSION = "[0-9.]+"'/'_PIP_VERSION = "%{pip_version}"'/ Lib/en
 %endif
 %patch111 -p1
 %patch132 -p1
-%patch137 -p1
 %patch155 -p1
 %patch157 -p1
 %patch160 -p1
@@ -1185,6 +1180,7 @@ CheckPython() {
   LD_LIBRARY_PATH=$ConfDir $ConfDir/python -m test.regrtest \
     -wW --slowest --findleaks \
     -x test_distutils \
+    -x test_bdist_rpm \
     %ifarch ppc64le aarch64
     -x test_faulthandler \
     %endif
@@ -1679,6 +1675,7 @@ fi
 - Rename patch files to be consistent
 - Run autotools to generate the configure script before building
 - Merge lib64 patches (104 into 102)
+- Skip test_bdist_rpm using test config rather than a patch (removes patch 137)
 
 * Mon Aug 28 2017 Michal Cyprian <mcyprian@redhat.com> - 3.6.2-12
 - Use python3 style of calling super() without arguments in rpath