diff --git a/00001-rpath.patch b/00001-rpath.patch
index 19186c7..3819c31 100644
--- a/00001-rpath.patch
+++ b/00001-rpath.patch
@@ -1,4 +1,4 @@
-From 85a385ad599f6232286497b3c67b215b3f388c21 Mon Sep 17 00:00:00 2001
+From 5cca0c5e66319d1e7f431b31b2059593d0d581fd Mon Sep 17 00:00:00 2001
 From: David Malcolm <dmalcolm@redhat.com>
 Date: Wed, 13 Jan 2010 21:25:18 +0000
 Subject: [PATCH] 00001: Fixup distutils/unixccompiler.py to remove standard
@@ -29,5 +29,5 @@ index d10a78da31..4df4b67810 100644
                     include_dirs=None, extra_preargs=None, extra_postargs=None):
          fixed_args = self._fix_compile_args(None, macros, include_dirs)
 -- 
-2.24.1
+2.26.0.rc2
 
diff --git a/00102-lib64.patch b/00102-lib64.patch
deleted file mode 100644
index 815058a..0000000
--- a/00102-lib64.patch
+++ /dev/null
@@ -1,261 +0,0 @@
-From de23a0cc0e2471d12aa82813e4fb6cf937ad1a51 Mon Sep 17 00:00:00 2001
-From: David Malcolm <dmalcolm@redhat.com>
-Date: Wed, 13 Jan 2010 21:25:18 +0000
-Subject: [PATCH] 00102: Change the various install paths to use /usr/lib64/
- instead or /usr/lib/
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Only used when "%{_lib}" == "lib64".
-
-Co-authored-by: David Malcolm <dmalcolm@redhat.com>
-Co-authored-by: Thomas Spura <tomspur@fedoraproject.org>
-Co-authored-by: Slavek Kabrda <bkabrda@redhat.com>
-Co-authored-by: Matej Stuchlik <mstuchli@redhat.com>
-Co-authored-by: Tomas Orsava <torsava@redhat.com>
-Co-authored-by: Charalampos Stratakis <cstratak@redhat.com>
-Co-authored-by: Petr Viktorin <pviktori@redhat.com>
-Co-authored-by: Miro Hrončok <miro@hroncok.cz>
-Co-authored-by: Iryna Shcherbina <shcherbina.iryna@gmail.com>
----
- Lib/distutils/command/install.py    |  4 ++--
- Lib/distutils/sysconfig.py          |  6 +++++-
- Lib/distutils/tests/test_install.py |  3 ++-
- Lib/site.py                         |  4 ++++
- Lib/sysconfig.py                    | 12 ++++++------
- Lib/test/test_site.py               |  4 ++--
- Makefile.pre.in                     |  2 +-
- Modules/getpath.c                   |  6 +++---
- configure                           |  4 ++--
- configure.ac                        |  4 ++--
- setup.py                            |  6 +++---
- 11 files changed, 32 insertions(+), 23 deletions(-)
-
-diff --git a/Lib/distutils/command/install.py b/Lib/distutils/command/install.py
-index c625c95bf7..ae4f915669 100644
---- a/Lib/distutils/command/install.py
-+++ b/Lib/distutils/command/install.py
-@@ -30,14 +30,14 @@ WINDOWS_SCHEME = {
- INSTALL_SCHEMES = {
-     'unix_prefix': {
-         'purelib': '$base/lib/python$py_version_short/site-packages',
--        'platlib': '$platbase/lib/python$py_version_short/site-packages',
-+        'platlib': '$platbase/lib64/python$py_version_short/site-packages',
-         'headers': '$base/include/python$py_version_short$abiflags/$dist_name',
-         'scripts': '$base/bin',
-         'data'   : '$base',
-         },
-     'unix_home': {
-         'purelib': '$base/lib/python',
--        'platlib': '$base/lib/python',
-+        'platlib': '$base/lib64/python',
-         'headers': '$base/include/python/$dist_name',
-         'scripts': '$base/bin',
-         'data'   : '$base',
-diff --git a/Lib/distutils/sysconfig.py b/Lib/distutils/sysconfig.py
-index b51629eb94..9a4892a737 100644
---- a/Lib/distutils/sysconfig.py
-+++ b/Lib/distutils/sysconfig.py
-@@ -146,8 +146,12 @@ def get_python_lib(plat_specific=0, standard_lib=0, prefix=None):
-             prefix = plat_specific and EXEC_PREFIX or PREFIX
- 
-     if os.name == "posix":
-+        if plat_specific or standard_lib:
-+            lib = "lib64"
-+        else:
-+            lib = "lib"
-         libpython = os.path.join(prefix,
--                                 "lib", "python" + get_python_version())
-+                                 lib, "python" + get_python_version())
-         if standard_lib:
-             return libpython
-         else:
-diff --git a/Lib/distutils/tests/test_install.py b/Lib/distutils/tests/test_install.py
-index 287ab1989e..d4c05e0ab1 100644
---- a/Lib/distutils/tests/test_install.py
-+++ b/Lib/distutils/tests/test_install.py
-@@ -57,8 +57,9 @@ class InstallTestCase(support.TempdirManager,
-             self.assertEqual(got, expected)
- 
-         libdir = os.path.join(destination, "lib", "python")
-+        platlibdir = os.path.join(destination, "lib64", "python")
-         check_path(cmd.install_lib, libdir)
--        check_path(cmd.install_platlib, libdir)
-+        check_path(cmd.install_platlib, platlibdir)
-         check_path(cmd.install_purelib, libdir)
-         check_path(cmd.install_headers,
-                    os.path.join(destination, "include", "python", "foopkg"))
-diff --git a/Lib/site.py b/Lib/site.py
-index 2c71798755..653c1d7203 100644
---- a/Lib/site.py
-+++ b/Lib/site.py
-@@ -335,11 +335,15 @@ def getsitepackages(prefixes=None):
-         seen.add(prefix)
- 
-         if os.sep == '/':
-+            sitepackages.append(os.path.join(prefix, "lib64",
-+                                        "python" + sys.version[:3],
-+                                        "site-packages"))
-             sitepackages.append(os.path.join(prefix, "lib",
-                                         "python%d.%d" % sys.version_info[:2],
-                                         "site-packages"))
-         else:
-             sitepackages.append(prefix)
-+            sitepackages.append(os.path.join(prefix, "lib64", "site-packages"))
-             sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
-     return sitepackages
- 
-diff --git a/Lib/sysconfig.py b/Lib/sysconfig.py
-index 64cf1560d9..f66314b203 100644
---- a/Lib/sysconfig.py
-+++ b/Lib/sysconfig.py
-@@ -20,10 +20,10 @@ __all__ = [
- 
- _INSTALL_SCHEMES = {
-     'posix_prefix': {
--        'stdlib': '{installed_base}/lib/python{py_version_short}',
--        'platstdlib': '{platbase}/lib/python{py_version_short}',
-+        'stdlib': '{installed_base}/lib64/python{py_version_short}',
-+        'platstdlib': '{platbase}/lib64/python{py_version_short}',
-         'purelib': '{base}/lib/python{py_version_short}/site-packages',
--        'platlib': '{platbase}/lib/python{py_version_short}/site-packages',
-+        'platlib': '{platbase}/lib64/python{py_version_short}/site-packages',
-         'include':
-             '{installed_base}/include/python{py_version_short}{abiflags}',
-         'platinclude':
-@@ -62,10 +62,10 @@ _INSTALL_SCHEMES = {
-         'data': '{userbase}',
-         },
-     'posix_user': {
--        'stdlib': '{userbase}/lib/python{py_version_short}',
--        'platstdlib': '{userbase}/lib/python{py_version_short}',
-+        'stdlib': '{userbase}/lib64/python{py_version_short}',
-+        'platstdlib': '{userbase}/lib64/python{py_version_short}',
-         'purelib': '{userbase}/lib/python{py_version_short}/site-packages',
--        'platlib': '{userbase}/lib/python{py_version_short}/site-packages',
-+        'platlib': '{userbase}/lib64/python{py_version_short}/site-packages',
-         'include': '{userbase}/include/python{py_version_short}',
-         'scripts': '{userbase}/bin',
-         'data': '{userbase}',
-diff --git a/Lib/test/test_site.py b/Lib/test/test_site.py
-index 41c4229919..543c88432a 100644
---- a/Lib/test/test_site.py
-+++ b/Lib/test/test_site.py
-@@ -266,8 +266,8 @@ class HelperFunctionsTests(unittest.TestCase):
-         dirs = site.getsitepackages()
-         if os.sep == '/':
-             # OS X, Linux, FreeBSD, etc
--            self.assertEqual(len(dirs), 1)
--            wanted = os.path.join('xoxo', 'lib',
-+            self.assertEqual(len(dirs), 2)
-+            wanted = os.path.join('xoxo', 'lib64',
-                                   'python%d.%d' % sys.version_info[:2],
-                                   'site-packages')
-             self.assertEqual(dirs[0], wanted)
-diff --git a/Makefile.pre.in b/Makefile.pre.in
-index 3199a1aa02..8dc55c158f 100644
---- a/Makefile.pre.in
-+++ b/Makefile.pre.in
-@@ -143,7 +143,7 @@ LIBDIR=		@libdir@
- MANDIR=		@mandir@
- INCLUDEDIR=	@includedir@
- CONFINCLUDEDIR=	$(exec_prefix)/include
--SCRIPTDIR=	$(prefix)/lib
-+SCRIPTDIR=	$(prefix)/lib64
- ABIFLAGS=	@ABIFLAGS@
- 
- # Detailed destination directories
-diff --git a/Modules/getpath.c b/Modules/getpath.c
-index 8632d1fe6d..09a818609e 100644
---- a/Modules/getpath.c
-+++ b/Modules/getpath.c
-@@ -810,7 +810,7 @@ calculate_exec_prefix(PyCalculatePath *calculate, _PyPathConfig *pathconfig)
-         }
- 
-         calculate->exec_prefix = joinpath2(calculate->exec_prefix_macro,
--                                           L"lib/lib-dynload");
-+                                           L"lib64/lib-dynload");
-         if (calculate->exec_prefix == NULL) {
-             return _PyStatus_NO_MEMORY();
-         }
-@@ -1284,7 +1284,7 @@ calculate_read_pyenv(PyCalculatePath *calculate)
- static PyStatus
- calculate_zip_path(PyCalculatePath *calculate)
- {
--    const wchar_t *lib_python = L"lib/python00.zip";
-+    const wchar_t *lib_python = L"lib64/python00.zip";
- 
-     if (calculate->prefix_found > 0) {
-         /* Use the reduced prefix returned by Py_GetPrefix()
-@@ -1435,7 +1435,7 @@ calculate_init(PyCalculatePath *calculate, const PyConfig *config)
-         return DECODE_LOCALE_ERR("VPATH macro", len);
-     }
- 
--    calculate->lib_python = Py_DecodeLocale("lib/python" VERSION, &len);
-+    calculate->lib_python = Py_DecodeLocale("lib64/python" VERSION, &len);
-     if (!calculate->lib_python) {
-         return DECODE_LOCALE_ERR("EXEC_PREFIX macro", len);
-     }
-diff --git a/configure b/configure
-index 846116e112..aaadb30ef9 100755
---- a/configure
-+++ b/configure
-@@ -15233,9 +15233,9 @@ fi
- 
- 
- if test x$PLATFORM_TRIPLET = x; then
--  LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
-+  LIBPL='$(prefix)'"/lib64/python${VERSION}/config-${LDVERSION}"
- else
--  LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
-+  LIBPL='$(prefix)'"/lib64/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
- fi
- 
- 
-diff --git a/configure.ac b/configure.ac
-index 840caf352d..ac4a44bdb8 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -4711,9 +4711,9 @@ fi
- dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
- AC_SUBST(PY_ENABLE_SHARED)
- if test x$PLATFORM_TRIPLET = x; then
--  LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
-+  LIBPL='$(prefix)'"/lib64/python${VERSION}/config-${LDVERSION}"
- else
--  LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
-+  LIBPL='$(prefix)'"/lib64/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
- fi
- AC_SUBST(LIBPL)
- 
-diff --git a/setup.py b/setup.py
-index 51e67fe4a5..bafa0bf99a 100644
---- a/setup.py
-+++ b/setup.py
-@@ -649,7 +649,7 @@ class PyBuildExt(build_ext):
-         # directories (i.e. '.' and 'Include') must be first.  See issue
-         # 10520.
-         if not CROSS_COMPILING:
--            add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
-+            add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib64')
-             add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
-         # only change this for cross builds for 3.3, issues on Mageia
-         if CROSS_COMPILING:
-@@ -955,11 +955,11 @@ class PyBuildExt(build_ext):
-             elif curses_library:
-                 readline_libs.append(curses_library)
-             elif self.compiler.find_library_file(self.lib_dirs +
--                                                     ['/usr/lib/termcap'],
-+                                                     ['/usr/lib64/termcap'],
-                                                      'termcap'):
-                 readline_libs.append('termcap')
-             self.add(Extension('readline', ['readline.c'],
--                               library_dirs=['/usr/lib/termcap'],
-+                               library_dirs=['/usr/lib64/termcap'],
-                                extra_link_args=readline_extra_link_args,
-                                libraries=readline_libs))
-         else:
--- 
-2.24.1
-
diff --git a/00111-no-static-lib.patch b/00111-no-static-lib.patch
index ef7946f..39f6df8 100644
--- a/00111-no-static-lib.patch
+++ b/00111-no-static-lib.patch
@@ -1,4 +1,4 @@
-From c58e1db077a3d7502640d2e5863e683b281fcf7b Mon Sep 17 00:00:00 2001
+From d6d13e87c507c77211dbd340b159ca4410849f13 Mon Sep 17 00:00:00 2001
 From: David Malcolm <dmalcolm@redhat.com>
 Date: Mon, 18 Jan 2010 17:59:07 +0000
 Subject: [PATCH] 00111: Don't try to build a libpythonMAJOR.MINOR.a
@@ -21,10 +21,10 @@ Co-authored-by: Miro Hrončok <miro@hroncok.cz>
  1 file changed, 2 insertions(+), 19 deletions(-)
 
 diff --git a/Makefile.pre.in b/Makefile.pre.in
-index 8dc55c158f..e1f021fbab 100644
+index caa1d37648..3178f16000 100644
 --- a/Makefile.pre.in
 +++ b/Makefile.pre.in
-@@ -562,7 +562,7 @@ clinic: check-clean-src $(srcdir)/Modules/_blake2/blake2s_impl.c
+@@ -563,7 +563,7 @@ clinic: check-clean-src $(srcdir)/Modules/_blake2/blake2s_impl.c
  	$(PYTHON_FOR_REGEN) $(srcdir)/Tools/clinic/clinic.py --make --srcdir $(srcdir)
  
  # Build the interpreter
@@ -33,7 +33,7 @@ index 8dc55c158f..e1f021fbab 100644
  	$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
  
  platform: $(BUILDPYTHON) pybuilddir.txt
-@@ -610,12 +610,6 @@ sharedmods: $(BUILDPYTHON) pybuilddir.txt Modules/_math.o
+@@ -611,12 +611,6 @@ sharedmods: $(BUILDPYTHON) pybuilddir.txt Modules/_math.o
  		_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
  		$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
  
@@ -46,7 +46,7 @@ index 8dc55c158f..e1f021fbab 100644
  libpython$(LDVERSION).so: $(LIBRARY_OBJS) $(DTRACE_OBJS)
  	if test $(INSTSONAME) != $(LDLIBRARY); then \
  		$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM); \
-@@ -693,7 +687,7 @@ Makefile Modules/config.c: Makefile.pre \
+@@ -694,7 +688,7 @@ Makefile Modules/config.c: Makefile.pre \
  	@echo "The Makefile was updated, you may need to re-run make."
  
  
@@ -55,7 +55,7 @@ index 8dc55c158f..e1f021fbab 100644
  	$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
  
  ############################################################################
-@@ -1567,17 +1561,6 @@ libainstall:	@DEF_MAKE_RULE@ python-config
+@@ -1570,17 +1564,6 @@ libainstall:	@DEF_MAKE_RULE@ python-config
  		else	true; \
  		fi; \
  	done
@@ -74,5 +74,5 @@ index 8dc55c158f..e1f021fbab 100644
  	$(INSTALL_DATA) Programs/python.o $(DESTDIR)$(LIBPL)/python.o
  	$(INSTALL_DATA) $(srcdir)/Modules/config.c.in $(DESTDIR)$(LIBPL)/config.c.in
 -- 
-2.24.1
+2.26.0.rc2
 
diff --git a/00189-use-rpm-wheels.patch b/00189-use-rpm-wheels.patch
index aaf370e..5b56674 100644
--- a/00189-use-rpm-wheels.patch
+++ b/00189-use-rpm-wheels.patch
@@ -1,4 +1,4 @@
-From 1e8c543d53d2aa0c92381c1e1995a58b57361bef Mon Sep 17 00:00:00 2001
+From 0eb96d45196adaa7dc1362590ae44ddfb175e29c Mon Sep 17 00:00:00 2001
 From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
 Date: Wed, 15 Aug 2018 15:36:29 +0200
 Subject: [PATCH] 00189: Instead of bundled wheels, use our RPM packaged wheels
@@ -9,15 +9,16 @@ We keep them in /usr/share/python-wheels
  1 file changed, 22 insertions(+), 11 deletions(-)
 
 diff --git a/Lib/ensurepip/__init__.py b/Lib/ensurepip/__init__.py
-index 386ed6c25c..dae2ba22e4 100644
+index 545fce656f..f86992c90c 100644
 --- a/Lib/ensurepip/__init__.py
 +++ b/Lib/ensurepip/__init__.py
-@@ -1,19 +1,33 @@
+@@ -1,3 +1,5 @@
 +import distutils.version
 +import glob
  import os
  import os.path
  import sys
+@@ -5,16 +7,28 @@ import runpy
  import tempfile
  from importlib import resources
  
@@ -50,7 +51,7 @@ index 386ed6c25c..dae2ba22e4 100644
  
  _PROJECTS = [
      ("setuptools", _SETUPTOOLS_VERSION),
-@@ -98,13 +112,10 @@ def _bootstrap(*, root=None, upgrade=False, user=False,
+@@ -108,13 +122,10 @@ def _bootstrap(*, root=None, upgrade=False, user=False,
          # additional paths that need added to sys.path
          additional_paths = []
          for project, version in _PROJECTS:
@@ -69,5 +70,5 @@ index 386ed6c25c..dae2ba22e4 100644
              additional_paths.append(os.path.join(tmpdir, wheel_name))
  
 -- 
-2.24.1
+2.26.0.rc2
 
diff --git a/00251-change-user-install-location.patch b/00251-change-user-install-location.patch
index 844f244..3f368c6 100644
--- a/00251-change-user-install-location.patch
+++ b/00251-change-user-install-location.patch
@@ -1,4 +1,4 @@
-From 0d3595ce9f30425aaceaf02c9adb6faa044db18d Mon Sep 17 00:00:00 2001
+From 792ba3f5ca938abfb276b6b938312b6af44619fb Mon Sep 17 00:00:00 2001
 From: Michal Cyprian <m.cyprian@gmail.com>
 Date: Mon, 26 Jun 2017 16:32:56 +0200
 Subject: [PATCH] 00251: Change user install location
@@ -14,10 +14,10 @@ Fedora Change: https://fedoraproject.org/wiki/Changes/Making_sudo_pip_safe
  2 files changed, 21 insertions(+), 3 deletions(-)
 
 diff --git a/Lib/distutils/command/install.py b/Lib/distutils/command/install.py
-index ae4f915669..0e4fd5b74a 100644
+index aaa300efa9..f8d453912a 100644
 --- a/Lib/distutils/command/install.py
 +++ b/Lib/distutils/command/install.py
-@@ -418,8 +418,19 @@ class install(Command):
+@@ -419,8 +419,19 @@ class install(Command):
                      raise DistutilsOptionError(
                            "must not supply exec-prefix without prefix")
  
@@ -40,10 +40,10 @@ index ae4f915669..0e4fd5b74a 100644
              else:
                  if self.exec_prefix is None:
 diff --git a/Lib/site.py b/Lib/site.py
-index 653c1d7203..9098f5762f 100644
+index e981a14208..63e05ff2ad 100644
 --- a/Lib/site.py
 +++ b/Lib/site.py
-@@ -348,7 +348,14 @@ def getsitepackages(prefixes=None):
+@@ -353,7 +353,14 @@ def getsitepackages(prefixes=None):
      return sitepackages
  
  def addsitepackages(known_paths, prefixes=None):
@@ -60,5 +60,5 @@ index 653c1d7203..9098f5762f 100644
          if os.path.isdir(sitedir):
              addsitedir(sitedir, known_paths)
 -- 
-2.24.1
+2.26.0.rc2
 
diff --git a/00274-fix-arch-names.patch b/00274-fix-arch-names.patch
index 692c5ef..0792468 100644
--- a/00274-fix-arch-names.patch
+++ b/00274-fix-arch-names.patch
@@ -1,4 +1,4 @@
-From 1da0d675508c66baafaca8cd811fb9ac7719c998 Mon Sep 17 00:00:00 2001
+From df0b3431e564d5f999086c060f1080b59338877a Mon Sep 17 00:00:00 2001
 From: Petr Viktorin <pviktori@redhat.com>
 Date: Mon, 28 Aug 2017 17:16:46 +0200
 Subject: [PATCH] 00274: Upstream uses Debian-style architecture naming, change
@@ -29,7 +29,7 @@ index ba37cf99e2..52a9ec6662 100755
  	ppc64le | powerpc64little)
  		basic_machine=powerpc64le-unknown
 diff --git a/configure.ac b/configure.ac
-index ac4a44bdb8..504618db12 100644
+index 8eed0151eb..73d3b136a4 100644
 --- a/configure.ac
 +++ b/configure.ac
 @@ -759,9 +759,9 @@ cat >> conftest.c <<EOF
@@ -82,5 +82,5 @@ index ac4a44bdb8..504618db12 100644
          s390x-linux-gnu
  # elif defined(__s390__)
 -- 
-2.24.1
+2.26.0.rc2
 
diff --git a/00328-pyc-timestamp-invalidation-mode.patch b/00328-pyc-timestamp-invalidation-mode.patch
index 7726bb4..a9db568 100644
--- a/00328-pyc-timestamp-invalidation-mode.patch
+++ b/00328-pyc-timestamp-invalidation-mode.patch
@@ -1,4 +1,4 @@
-From 662a4a0ab64b6801a5051b042ddc21224b9cd34e Mon Sep 17 00:00:00 2001
+From 7b5490ad6889846a944f4441eab5007875fcfc9f Mon Sep 17 00:00:00 2001
 From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
 Date: Thu, 11 Jul 2019 13:44:13 +0200
 Subject: [PATCH] 00328: Restore pyc to TIMESTAMP invalidation mode as default
@@ -51,5 +51,5 @@ index d4a68c9320..ed09874023 100644
      return wrapper
  
 -- 
-2.24.1
+2.26.0.rc2
 
diff --git a/python39.spec b/python39.spec
index 7713d35..9eda2fe 100644
--- a/python39.spec
+++ b/python39.spec
@@ -14,7 +14,7 @@ URL: https://www.python.org/
 #  WARNING  When rebasing to a new Python version,
 #           remember to update the python3-docs package as well
 %global general_version %{pybasever}.0
-%global prerel a4
+%global prerel a5
 %global upstream_version %{general_version}%{?prerel}
 Version: %{general_version}%{?prerel:~%{prerel}}
 Release: 1%{?dist}
@@ -232,12 +232,6 @@ Source11: idle3.appdata.xml
 # Was Patch0 in ivazquez' python3000 specfile:
 Patch1:         00001-rpath.patch
 
-# 00102 #
-# Change the various install paths to use /usr/lib64/ instead or /usr/lib
-# Only used when "%%{_lib}" == "lib64"
-# Not yet sent upstream.
-Patch102: 00102-lib64.patch
-
 # 00111 #
 # Patch the Makefile.pre.in so that the generated Makefile doesn't try to build
 # a libpythonMAJOR.MINOR.a
@@ -604,10 +598,6 @@ rm -r Modules/expat
 # Apply patches:
 #
 %patch1 -p1
-
-%if "%{_lib}" == "lib64"
-%patch102 -p1
-%endif
 %patch111 -p1
 
 %if %{with rpmwheels}
@@ -691,6 +681,7 @@ BuildPython() {
   export DFLAGS=" "
 
 %configure \
+  --with-platlibdir=%{_lib} \
   --enable-ipv6 \
   --enable-shared \
   --with-computed-gotos=%{computed_gotos_flag} \
@@ -1575,6 +1566,9 @@ CheckPython optimized
 # ======================================================
 
 %changelog
+* Tue Mar 24 2020 Miro Hrončok <mhroncok@redhat.com> - 3.9.0~a5-1
+- Update to Python 3.9.0a5
+
 * Thu Feb 27 2020 Marcel Plch <mplch@redhat.com> - 3.9.0~a4-1
 - Update to Python 3.9.0a4
 
diff --git a/sources b/sources
index 5f806d8..4fe3c2e 100644
--- a/sources
+++ b/sources
@@ -1,2 +1,2 @@
-SHA512 (Python-3.9.0a4.tar.xz) = 8f7ca0a891fb7e7868dfe5f040e9ceb7ce14d036bc5d9eae1493570c5a9631832e796a1972590c444d2347c585b0c8216345375dd1476b4da7bd47e187591afc
-SHA512 (Python-3.9.0a4.tar.xz.asc) = 67f55246d3cbe46a71aae2328b36452cc9c33191bbcae13abb083e63a7eb923c4db63731add04456c9cb657bf5126137e7047e90de3afdc24dd082d194aa8837
+SHA512 (Python-3.9.0a5.tar.xz) = b2f884a492eeb9fa7347c664bb6fd1dc3c25f663ebb4f9455b66540e12ce8da845c2ad4960999d5475625bc64c834f3cff28f61cd37881bdf53efa349c44bff3
+SHA512 (Python-3.9.0a5.tar.xz.asc) = c3988caedfa183af563a6fddabc16357863834ce2460ce05d7adaa78de76dc08c5bb6d078f10bb4f58775e1d4b5d9168f59319b488638010f6066c2c2a21a211