37 lines
1.5 KiB
Diff
37 lines
1.5 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Karolina Surma <ksurma@redhat.com>
|
|
Date: Thu, 8 Feb 2024 15:53:26 +0100
|
|
Subject: [PATCH] 00418: Don't generate sbom in make regen-all
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
The script and make target, added in Python 3.12.2, assumes a fixed
|
|
location of pip wheel and other bundled libraries, resulting in an
|
|
error and failed build when not found.
|
|
Reported upstream: https://github.com/python/cpython/issues/114240
|
|
and https://github.com/python/cpython/issues/114244
|
|
|
|
Co-Authored-By: Tomáš Hrnčiar <thrnciar@redhat.com>
|
|
---
|
|
Makefile.pre.in | 5 +++--
|
|
1 file changed, 3 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
|
index dd5e69f7ab..40097647b5 100644
|
|
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -1320,9 +1320,10 @@ regen-limited-abi: all
|
|
regen-all: regen-cases regen-opcode regen-opcode-targets regen-typeslots \
|
|
regen-token regen-ast regen-keyword regen-sre regen-frozen \
|
|
regen-pegen-metaparser regen-pegen regen-test-frozenmain \
|
|
- regen-test-levenshtein regen-global-objects regen-sbom
|
|
+ regen-test-levenshtein regen-global-objects
|
|
@echo
|
|
- @echo "Note: make regen-stdlib-module-names and make regen-configure should be run manually"
|
|
+ @echo "Note: make regen-stdlib-module-names, make regen-configure and make regen-sbom "
|
|
+ @echo "should be run manually"
|
|
|
|
############################################################################
|
|
# Special rules for object files
|