7eb10c8dbe
* Sat Aug 21 2010 David Malcolm <dmalcolm@redhat.com> - 3.2-0.0.a1 - 3.2a1; add alphatag - rework %%files in the light of PEP 3147 (__pycache__) - drop our configuration patch to Setup.dist (patch 0): setup.py should do a better job of things, and the %%files explicitly lists our modules (r82746 appears to break the old way of doing things). This leads to various modules changing from "foomodule.so" to "foo.so". It also leads to the optimized build dropping the _sha1, _sha256 and _sha512 modules, but these are provided by _hashlib; _weakref becomes a builtin module; xxsubtype goes away (it's only for testing/devel purposes) - fixup patches 3, 4, 6, 8, 102, 103, 105, 111 for the rebase - remove upstream patches: 7 (system expat), 106, 107, 108 (audioop reformat plus CVE-2010-1634 and CVE-2010-2089), 109 (CVE-2008-5983) - add machinery for rebuilding "configure" and friends, using the correct version of autoconf (patch 300) - patch the debug build's usage of COUNT_ALLOCS to be less verbose (patch 125) - "modulator" was removed upstream - drop "-b" from patch applications affecting .py files to avoid littering the installation tree
21 lines
901 B
Diff
21 lines
901 B
Diff
diff -up Python-2.7/Python/pythonrun.c.less-verbose-COUNT_ALLOCS Python-2.7/Python/pythonrun.c
|
|
--- Python-2.7/Python/pythonrun.c.less-verbose-COUNT_ALLOCS 2010-08-17 14:49:33.321913909 -0400
|
|
+++ Python-2.7/Python/pythonrun.c 2010-08-17 14:54:48.750910403 -0400
|
|
@@ -470,7 +470,15 @@ Py_Finalize(void)
|
|
|
|
/* Debugging stuff */
|
|
#ifdef COUNT_ALLOCS
|
|
- dump_counts(stdout);
|
|
+ /* This is a downstream Fedora modification.
|
|
+ The upstream default with COUNT_ALLOCS is to always dump the counts to
|
|
+ stdout on exit. For our debug builds its useful to have the info from
|
|
+ COUNT_ALLOCS available, but the stdout info here gets in the way, so
|
|
+ we make it optional, wrapping it in an environment variable (modelled
|
|
+ on the other PYTHONDUMP* env variables):
|
|
+ */
|
|
+ if (Py_GETENV("PYTHONDUMPCOUNTS"))
|
|
+ dump_counts(stdout);
|
|
#endif
|
|
|
|
PRINT_TOTAL_REFS();
|