5080ffc5d3
- 3.2b2 - rework patch 3 (removal of mimeaudio tests), patch 6 (no static libs), patch 8 (systemtap), patch 102 (lib64) - remove patch 4 (rendered redundant by upstream r85537), patch 103 (PEP 3149), patch 110 (upstreamed expat fix), patch 111 (parallel build fix for grammar fixed upstream) - regenerate patch 300 (autotool intermediates) - workaround COUNT_ALLOCS weakref issues in test suite (patch 126, patch 127, patch 128) - stop using runtest.sh in %%check (dropped by upstream), replacing with regrtest; fixup list of failing tests - introduce "pyshortver", "SOABI_optimized" and "SOABI_debug" macros - rework manifests of shared libraries to use "SOABI_" macros, reflecting PEP 3149 - drop itertools, operator and _collections modules from the manifests as py3k commit r84058 moved these inside libpython; json/tests moved to test/json_tests - move turtle code into the tkinter subpackage
51 lines
2.0 KiB
Diff
51 lines
2.0 KiB
Diff
diff -up Python-3.2b2/Makefile.pre.in.no-static-lib Python-3.2b2/Makefile.pre.in
|
|
--- Python-3.2b2/Makefile.pre.in.no-static-lib 2010-12-13 13:04:23.000000000 -0500
|
|
+++ Python-3.2b2/Makefile.pre.in 2010-12-28 16:57:11.484065804 -0500
|
|
@@ -420,7 +420,7 @@ coverage:
|
|
|
|
|
|
# Build the interpreter
|
|
-$(BUILDPYTHON): Modules/python.o $(LIBRARY) $(LDLIBRARY)
|
|
+$(BUILDPYTHON): Modules/python.o $(LDLIBRARY)
|
|
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
|
|
|
|
platform: $(BUILDPYTHON)
|
|
@@ -434,18 +434,6 @@ sharedmods: $(BUILDPYTHON)
|
|
*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' ./$(BUILDPYTHON) -E $(srcdir)/setup.py build;; \
|
|
esac
|
|
|
|
-# Build static library
|
|
-# avoid long command lines, same as LIBRARY_OBJS
|
|
-$(LIBRARY): $(LIBRARY_OBJS)
|
|
- -rm -f $@
|
|
- $(AR) $(ARFLAGS) $@ Modules/getbuildinfo.o
|
|
- $(AR) $(ARFLAGS) $@ $(PARSER_OBJS)
|
|
- $(AR) $(ARFLAGS) $@ $(OBJECT_OBJS)
|
|
- $(AR) $(ARFLAGS) $@ $(PYTHON_OBJS)
|
|
- $(AR) $(ARFLAGS) $@ $(MODULE_OBJS) $(SIGNAL_OBJS)
|
|
- $(AR) $(ARFLAGS) $@ $(MODOBJS)
|
|
- $(RANLIB) $@
|
|
-
|
|
libpython$(LDVERSION).so: $(LIBRARY_OBJS)
|
|
if test $(INSTSONAME) != $(LDLIBRARY); then \
|
|
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
|
|
@@ -1035,18 +1023,6 @@ libainstall: all python-config
|
|
else true; \
|
|
fi; \
|
|
done
|
|
- @if test -d $(LIBRARY); then :; else \
|
|
- if test "$(PYTHONFRAMEWORKDIR)" = no-framework; then \
|
|
- if test "$(SO)" = .dll; then \
|
|
- $(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBPL) ; \
|
|
- else \
|
|
- $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
|
|
- $(RANLIB) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
|
|
- fi; \
|
|
- else \
|
|
- echo Skip install of $(LIBRARY) - use make frameworkinstall; \
|
|
- fi; \
|
|
- fi
|
|
$(INSTALL_DATA) Modules/config.c $(DESTDIR)$(LIBPL)/config.c
|
|
$(INSTALL_DATA) Modules/python.o $(DESTDIR)$(LIBPL)/python.o
|
|
$(INSTALL_DATA) $(srcdir)/Modules/config.c.in $(DESTDIR)$(LIBPL)/config.c.in
|