27c558eb66
build commands and the --enable-optimizations flag. Enable profile guided optimizations for x86_64 and i686 architectures
68 lines
2.2 KiB
Diff
68 lines
2.2 KiB
Diff
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
|
index 0e1d0af..42ab191 100644
|
|
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -989,7 +989,7 @@ TESTTIMEOUT= 1200
|
|
|
|
# Run a basic set of regression tests.
|
|
# This excludes some tests that are particularly resource-intensive.
|
|
-test: all platform
|
|
+test: @DEF_MAKE_RULE@ platform
|
|
$(TESTRUNNER) $(TESTOPTS)
|
|
|
|
# Run the full test suite twice - once without .pyc files, and once with.
|
|
@@ -999,7 +999,7 @@ test: all platform
|
|
# the bytecode read from a .pyc file had the bug, sometimes the directly
|
|
# generated bytecode. This is sometimes a very shy bug needing a lot of
|
|
# sample data.
|
|
-testall: all platform
|
|
+testall: @DEF_MAKE_RULE@ platform
|
|
-find $(srcdir)/Lib -name '*.py[co]' -print | xargs rm -f
|
|
$(TESTPYTHON) -E $(srcdir)/Lib/compileall.py
|
|
-find $(srcdir)/Lib -name '*.py[co]' -print | xargs rm -f
|
|
@@ -1008,7 +1008,7 @@ testall: all platform
|
|
|
|
# Run the test suite for both architectures in a Universal build on OSX.
|
|
# Must be run on an Intel box.
|
|
-testuniversal: all platform
|
|
+testuniversal: @DEF_MAKE_RULE@ platform
|
|
if [ `arch` != 'i386' ];then \
|
|
echo "This can only be used on OSX/i386" ;\
|
|
exit 1 ;\
|
|
@@ -1031,7 +1031,7 @@ QUICKTESTOPTS= $(TESTOPTS) -x test_subprocess test_io test_lib2to3 \
|
|
test_multiprocessing_forkserver \
|
|
test_mailbox test_socket test_poll \
|
|
test_select test_zipfile test_concurrent_futures
|
|
-quicktest: all platform
|
|
+quicktest: @DEF_MAKE_RULE@ platform
|
|
$(TESTRUNNER) $(QUICKTESTOPTS)
|
|
|
|
|
|
@@ -1368,7 +1368,7 @@ LIBPL= $(LIBDEST)/config-$(LDVERSION)-$(MULTIARCH)
|
|
# pkgconfig directory
|
|
LIBPC= $(LIBDIR)/pkgconfig
|
|
|
|
-libainstall: all python-config
|
|
+libainstall: @DEF_MAKE_RULE@ python-config
|
|
@for i in $(LIBDIR) $(LIBPL) $(LIBPC); \
|
|
do \
|
|
if test ! -d $(DESTDIR)$$i; then \
|
|
@@ -1616,7 +1616,7 @@ distclean: clobber
|
|
-exec rm -f {} ';'
|
|
|
|
# Check for smelly exported symbols (not starting with Py/_Py)
|
|
-smelly: all
|
|
+smelly: @DEF_MAKE_RULE@
|
|
nm -p $(LIBRARY) | \
|
|
sed -n "/ [TDB] /s/.* //p" | grep -v "^_*Py" | sort -u; \
|
|
|
|
@@ -1653,7 +1653,7 @@ funny:
|
|
-o -print
|
|
|
|
# Perform some verification checks on any modified files.
|
|
-patchcheck: all
|
|
+patchcheck: @DEF_MAKE_RULE@
|
|
$(RUNSHARED) ./$(BUILDPYTHON) $(srcdir)/Tools/scripts/patchcheck.py
|
|
|
|
# Dependencies
|