c969609dfe
- add systemtap static markers (wcohen, mjw, dmalcolm; patch 8), a systemtap tapset defining "python.function.entry" and "python.function.return" to make the markers easy to use (dmalcolm; source 5), and an example of using the tapset to the docs (dmalcolm; source 6) (rhbz:545179)
323 lines
9.5 KiB
Diff
323 lines
9.5 KiB
Diff
diff -up Python-3.1.1/configure.in.systemtap Python-3.1.1/configure.in
|
|
--- Python-3.1.1/configure.in.systemtap 2010-02-12 15:24:34.959845279 -0500
|
|
+++ Python-3.1.1/configure.in 2010-02-12 15:24:34.965845345 -0500
|
|
@@ -2359,6 +2359,38 @@ then
|
|
fi
|
|
AC_MSG_RESULT($with_pymalloc)
|
|
|
|
+# Check for dtrace support
|
|
+AC_MSG_CHECKING(for --with-dtrace)
|
|
+AC_ARG_WITH(dtrace,
|
|
+ AC_HELP_STRING(--with(out)-dtrace, disable/enable dtrace support))
|
|
+
|
|
+if test ! -z "$with_dtrace"
|
|
+then
|
|
+ if dtrace -G -o /dev/null -s $srcdir/Include/pydtrace.d 2>/dev/null
|
|
+ then
|
|
+ AC_DEFINE(WITH_DTRACE, 1,
|
|
+ [Define if you want to compile in Dtrace support])
|
|
+ with_dtrace="Sun"
|
|
+ DTRACEOBJS="Python/dtrace.o"
|
|
+ DTRADEHDRS=""
|
|
+ elif dtrace -h -o /dev/null -s $srcdir/Include/pydtrace.d
|
|
+ then
|
|
+ AC_DEFINE(WITH_DTRACE, 1,
|
|
+ [Define if you want to compile in Dtrace support])
|
|
+ with_dtrace="Apple"
|
|
+ DTRACEOBJS=""
|
|
+ DTRADEHDRS="pydtrace.h"
|
|
+ else
|
|
+ with_dtrace="no"
|
|
+ fi
|
|
+else
|
|
+ with_dtrace="no"
|
|
+fi
|
|
+
|
|
+AC_MSG_RESULT($with_dtrace)
|
|
+AC_SUBST(DTRACEOBJS)
|
|
+AC_SUBST(DTRACEHDRS)
|
|
+
|
|
# Check for --with-wctype-functions
|
|
AC_MSG_CHECKING(for --with-wctype-functions)
|
|
AC_ARG_WITH(wctype-functions,
|
|
diff -up Python-3.1.1/Include/pydtrace.d.systemtap Python-3.1.1/Include/pydtrace.d
|
|
--- Python-3.1.1/Include/pydtrace.d.systemtap 2010-02-12 15:24:34.966844913 -0500
|
|
+++ Python-3.1.1/Include/pydtrace.d 2010-02-12 15:24:34.966844913 -0500
|
|
@@ -0,0 +1,10 @@
|
|
+provider python {
|
|
+ probe function__entry(const char *, const char *, int);
|
|
+ probe function__return(const char *, const char *, int);
|
|
+};
|
|
+
|
|
+#pragma D attributes Evolving/Evolving/Common provider python provider
|
|
+#pragma D attributes Private/Private/Common provider python module
|
|
+#pragma D attributes Private/Private/Common provider python function
|
|
+#pragma D attributes Evolving/Evolving/Common provider python name
|
|
+#pragma D attributes Evolving/Evolving/Common provider python args
|
|
diff -up Python-3.1.1/Makefile.pre.in.systemtap Python-3.1.1/Makefile.pre.in
|
|
--- Python-3.1.1/Makefile.pre.in.systemtap 2010-02-12 15:24:34.953845073 -0500
|
|
+++ Python-3.1.1/Makefile.pre.in 2010-02-12 15:24:34.990844336 -0500
|
|
@@ -312,6 +312,7 @@ PYTHON_OBJS= \
|
|
Python/dtoa.o \
|
|
Python/formatter_unicode.o \
|
|
Python/$(DYNLOADFILE) \
|
|
+ @DTRACEOBJS@ \
|
|
$(LIBOBJS) \
|
|
$(MACHDEP_OBJS) \
|
|
$(THREADOBJ)
|
|
@@ -592,6 +593,18 @@ Python/formatter_unicode.o: $(srcdir)/Py
|
|
$(srcdir)/Objects/stringlib/formatter.h
|
|
|
|
|
|
+# Only needed with --with-dtrace
|
|
+buildinclude:
|
|
+ mkdir -p Include
|
|
+
|
|
+Include/pydtrace.h: buildinclude $(srcdir)/Include/pydtrace.d
|
|
+ dtrace -o $@ $(DFLAGS) -C -h -s $(srcdir)/Include/pydtrace.d
|
|
+
|
|
+Python/ceval.o: Include/pydtrace.h
|
|
+
|
|
+Python/dtrace.o: buildinclude $(srcdir)/Include/pydtrace.d Python/ceval.o
|
|
+ dtrace -o $@ $(DFLAGS) -C -G -s $(srcdir)/Include/pydtrace.d Python/ceval.o
|
|
+
|
|
############################################################################
|
|
# Header files
|
|
|
|
@@ -1224,6 +1237,6 @@ Python/thread.o: @THREADHEADERS@
|
|
.PHONY: frameworkinstall frameworkinstallframework frameworkinstallstructure
|
|
.PHONY: frameworkinstallmaclib frameworkinstallapps frameworkinstallunixtools
|
|
.PHONY: frameworkaltinstallunixtools recheck autoconf clean clobber distclean
|
|
-.PHONY: smelly funny patchcheck
|
|
+.PHONY: smelly funny patchcheck buildinclude
|
|
|
|
# IF YOU PUT ANYTHING HERE IT WILL GO AWAY
|
|
diff -up Python-3.1.1/pyconfig.h.in.systemtap Python-3.1.1/pyconfig.h.in
|
|
--- Python-3.1.1/pyconfig.h.in.systemtap 2009-05-29 13:25:39.000000000 -0400
|
|
+++ Python-3.1.1/pyconfig.h.in 2010-02-12 15:24:34.991845511 -0500
|
|
@@ -5,6 +5,9 @@
|
|
#define Py_PYCONFIG_H
|
|
|
|
|
|
+/* Define if building universal (internal helper macro) */
|
|
+#undef AC_APPLE_UNIVERSAL_BUILD
|
|
+
|
|
/* Define for AIX if your compiler is a genuine IBM xlC/xlC_r and you want
|
|
support for AIX C++ shared extension modules. */
|
|
#undef AIX_GENUINE_CPLUSPLUS
|
|
@@ -995,6 +998,28 @@
|
|
/* Define if you want to use computed gotos in ceval.c. */
|
|
#undef USE_COMPUTED_GOTOS
|
|
|
|
+/* Enable extensions on AIX 3, Interix. */
|
|
+#ifndef _ALL_SOURCE
|
|
+# undef _ALL_SOURCE
|
|
+#endif
|
|
+/* Enable GNU extensions on systems that have them. */
|
|
+#ifndef _GNU_SOURCE
|
|
+# undef _GNU_SOURCE
|
|
+#endif
|
|
+/* Enable threading extensions on Solaris. */
|
|
+#ifndef _POSIX_PTHREAD_SEMANTICS
|
|
+# undef _POSIX_PTHREAD_SEMANTICS
|
|
+#endif
|
|
+/* Enable extensions on HP NonStop. */
|
|
+#ifndef _TANDEM_SOURCE
|
|
+# undef _TANDEM_SOURCE
|
|
+#endif
|
|
+/* Enable general extensions on Solaris. */
|
|
+#ifndef __EXTENSIONS__
|
|
+# undef __EXTENSIONS__
|
|
+#endif
|
|
+
|
|
+
|
|
/* Define if a va_list is an array of some kind */
|
|
#undef VA_LIST_IS_ARRAY
|
|
|
|
@@ -1011,6 +1036,9 @@
|
|
/* Define if you want documentation strings in extension modules */
|
|
#undef WITH_DOC_STRINGS
|
|
|
|
+/* Define if you want to compile in Dtrace support */
|
|
+#undef WITH_DTRACE
|
|
+
|
|
/* Define if you want to use the new-style (Openstep, Rhapsody, MacOS) dynamic
|
|
linker (dyld) instead of the old-style (NextStep) dynamic linker (rld).
|
|
Dyld is necessary to support frameworks. */
|
|
@@ -1032,20 +1060,21 @@
|
|
/* Define to profile with the Pentium timestamp counter */
|
|
#undef WITH_TSC
|
|
|
|
-/* Define to 1 if your processor stores words with the most significant byte
|
|
- first (like Motorola and SPARC, unlike Intel and VAX). */
|
|
-#undef WORDS_BIGENDIAN
|
|
+/* Define WORDS_BIGENDIAN to 1 if your processor stores words with the most
|
|
+ significant byte first (like Motorola and SPARC, unlike Intel). */
|
|
+#if defined AC_APPLE_UNIVERSAL_BUILD
|
|
+# if defined __BIG_ENDIAN__
|
|
+# define WORDS_BIGENDIAN 1
|
|
+# endif
|
|
+#else
|
|
+# ifndef WORDS_BIGENDIAN
|
|
+# undef WORDS_BIGENDIAN
|
|
+# endif
|
|
+#endif
|
|
|
|
/* Define if arithmetic is subject to x87-style double rounding issue */
|
|
#undef X87_DOUBLE_ROUNDING
|
|
|
|
-/* Define to 1 if on AIX 3.
|
|
- System headers sometimes define this.
|
|
- We just want to avoid a redefinition error message. */
|
|
-#ifndef _ALL_SOURCE
|
|
-# undef _ALL_SOURCE
|
|
-#endif
|
|
-
|
|
/* Define on OpenBSD to activate all library features */
|
|
#undef _BSD_SOURCE
|
|
|
|
@@ -1064,15 +1093,25 @@
|
|
/* This must be defined on some systems to enable large file support. */
|
|
#undef _LARGEFILE_SOURCE
|
|
|
|
+/* Define to 1 if on MINIX. */
|
|
+#undef _MINIX
|
|
+
|
|
/* Define on NetBSD to activate all library features */
|
|
#undef _NETBSD_SOURCE
|
|
|
|
/* Define _OSF_SOURCE to get the makedev macro. */
|
|
#undef _OSF_SOURCE
|
|
|
|
+/* Define to 2 if the system does not provide POSIX.1 features except with
|
|
+ this defined. */
|
|
+#undef _POSIX_1_SOURCE
|
|
+
|
|
/* Define to activate features from IEEE Stds 1003.1-2001 */
|
|
#undef _POSIX_C_SOURCE
|
|
|
|
+/* Define to 1 if you need to in order for `stat' and other things to work. */
|
|
+#undef _POSIX_SOURCE
|
|
+
|
|
/* Define if you have POSIX threads, and your system does not define that. */
|
|
#undef _POSIX_THREADS
|
|
|
|
@@ -1080,12 +1119,12 @@
|
|
#undef _REENTRANT
|
|
|
|
/* Define for Solaris 2.5.1 so the uint32_t typedef from <sys/synch.h>,
|
|
- <pthread.h>, or <semaphore.h> is not used. If the typedef was allowed, the
|
|
+ <pthread.h>, or <semaphore.h> is not used. If the typedef were allowed, the
|
|
#define below would cause a syntax error. */
|
|
#undef _UINT32_T
|
|
|
|
/* Define for Solaris 2.5.1 so the uint64_t typedef from <sys/synch.h>,
|
|
- <pthread.h>, or <semaphore.h> is not used. If the typedef was allowed, the
|
|
+ <pthread.h>, or <semaphore.h> is not used. If the typedef were allowed, the
|
|
#define below would cause a syntax error. */
|
|
#undef _UINT64_T
|
|
|
|
diff -up Python-3.1.1/Python/ceval.c.systemtap Python-3.1.1/Python/ceval.c
|
|
--- Python-3.1.1/Python/ceval.c.systemtap 2009-05-30 17:41:10.000000000 -0400
|
|
+++ Python-3.1.1/Python/ceval.c 2010-02-12 15:24:54.075844169 -0500
|
|
@@ -19,6 +19,10 @@
|
|
|
|
#include <ctype.h>
|
|
|
|
+#ifdef WITH_DTRACE
|
|
+#include "pydtrace.h"
|
|
+#endif
|
|
+
|
|
#ifndef WITH_TSC
|
|
|
|
#define READ_TIMESTAMP(var)
|
|
@@ -655,6 +659,69 @@ PyEval_EvalCode(PyCodeObject *co, PyObje
|
|
NULL, NULL);
|
|
}
|
|
|
|
+#ifdef WITH_DTRACE
|
|
+struct frame_marker_info
|
|
+{
|
|
+ char *filename;
|
|
+ char *name;
|
|
+ int lineno;
|
|
+
|
|
+ PyObject *utf8_filename;
|
|
+ PyObject *utf8_name;
|
|
+};
|
|
+
|
|
+static void
|
|
+get_frame_marker_info(PyFrameObject *f, struct frame_marker_info *fmi)
|
|
+{
|
|
+ fmi->utf8_filename = PyUnicode_AsUTF8String(f->f_code->co_filename);
|
|
+ if (fmi->utf8_filename) {
|
|
+ fmi->filename = PyBytes_AsString(fmi->utf8_filename);
|
|
+ } else {
|
|
+ fmi->filename = NULL;
|
|
+ /* FIXME: clear the exception? */
|
|
+ }
|
|
+
|
|
+ fmi->utf8_name = PyUnicode_AsUTF8String(f->f_code->co_name);
|
|
+ if (fmi->utf8_name) {
|
|
+ fmi->name = PyBytes_AsString(fmi->utf8_name);
|
|
+ } else {
|
|
+ fmi->name = NULL;
|
|
+ /* FIXME: clear the exception? */
|
|
+ }
|
|
+
|
|
+ fmi->lineno = PyCode_Addr2Line(f->f_code, f->f_lasti);
|
|
+}
|
|
+
|
|
+static void
|
|
+release_frame_marker_info(struct frame_marker_info *fmi)
|
|
+{
|
|
+ Py_XDECREF(fmi->utf8_filename);
|
|
+ Py_XDECREF(fmi->utf8_name);
|
|
+}
|
|
+
|
|
+static void
|
|
+dtrace_entry(PyFrameObject *f)
|
|
+{
|
|
+ struct frame_marker_info fmi;
|
|
+ get_frame_marker_info(f, &fmi);
|
|
+ PYTHON_FUNCTION_ENTRY(fmi.filename, fmi.name, fmi.lineno);
|
|
+ release_frame_marker_info(&fmi);
|
|
+}
|
|
+
|
|
+static void
|
|
+dtrace_return(PyFrameObject *f)
|
|
+{
|
|
+ struct frame_marker_info fmi;
|
|
+ get_frame_marker_info(f, &fmi);
|
|
+ PYTHON_FUNCTION_RETURN(fmi.filename, fmi.name, fmi.lineno);
|
|
+ release_frame_marker_info(&fmi);
|
|
+}
|
|
+#else
|
|
+#define PYTHON_FUNCTION_ENTRY_ENABLED() 0
|
|
+#define PYTHON_FUNCTION_RETURN_ENABLED() 0
|
|
+#define dtrace_entry(f)
|
|
+#define dtrace_return(f)
|
|
+#endif
|
|
|
|
/* Interpreter main loop */
|
|
|
|
@@ -1061,6 +1128,9 @@ PyEval_EvalFrameEx(PyFrameObject *f, int
|
|
}
|
|
}
|
|
|
|
+ if (PYTHON_FUNCTION_ENTRY_ENABLED())
|
|
+ dtrace_entry(f);
|
|
+
|
|
co = f->f_code;
|
|
names = co->co_names;
|
|
consts = co->co_consts;
|
|
@@ -2907,6 +2977,8 @@ fast_yield:
|
|
|
|
/* pop frame */
|
|
exit_eval_frame:
|
|
+ if (PYTHON_FUNCTION_RETURN_ENABLED())
|
|
+ dtrace_return(f);
|
|
Py_LeaveRecursiveCall();
|
|
tstate->frame = f->f_back;
|
|
|