Remove Patch179 as test_gdb pass on arm without problems
This commit is contained in:
parent
c63af87347
commit
d2c2647ea9
@ -1,48 +0,0 @@
|
|||||||
--- a/Tools/gdb/libpython.py 2013-04-06 03:41:58.000000000 -0400
|
|
||||||
+++ b/Tools/gdb/libpython.py 2013-04-24 03:51:04.720540343 -0400
|
|
||||||
@@ -274,6 +274,9 @@
|
|
||||||
self.tp_name = tp_name
|
|
||||||
self.address = address
|
|
||||||
|
|
||||||
+ def __len__(self):
|
|
||||||
+ return len(repr(self))
|
|
||||||
+
|
|
||||||
def __repr__(self):
|
|
||||||
# For the NULL pointer, we have no way of knowing a type, so
|
|
||||||
# special-case it as per
|
|
||||||
@@ -881,6 +884,8 @@
|
|
||||||
filename = self.filename()
|
|
||||||
try:
|
|
||||||
f = open(os_fsencode(filename), 'r')
|
|
||||||
+ except TypeError: # filename is FakeRepr
|
|
||||||
+ return None
|
|
||||||
except IOError:
|
|
||||||
return None
|
|
||||||
with f:
|
|
||||||
@@ -1523,9 +1528,12 @@
|
|
||||||
|
|
||||||
def print_summary(self):
|
|
||||||
if self.is_evalframeex():
|
|
||||||
- pyop = self.get_pyop()
|
|
||||||
- if pyop:
|
|
||||||
+ try:
|
|
||||||
+ pyop = self.get_pyop()
|
|
||||||
line = pyop.get_truncated_repr(MAX_OUTPUT_LEN)
|
|
||||||
+ except:
|
|
||||||
+ pyop = None
|
|
||||||
+ if pyop:
|
|
||||||
write_unicode(sys.stdout, '#%i %s\n' % (self.get_index(), line))
|
|
||||||
if not pyop.is_optimized_out():
|
|
||||||
line = pyop.current_line()
|
|
||||||
@@ -1542,7 +1550,10 @@
|
|
||||||
|
|
||||||
def print_traceback(self):
|
|
||||||
if self.is_evalframeex():
|
|
||||||
- pyop = self.get_pyop()
|
|
||||||
+ try:
|
|
||||||
+ pyop = self.get_pyop()
|
|
||||||
+ except:
|
|
||||||
+ pyop = None
|
|
||||||
if pyop:
|
|
||||||
pyop.print_traceback()
|
|
||||||
if not pyop.is_optimized_out():
|
|
10
python3.spec
10
python3.spec
@ -337,15 +337,6 @@ Patch170: 00170-gc-assertions.patch
|
|||||||
# Does not affect python2 AFAICS (different sysconfig values initialization)
|
# Does not affect python2 AFAICS (different sysconfig values initialization)
|
||||||
Patch178: 00178-dont-duplicate-flags-in-sysconfig.patch
|
Patch178: 00178-dont-duplicate-flags-in-sysconfig.patch
|
||||||
|
|
||||||
# 00179 #
|
|
||||||
# Workaround for https://bugzilla.redhat.com/show_bug.cgi?id=951802
|
|
||||||
# Reported upstream in http://bugs.python.org/issue17737
|
|
||||||
# This patch basically looks at every frame and if it is somehow corrupted,
|
|
||||||
# it just stops printing the traceback - it doesn't fix the actual bug.
|
|
||||||
# This bug seems to only affect ARM.
|
|
||||||
# Doesn't seem to affect Python 2 AFAICS.
|
|
||||||
Patch179: 00179-dont-raise-error-on-gdb-corrupted-frames-in-backtrace.patch
|
|
||||||
|
|
||||||
# 00180 #
|
# 00180 #
|
||||||
# Enable building on ppc64p7
|
# Enable building on ppc64p7
|
||||||
# Not appropriate for upstream, Fedora-specific naming
|
# Not appropriate for upstream, Fedora-specific naming
|
||||||
@ -644,7 +635,6 @@ sed -r -i s/'_PIP_VERSION = "[0-9.]+"'/'_PIP_VERSION = "%{pip_version}"'/ Lib/en
|
|||||||
%patch163 -p1
|
%patch163 -p1
|
||||||
%patch170 -p0
|
%patch170 -p0
|
||||||
%patch178 -p1
|
%patch178 -p1
|
||||||
%patch179 -p1
|
|
||||||
%patch180 -p1
|
%patch180 -p1
|
||||||
%patch184 -p1
|
%patch184 -p1
|
||||||
%patch186 -p1
|
%patch186 -p1
|
||||||
|
Loading…
Reference in New Issue
Block a user