Remove unused patches
This commit is contained in:
parent
f13050e2f3
commit
a94422417a
@ -1,12 +0,0 @@
|
||||
--- Python-3.3.2/setup.py.orig 2013-07-01 15:23:24.377711044 +0200
|
||||
+++ Python-3.3.2/setup.py 2013-07-01 15:23:34.094676496 +0200
|
||||
@@ -1882,7 +1882,8 @@
|
||||
if not line:
|
||||
ffi_inc = None
|
||||
break
|
||||
- if line.startswith('#define LIBFFI_H'):
|
||||
+ if line.startswith('#define LIBFFI_H') or \
|
||||
+ line.startswith('#define ffi_wrapper_h'):
|
||||
break
|
||||
ffi_lib = None
|
||||
if ffi_inc is not None:
|
@ -1,30 +0,0 @@
|
||||
Subject: python3.test gdb match addr before builtin
|
||||
From: Michel Normand <normand@linux.vnet.ibm.com>
|
||||
|
||||
For ppc64le archi and python3... and gdb... versions
|
||||
the test_gdb.py need a change of re.match to handle address before the builtin_id word.
|
||||
Of course there is no error if this substring is not present.
|
||||
===
|
||||
...
|
||||
#0 0x00003fffb7dd0898 in builtin_id (self=<module at remote 0x3fffb7901440>, v=<unknown at remote 0x3fffb7f68910>) at /builddir/build/BUILD/Python-3.3.2/Python/bltinmodule.c:966
|
||||
....xxxxxxxxxxxxxxxxxxxxxx <= added regexp
|
||||
===
|
||||
|
||||
Signed-off-by: Michel Normand <normand@linux.vnet.ibm.com>
|
||||
---
|
||||
Lib/test/test_gdb.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
Index: Python-3.3.2/Lib/test/test_gdb.py
|
||||
===================================================================
|
||||
--- Python-3.3.2.orig/Lib/test/test_gdb.py
|
||||
+++ Python-3.3.2/Lib/test/test_gdb.py
|
||||
@@ -230,7 +230,7 @@ class DebuggerTests(unittest.TestCase):
|
||||
# gdb can insert additional '\n' and space characters in various places
|
||||
# in its output, depending on the width of the terminal it's connected
|
||||
# to (using its "wrap_here" function)
|
||||
- m = re.match('.*#0\s+builtin_id\s+\(self\=.*,\s+v=\s*(.*?)\)\s+at\s+\S*Python/bltinmodule.c.*',
|
||||
+ m = re.match('.*#0\s+(?: 0x[0-9a-f]+\s+in\s+)?builtin_id\s+\(self\=.*,\s+v=\s*(.*?)\)\s+at\s+\S*Python/bltinmodule.c.*',
|
||||
gdb_output, re.DOTALL)
|
||||
if not m:
|
||||
self.fail('Unexpected gdb output: %r\n%s' % (gdb_output, gdb_output))
|
@ -1,12 +0,0 @@
|
||||
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
||||
index 28df0e1..42f811c 100644
|
||||
--- a/Makefile.pre.in
|
||||
+++ b/Makefile.pre.in
|
||||
@@ -867,6 +867,7 @@ Python/frozen.o: Python/importlib.h Python/importlib_external.h
|
||||
# follow our naming conventions. dtrace(1) uses the output filename to generate
|
||||
# an include guard, so we can't use a pipeline to transform its output.
|
||||
Include/pydtrace_probes.h: $(srcdir)/Include/pydtrace.d
|
||||
+ @$(MKDIR_P) Include
|
||||
$(DTRACE) $(DFLAGS) -o $@ -h -s $<
|
||||
: sed in-place edit with POSIX-only tools
|
||||
sed 's/PYTHON_/PyDTrace_/' $@ > $@.tmp
|
@ -1,12 +0,0 @@
|
||||
diff --git a/Lib/test/test_socket.py b/Lib/test/test_socket.py
|
||||
index 8992a01..74170f4 100644
|
||||
--- a/Lib/test/test_socket.py
|
||||
+++ b/Lib/test/test_socket.py
|
||||
@@ -5458,6 +5458,7 @@ class LinuxKernelCryptoAPI(unittest.TestCase):
|
||||
self.assertEqual(dec, msg * multiplier)
|
||||
|
||||
@support.requires_linux_version(4, 3) # see test_aes_cbc
|
||||
+ @unittest.skip('Failure on Kernel 4.9+')
|
||||
def test_aead_aes_gcm(self):
|
||||
key = bytes.fromhex('c939cc13397c1d37de6ae0e1cb7c423c')
|
||||
iv = bytes.fromhex('b3d8cc017cbb89b39e0f67e2')
|
@ -1,104 +0,0 @@
|
||||
diff --git a/Lib/test/test_capi.py b/Lib/test/test_capi.py
|
||||
index 6c3625d..2a53f3d 100644
|
||||
--- a/Lib/test/test_capi.py
|
||||
+++ b/Lib/test/test_capi.py
|
||||
@@ -385,7 +385,7 @@ class EmbeddingTests(unittest.TestCase):
|
||||
|
||||
def test_subinterps(self):
|
||||
# This is just a "don't crash" test
|
||||
- out, err = self.run_embedded_interpreter()
|
||||
+ out, err = self.run_embedded_interpreter("repeated_init_and_subinterpreters")
|
||||
if support.verbose:
|
||||
print()
|
||||
print(out)
|
||||
diff --git a/Programs/_testembed.c b/Programs/_testembed.c
|
||||
index 3968399..a68d4fa 100644
|
||||
--- a/Programs/_testembed.c
|
||||
+++ b/Programs/_testembed.c
|
||||
@@ -33,7 +33,7 @@ static void print_subinterp(void)
|
||||
);
|
||||
}
|
||||
|
||||
-static void test_repeated_init_and_subinterpreters(void)
|
||||
+static int test_repeated_init_and_subinterpreters(void)
|
||||
{
|
||||
PyThreadState *mainstate, *substate;
|
||||
#ifdef WITH_THREAD
|
||||
@@ -70,6 +70,7 @@ static void test_repeated_init_and_subinterpreters(void)
|
||||
PyEval_RestoreThread(mainstate);
|
||||
Py_Finalize();
|
||||
}
|
||||
+ return 0;
|
||||
}
|
||||
|
||||
/*****************************************************
|
||||
@@ -103,7 +104,7 @@ static void check_stdio_details(const char *encoding, const char * errors)
|
||||
Py_Finalize();
|
||||
}
|
||||
|
||||
-static void test_forced_io_encoding(void)
|
||||
+static int test_forced_io_encoding(void)
|
||||
{
|
||||
/* Check various combinations */
|
||||
printf("--- Use defaults ---\n");
|
||||
@@ -122,19 +123,51 @@ static void test_forced_io_encoding(void)
|
||||
printf("Unexpected success calling Py_SetStandardStreamEncoding");
|
||||
}
|
||||
Py_Finalize();
|
||||
+ return 0;
|
||||
}
|
||||
|
||||
-/* Different embedding tests */
|
||||
-int main(int argc, char *argv[])
|
||||
+/* *********************************************************
|
||||
+ * List of test cases and the function that implements it.
|
||||
+ *
|
||||
+ * Names are compared case-sensitively with the first
|
||||
+ * argument. If no match is found, or no first argument was
|
||||
+ * provided, the names of all test cases are printed and
|
||||
+ * the exit code will be -1.
|
||||
+ *
|
||||
+ * The int returned from test functions is used as the exit
|
||||
+ * code, and test_capi treats all non-zero exit codes as a
|
||||
+ * failed test.
|
||||
+ *********************************************************/
|
||||
+struct TestCase
|
||||
{
|
||||
+ const char *name;
|
||||
+ int (*func)(void);
|
||||
+};
|
||||
+
|
||||
+static struct TestCase TestCases[] = {
|
||||
+ { "forced_io_encoding", test_forced_io_encoding },
|
||||
+ { "repeated_init_and_subinterpreters", test_repeated_init_and_subinterpreters },
|
||||
+ { NULL, NULL }
|
||||
+};
|
||||
|
||||
- /* TODO: Check the argument string to allow for more test cases */
|
||||
+int main(int argc, char *argv[])
|
||||
+{
|
||||
if (argc > 1) {
|
||||
- /* For now: assume "forced_io_encoding */
|
||||
- test_forced_io_encoding();
|
||||
- } else {
|
||||
- /* Run the original embedding test case by default */
|
||||
- test_repeated_init_and_subinterpreters();
|
||||
+ for (struct TestCase *tc = TestCases; tc && tc->name; tc++) {
|
||||
+ if (strcmp(argv[1], tc->name) == 0)
|
||||
+ return (*tc->func)();
|
||||
+ }
|
||||
}
|
||||
- return 0;
|
||||
+
|
||||
+ /* No match found, or no test name provided, so display usage */
|
||||
+ printf("Python " PY_VERSION " _testembed executable for embedded interpreter tests\n"
|
||||
+ "Normally executed via 'EmbeddingTests' in Lib/test/test_capi.py\n\n"
|
||||
+ "Usage: %s TESTNAME\n\nAll available tests:\n", argv[0]);
|
||||
+ for (struct TestCase *tc = TestCases; tc && tc->name; tc++) {
|
||||
+ printf(" %s\n", tc->name);
|
||||
+ }
|
||||
+
|
||||
+ /* Non-zero exit code will cause test_capi.py tests to fail.
|
||||
+ This is intentional. */
|
||||
+ return -1;
|
||||
}
|
@ -1,67 +0,0 @@
|
||||
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
||||
index 0e1d0af..42ab191 100644
|
||||
--- a/Makefile.pre.in
|
||||
+++ b/Makefile.pre.in
|
||||
@@ -989,7 +989,7 @@ TESTTIMEOUT= 1200
|
||||
|
||||
# Run a basic set of regression tests.
|
||||
# This excludes some tests that are particularly resource-intensive.
|
||||
-test: all platform
|
||||
+test: @DEF_MAKE_RULE@ platform
|
||||
$(TESTRUNNER) $(TESTOPTS)
|
||||
|
||||
# Run the full test suite twice - once without .pyc files, and once with.
|
||||
@@ -999,7 +999,7 @@ test: all platform
|
||||
# the bytecode read from a .pyc file had the bug, sometimes the directly
|
||||
# generated bytecode. This is sometimes a very shy bug needing a lot of
|
||||
# sample data.
|
||||
-testall: all platform
|
||||
+testall: @DEF_MAKE_RULE@ platform
|
||||
-find $(srcdir)/Lib -name '*.py[co]' -print | xargs rm -f
|
||||
$(TESTPYTHON) -E $(srcdir)/Lib/compileall.py
|
||||
-find $(srcdir)/Lib -name '*.py[co]' -print | xargs rm -f
|
||||
@@ -1008,7 +1008,7 @@ testall: all platform
|
||||
|
||||
# Run the test suite for both architectures in a Universal build on OSX.
|
||||
# Must be run on an Intel box.
|
||||
-testuniversal: all platform
|
||||
+testuniversal: @DEF_MAKE_RULE@ platform
|
||||
if [ `arch` != 'i386' ];then \
|
||||
echo "This can only be used on OSX/i386" ;\
|
||||
exit 1 ;\
|
||||
@@ -1031,7 +1031,7 @@ QUICKTESTOPTS= $(TESTOPTS) -x test_subprocess test_io test_lib2to3 \
|
||||
test_multiprocessing_forkserver \
|
||||
test_mailbox test_socket test_poll \
|
||||
test_select test_zipfile test_concurrent_futures
|
||||
-quicktest: all platform
|
||||
+quicktest: @DEF_MAKE_RULE@ platform
|
||||
$(TESTRUNNER) $(QUICKTESTOPTS)
|
||||
|
||||
|
||||
@@ -1368,7 +1368,7 @@ LIBPL= $(LIBDEST)/config-$(LDVERSION)-$(MULTIARCH)
|
||||
# pkgconfig directory
|
||||
LIBPC= $(LIBDIR)/pkgconfig
|
||||
|
||||
-libainstall: all python-config
|
||||
+libainstall: @DEF_MAKE_RULE@ python-config
|
||||
@for i in $(LIBDIR) $(LIBPL) $(LIBPC); \
|
||||
do \
|
||||
if test ! -d $(DESTDIR)$$i; then \
|
||||
@@ -1616,7 +1616,7 @@ distclean: clobber
|
||||
-exec rm -f {} ';'
|
||||
|
||||
# Check for smelly exported symbols (not starting with Py/_Py)
|
||||
-smelly: all
|
||||
+smelly: @DEF_MAKE_RULE@
|
||||
nm -p $(LIBRARY) | \
|
||||
sed -n "/ [TDB] /s/.* //p" | grep -v "^_*Py" | sort -u; \
|
||||
|
||||
@@ -1653,7 +1653,7 @@ funny:
|
||||
-o -print
|
||||
|
||||
# Perform some verification checks on any modified files.
|
||||
-patchcheck: all
|
||||
+patchcheck: @DEF_MAKE_RULE@
|
||||
$(RUNSHARED) ./$(BUILDPYTHON) $(srcdir)/Tools/scripts/patchcheck.py
|
||||
|
||||
# Dependencies
|
@ -1,25 +0,0 @@
|
||||
diff -up Python-3.4.0/Lib/test/test_asyncio/test_events.py.orig Python-3.4.0/Lib/test/test_asyncio/test_events.py
|
||||
--- Python-3.4.0/Lib/test/test_asyncio/test_events.py.orig 2014-04-15 13:18:49.696215288 +0200
|
||||
+++ Python-3.4.0/Lib/test/test_asyncio/test_events.py 2014-04-15 13:18:56.104258453 +0200
|
||||
@@ -1528,7 +1528,7 @@ class SubprocessTestsMixin:
|
||||
self.check_terminated(proto.returncode)
|
||||
transp.close()
|
||||
|
||||
- @unittest.skipIf(sys.platform == 'win32', "Don't have SIGHUP")
|
||||
+ @unittest.skipIf(True, "Temporarily skipped (rhbz#1088233)")
|
||||
def test_subprocess_send_signal(self):
|
||||
prog = os.path.join(os.path.dirname(__file__), 'echo.py')
|
||||
|
||||
|
||||
diff -up Python-3.4.0/Lib/test/test_asyncio/test_subprocess.py.orig Python-3.4.0/Lib/test/test_asyncio/test_subprocess.py
|
||||
--- Python-3.4.0/Lib/test/test_asyncio/test_subprocess.py.orig 2014-04-17 12:03:32.777827520 +0200
|
||||
+++ Python-3.4.0/Lib/test/test_asyncio/test_subprocess.py 2014-04-17 12:04:37.614210481 +0200
|
||||
@@ -108,7 +108,7 @@ class SubprocessMixin:
|
||||
else:
|
||||
self.assertEqual(-signal.SIGTERM, returncode)
|
||||
|
||||
- @unittest.skipIf(sys.platform == 'win32', "Don't have SIGHUP")
|
||||
+ @unittest.skipIf(True, "Temporarily skipped (rhbz#1088233)")
|
||||
def test_send_signal(self):
|
||||
code = 'import time; print("sleeping", flush=True); time.sleep(3600)'
|
||||
args = [sys.executable, '-c', code]
|
Loading…
Reference in New Issue
Block a user