Remove patch150 as the issue was already fixed rhbz#1318565
This commit is contained in:
parent
f2e5fa9a56
commit
83d6e884b3
@ -1,11 +0,0 @@
|
||||
diff -up Python-3.2.2/Lib/test/test_cmath.py.ppc Python-3.2.2/Lib/test/test_cmath.py
|
||||
--- Python-3.2.2/Lib/test/test_cmath.py.ppc 2011-12-07 23:43:55.000000000 +0100
|
||||
+++ Python-3.2.2/Lib/test/test_cmath.py 2011-12-07 23:49:44.000000000 +0100
|
||||
@@ -95,6 +95,7 @@ class CMathTests(unittest.TestCase):
|
||||
self.assertFloatIdentical(x.real, y.real)
|
||||
self.assertFloatIdentical(x.imag, y.imag)
|
||||
|
||||
+ @unittest.skip('Known failure on PPC: glibc bug https://bugzilla.redhat.com/show_bug.cgi?id=750811')
|
||||
def rAssertAlmostEqual(self, a, b, rel_err = 2e-15, abs_err = 5e-323,
|
||||
msg=None):
|
||||
"""Fail if the two floating-point numbers are not almost equal.
|
10
python3.spec
10
python3.spec
@ -292,13 +292,6 @@ Patch143: 00143-tsc-on-ppc.patch
|
||||
# implementation and OpenSSL still doesn't support it. For now, they're harmless.
|
||||
Patch146: 00146-hashlib-fips.patch
|
||||
|
||||
# 00150 #
|
||||
# temporarily disable rAssertAlmostEqual in test_cmath on PPC (bz #750811)
|
||||
# caused by a glibc bug. This patch can be removed when we have a glibc with
|
||||
# the patch mentioned here:
|
||||
# http://sourceware.org/bugzilla/show_bug.cgi?id=13472
|
||||
Patch150: 00150-disable-rAssertAlmostEqual-cmath-on-ppc.patch
|
||||
|
||||
# 00155 #
|
||||
# Avoid allocating thunks in ctypes unless absolutely necessary, to avoid
|
||||
# generating SELinux denials on "import ctypes" and "import uuid" when
|
||||
@ -668,9 +661,6 @@ sed -r -i s/'_PIP_VERSION = "[0-9.]+"'/'_PIP_VERSION = "%{pip_version}"'/ Lib/en
|
||||
%endif
|
||||
%patch143 -p1 -b .tsc-on-ppc
|
||||
%patch146 -p1
|
||||
%ifarch ppc %{power64}
|
||||
%patch150 -p1
|
||||
%endif
|
||||
%patch155 -p1
|
||||
%patch157 -p1
|
||||
%patch160 -p1
|
||||
|
Loading…
Reference in New Issue
Block a user