3.3.0-0.5.rc2
3.3.0rc1 -> 3.3.0rc2; refresh patch 55
This commit is contained in:
parent
92d712a0d8
commit
78727dec4a
@ -1,6 +1,6 @@
|
|||||||
diff -up Python-3.3.0rc1/configure.ac.systemtap Python-3.3.0rc1/configure.ac
|
diff -up Python-3.3.0rc2/configure.ac.systemtap Python-3.3.0rc2/configure.ac
|
||||||
--- Python-3.3.0rc1/configure.ac.systemtap 2012-08-25 15:22:13.000000000 -0400
|
--- Python-3.3.0rc2/configure.ac.systemtap 2012-09-09 05:11:14.000000000 -0400
|
||||||
+++ Python-3.3.0rc1/configure.ac 2012-08-27 11:00:36.593962900 -0400
|
+++ Python-3.3.0rc2/configure.ac 2012-09-10 09:17:21.114511781 -0400
|
||||||
@@ -2678,6 +2678,23 @@ if test "$with_valgrind" != no; then
|
@@ -2678,6 +2678,23 @@ if test "$with_valgrind" != no; then
|
||||||
OPT="-DDYNAMIC_ANNOTATIONS_ENABLED=1 $OPT"
|
OPT="-DDYNAMIC_ANNOTATIONS_ENABLED=1 $OPT"
|
||||||
fi
|
fi
|
||||||
@ -25,9 +25,9 @@ diff -up Python-3.3.0rc1/configure.ac.systemtap Python-3.3.0rc1/configure.ac
|
|||||||
# -I${DLINCLDIR} is added to the compile rule for importdl.o
|
# -I${DLINCLDIR} is added to the compile rule for importdl.o
|
||||||
AC_SUBST(DLINCLDIR)
|
AC_SUBST(DLINCLDIR)
|
||||||
DLINCLDIR=.
|
DLINCLDIR=.
|
||||||
diff -up Python-3.3.0rc1/configure.systemtap Python-3.3.0rc1/configure
|
diff -up Python-3.3.0rc2/configure.systemtap Python-3.3.0rc2/configure
|
||||||
--- Python-3.3.0rc1/configure.systemtap 2012-08-25 15:22:13.000000000 -0400
|
--- Python-3.3.0rc2/configure.systemtap 2012-09-09 05:11:14.000000000 -0400
|
||||||
+++ Python-3.3.0rc1/configure 2012-08-27 11:00:36.595962898 -0400
|
+++ Python-3.3.0rc2/configure 2012-09-10 09:17:21.116511780 -0400
|
||||||
@@ -618,6 +618,8 @@ TRUE
|
@@ -618,6 +618,8 @@ TRUE
|
||||||
MACHDEP_OBJS
|
MACHDEP_OBJS
|
||||||
DYNLOADFILE
|
DYNLOADFILE
|
||||||
@ -85,18 +85,18 @@ diff -up Python-3.3.0rc1/configure.systemtap Python-3.3.0rc1/configure
|
|||||||
# -I${DLINCLDIR} is added to the compile rule for importdl.o
|
# -I${DLINCLDIR} is added to the compile rule for importdl.o
|
||||||
|
|
||||||
DLINCLDIR=.
|
DLINCLDIR=.
|
||||||
diff -up Python-3.3.0rc1/Doc/howto/index.rst.systemtap Python-3.3.0rc1/Doc/howto/index.rst
|
diff -up Python-3.3.0rc2/Doc/howto/index.rst.systemtap Python-3.3.0rc2/Doc/howto/index.rst
|
||||||
--- Python-3.3.0rc1/Doc/howto/index.rst.systemtap 2012-08-25 15:22:08.000000000 -0400
|
--- Python-3.3.0rc2/Doc/howto/index.rst.systemtap 2012-09-09 05:10:51.000000000 -0400
|
||||||
+++ Python-3.3.0rc1/Doc/howto/index.rst 2012-08-27 11:00:36.596962898 -0400
|
+++ Python-3.3.0rc2/Doc/howto/index.rst 2012-09-10 09:17:21.117511779 -0400
|
||||||
@@ -29,4 +29,5 @@ Currently, the HOWTOs are:
|
@@ -29,4 +29,5 @@ Currently, the HOWTOs are:
|
||||||
webservers.rst
|
webservers.rst
|
||||||
argparse.rst
|
argparse.rst
|
||||||
ipaddress.rst
|
ipaddress.rst
|
||||||
+ instrumentation.rst
|
+ instrumentation.rst
|
||||||
|
|
||||||
diff -up Python-3.3.0rc1/Doc/howto/instrumentation.rst.systemtap Python-3.3.0rc1/Doc/howto/instrumentation.rst
|
diff -up Python-3.3.0rc2/Doc/howto/instrumentation.rst.systemtap Python-3.3.0rc2/Doc/howto/instrumentation.rst
|
||||||
--- Python-3.3.0rc1/Doc/howto/instrumentation.rst.systemtap 2012-08-27 11:00:36.596962898 -0400
|
--- Python-3.3.0rc2/Doc/howto/instrumentation.rst.systemtap 2012-09-10 09:17:21.117511779 -0400
|
||||||
+++ Python-3.3.0rc1/Doc/howto/instrumentation.rst 2012-08-27 11:00:36.596962898 -0400
|
+++ Python-3.3.0rc2/Doc/howto/instrumentation.rst 2012-09-10 09:17:21.117511779 -0400
|
||||||
@@ -0,0 +1,295 @@
|
@@ -0,0 +1,295 @@
|
||||||
+.. _instrumentation:
|
+.. _instrumentation:
|
||||||
+
|
+
|
||||||
@ -393,9 +393,9 @@ diff -up Python-3.3.0rc1/Doc/howto/instrumentation.rst.systemtap Python-3.3.0rc1
|
|||||||
+ delete fn_calls;
|
+ delete fn_calls;
|
||||||
+ }
|
+ }
|
||||||
+
|
+
|
||||||
diff -up Python-3.3.0rc1/Lib/test/test_systemtap.py.systemtap Python-3.3.0rc1/Lib/test/test_systemtap.py
|
diff -up Python-3.3.0rc2/Lib/test/test_systemtap.py.systemtap Python-3.3.0rc2/Lib/test/test_systemtap.py
|
||||||
--- Python-3.3.0rc1/Lib/test/test_systemtap.py.systemtap 2012-08-27 11:00:36.596962898 -0400
|
--- Python-3.3.0rc2/Lib/test/test_systemtap.py.systemtap 2012-09-10 09:17:21.117511779 -0400
|
||||||
+++ Python-3.3.0rc1/Lib/test/test_systemtap.py 2012-08-27 11:00:36.596962898 -0400
|
+++ Python-3.3.0rc2/Lib/test/test_systemtap.py 2012-09-10 09:17:21.117511779 -0400
|
||||||
@@ -0,0 +1,234 @@
|
@@ -0,0 +1,234 @@
|
||||||
+# Verify that systemtap static probes work
|
+# Verify that systemtap static probes work
|
||||||
+#
|
+#
|
||||||
@ -631,9 +631,9 @@ diff -up Python-3.3.0rc1/Lib/test/test_systemtap.py.systemtap Python-3.3.0rc1/Li
|
|||||||
+
|
+
|
||||||
+if __name__ == "__main__":
|
+if __name__ == "__main__":
|
||||||
+ test_main()
|
+ test_main()
|
||||||
diff -up Python-3.3.0rc1/Makefile.pre.in.systemtap Python-3.3.0rc1/Makefile.pre.in
|
diff -up Python-3.3.0rc2/Makefile.pre.in.systemtap Python-3.3.0rc2/Makefile.pre.in
|
||||||
--- Python-3.3.0rc1/Makefile.pre.in.systemtap 2012-08-25 15:22:11.000000000 -0400
|
--- Python-3.3.0rc2/Makefile.pre.in.systemtap 2012-09-09 05:11:05.000000000 -0400
|
||||||
+++ Python-3.3.0rc1/Makefile.pre.in 2012-08-27 11:08:51.950929030 -0400
|
+++ Python-3.3.0rc2/Makefile.pre.in 2012-09-10 09:19:51.195501518 -0400
|
||||||
@@ -363,6 +363,7 @@ PYTHON_OBJS= \
|
@@ -363,6 +363,7 @@ PYTHON_OBJS= \
|
||||||
Python/formatter_unicode.o \
|
Python/formatter_unicode.o \
|
||||||
Python/fileutils.o \
|
Python/fileutils.o \
|
||||||
@ -666,18 +666,18 @@ diff -up Python-3.3.0rc1/Makefile.pre.in.systemtap Python-3.3.0rc1/Makefile.pre.
|
|||||||
############################################################################
|
############################################################################
|
||||||
# Header files
|
# Header files
|
||||||
|
|
||||||
@@ -1343,6 +1352,7 @@ clean: pycremoval
|
@@ -1345,6 +1354,7 @@ clean: pycremoval
|
||||||
-rm -f $(srcdir)/Lib/lib2to3/*Grammar*.pickle
|
-rm -f Lib/lib2to3/*Grammar*.pickle
|
||||||
-rm -f $(SYSCONFIGDATA)
|
-rm -f $(SYSCONFIGDATA)
|
||||||
-rm -f Modules/_testembed Modules/_freeze_importlib
|
-rm -f Modules/_testembed Modules/_freeze_importlib
|
||||||
+ -rm -f $(srcdir)/Python/pysystemtap.h
|
+ -rm -f $(srcdir)/Python/pysystemtap.h
|
||||||
|
|
||||||
profile-removal:
|
profile-removal:
|
||||||
find . -name '*.gc??' -exec rm -f {} ';'
|
find . -name '*.gc??' -exec rm -f {} ';'
|
||||||
diff -up Python-3.3.0rc1/Misc/NEWS.systemtap Python-3.3.0rc1/Misc/NEWS
|
diff -up Python-3.3.0rc2/Misc/NEWS.systemtap Python-3.3.0rc2/Misc/NEWS
|
||||||
--- Python-3.3.0rc1/Misc/NEWS.systemtap 2012-08-25 15:22:11.000000000 -0400
|
--- Python-3.3.0rc2/Misc/NEWS.systemtap 2012-09-09 05:11:05.000000000 -0400
|
||||||
+++ Python-3.3.0rc1/Misc/NEWS 2012-08-27 11:00:36.599962901 -0400
|
+++ Python-3.3.0rc2/Misc/NEWS 2012-09-10 09:17:21.120511781 -0400
|
||||||
@@ -560,6 +560,11 @@ Core and Builtins
|
@@ -619,6 +619,11 @@ Core and Builtins
|
||||||
|
|
||||||
- Issue #15038: Optimize python Locks on Windows.
|
- Issue #15038: Optimize python Locks on Windows.
|
||||||
|
|
||||||
@ -689,9 +689,9 @@ diff -up Python-3.3.0rc1/Misc/NEWS.systemtap Python-3.3.0rc1/Misc/NEWS
|
|||||||
Library
|
Library
|
||||||
-------
|
-------
|
||||||
|
|
||||||
diff -up Python-3.3.0rc1/pyconfig.h.in.systemtap Python-3.3.0rc1/pyconfig.h.in
|
diff -up Python-3.3.0rc2/pyconfig.h.in.systemtap Python-3.3.0rc2/pyconfig.h.in
|
||||||
--- Python-3.3.0rc1/pyconfig.h.in.systemtap 2012-08-25 15:22:13.000000000 -0400
|
--- Python-3.3.0rc2/pyconfig.h.in.systemtap 2012-09-09 05:11:14.000000000 -0400
|
||||||
+++ Python-3.3.0rc1/pyconfig.h.in 2012-08-27 11:00:36.600962901 -0400
|
+++ Python-3.3.0rc2/pyconfig.h.in 2012-09-10 09:17:21.120511781 -0400
|
||||||
@@ -1306,6 +1306,9 @@
|
@@ -1306,6 +1306,9 @@
|
||||||
/* Define if you want to compile in Python-specific mallocs */
|
/* Define if you want to compile in Python-specific mallocs */
|
||||||
#undef WITH_PYMALLOC
|
#undef WITH_PYMALLOC
|
||||||
@ -702,9 +702,9 @@ diff -up Python-3.3.0rc1/pyconfig.h.in.systemtap Python-3.3.0rc1/pyconfig.h.in
|
|||||||
/* Define if you want to compile in rudimentary thread support */
|
/* Define if you want to compile in rudimentary thread support */
|
||||||
#undef WITH_THREAD
|
#undef WITH_THREAD
|
||||||
|
|
||||||
diff -up Python-3.3.0rc1/Python/ceval.c.systemtap Python-3.3.0rc1/Python/ceval.c
|
diff -up Python-3.3.0rc2/Python/ceval.c.systemtap Python-3.3.0rc2/Python/ceval.c
|
||||||
--- Python-3.3.0rc1/Python/ceval.c.systemtap 2012-08-25 15:22:12.000000000 -0400
|
--- Python-3.3.0rc2/Python/ceval.c.systemtap 2012-09-09 05:11:12.000000000 -0400
|
||||||
+++ Python-3.3.0rc1/Python/ceval.c 2012-08-27 11:00:36.600962901 -0400
|
+++ Python-3.3.0rc2/Python/ceval.c 2012-09-10 09:17:21.122511781 -0400
|
||||||
@@ -18,6 +18,8 @@
|
@@ -18,6 +18,8 @@
|
||||||
|
|
||||||
#include <ctype.h>
|
#include <ctype.h>
|
||||||
@ -737,9 +737,9 @@ diff -up Python-3.3.0rc1/Python/ceval.c.systemtap Python-3.3.0rc1/Python/ceval.c
|
|||||||
Py_LeaveRecursiveCall();
|
Py_LeaveRecursiveCall();
|
||||||
tstate->frame = f->f_back;
|
tstate->frame = f->f_back;
|
||||||
|
|
||||||
diff -up Python-3.3.0rc1/Python/ceval_systemtap.h.systemtap Python-3.3.0rc1/Python/ceval_systemtap.h
|
diff -up Python-3.3.0rc2/Python/ceval_systemtap.h.systemtap Python-3.3.0rc2/Python/ceval_systemtap.h
|
||||||
--- Python-3.3.0rc1/Python/ceval_systemtap.h.systemtap 2012-08-27 11:00:36.601962901 -0400
|
--- Python-3.3.0rc2/Python/ceval_systemtap.h.systemtap 2012-09-10 09:17:21.122511781 -0400
|
||||||
+++ Python-3.3.0rc1/Python/ceval_systemtap.h 2012-08-27 11:00:36.601962901 -0400
|
+++ Python-3.3.0rc2/Python/ceval_systemtap.h 2012-09-10 09:17:21.122511781 -0400
|
||||||
@@ -0,0 +1,86 @@
|
@@ -0,0 +1,86 @@
|
||||||
+/*
|
+/*
|
||||||
+ Support for SystemTap static markers
|
+ Support for SystemTap static markers
|
||||||
@ -827,9 +827,9 @@ diff -up Python-3.3.0rc1/Python/ceval_systemtap.h.systemtap Python-3.3.0rc1/Pyth
|
|||||||
+#define systemtap_function_return(f)
|
+#define systemtap_function_return(f)
|
||||||
+
|
+
|
||||||
+#endif
|
+#endif
|
||||||
diff -up Python-3.3.0rc1/Python/pysystemtap.d.systemtap Python-3.3.0rc1/Python/pysystemtap.d
|
diff -up Python-3.3.0rc2/Python/pysystemtap.d.systemtap Python-3.3.0rc2/Python/pysystemtap.d
|
||||||
--- Python-3.3.0rc1/Python/pysystemtap.d.systemtap 2012-08-27 11:00:36.601962901 -0400
|
--- Python-3.3.0rc2/Python/pysystemtap.d.systemtap 2012-09-10 09:17:21.122511781 -0400
|
||||||
+++ Python-3.3.0rc1/Python/pysystemtap.d 2012-08-27 11:00:36.601962901 -0400
|
+++ Python-3.3.0rc2/Python/pysystemtap.d 2012-09-10 09:17:21.122511781 -0400
|
||||||
@@ -0,0 +1,4 @@
|
@@ -0,0 +1,4 @@
|
||||||
+provider python {
|
+provider python {
|
||||||
+ probe function__entry(const char *, const char *, int, PyFrameObject *);
|
+ probe function__entry(const char *, const char *, int, PyFrameObject *);
|
||||||
|
@ -3,7 +3,7 @@
|
|||||||
# ======================================================
|
# ======================================================
|
||||||
|
|
||||||
%global pybasever 3.3
|
%global pybasever 3.3
|
||||||
%global alphatag rc1
|
%global alphatag rc2
|
||||||
|
|
||||||
# pybasever without the dot:
|
# pybasever without the dot:
|
||||||
%global pyshortver 33
|
%global pyshortver 33
|
||||||
@ -127,7 +127,7 @@
|
|||||||
Summary: Version 3 of the Python programming language aka Python 3000
|
Summary: Version 3 of the Python programming language aka Python 3000
|
||||||
Name: python3
|
Name: python3
|
||||||
Version: %{pybasever}.0
|
Version: %{pybasever}.0
|
||||||
Release: 0.4.%{alphatag}%{?dist}
|
Release: 0.5.%{alphatag}%{?dist}
|
||||||
License: Python
|
License: Python
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
|
|
||||||
@ -1588,6 +1588,9 @@ rm -fr %{buildroot}
|
|||||||
# ======================================================
|
# ======================================================
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Sep 10 2012 David Malcolm <dmalcolm@redhat.com> - 3.3.0-0.5.rc2
|
||||||
|
- 3.3.0rc1 -> 3.3.0rc2; refresh patch 55
|
||||||
|
|
||||||
* Mon Aug 27 2012 David Malcolm <dmalcolm@redhat.com> - 3.3.0-0.4.rc1
|
* Mon Aug 27 2012 David Malcolm <dmalcolm@redhat.com> - 3.3.0-0.4.rc1
|
||||||
- 3.3.0b2 -> 3.3.0rc1; refresh patches 3, 55
|
- 3.3.0b2 -> 3.3.0rc1; refresh patches 3, 55
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user