Replace patch 291 with the upstream fix.
This commit is contained in:
parent
347e968f54
commit
6b9e1d1d7a
@ -1,25 +1,15 @@
|
|||||||
From aae2ef0bace0e38f4ee5aaa4642aa32450a84216 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <besser82@fedoraproject.org>
|
|
||||||
Date: Tue, 23 Jan 2018 14:43:43 +0100
|
|
||||||
Subject: [PATCH] setup: Link ctypes against dl explicitly
|
|
||||||
|
|
||||||
---
|
|
||||||
setup.py | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/setup.py b/setup.py
|
diff --git a/setup.py b/setup.py
|
||||||
index c23628a2a9..9e40bb53e6 100644
|
index f4f6e4fdb1f0..8536c350fe3a 100644
|
||||||
--- a/setup.py
|
--- a/setup.py
|
||||||
+++ b/setup.py
|
+++ b/setup.py
|
||||||
@@ -1935,7 +1935,7 @@ class PyBuildExt(build_ext):
|
@@ -2005,6 +2005,10 @@ def detect_ctypes(self, inc_dirs, lib_dirs):
|
||||||
self.use_system_libffi = False
|
ext.libraries.append(ffi_lib)
|
||||||
include_dirs = []
|
self.use_system_libffi = True
|
||||||
|
|
||||||
|
+ if sysconfig.get_config_var('HAVE_LIBDL'):
|
||||||
|
+ # for dlopen, see bpo-32647
|
||||||
|
+ ext.libraries.append('dl')
|
||||||
|
+
|
||||||
|
def _decimal_ext(self):
|
||||||
extra_compile_args = []
|
extra_compile_args = []
|
||||||
- extra_link_args = []
|
undef_macros = []
|
||||||
+ extra_link_args = ['-ldl']
|
|
||||||
sources = ['_ctypes/_ctypes.c',
|
|
||||||
'_ctypes/callbacks.c',
|
|
||||||
'_ctypes/callproc.c',
|
|
||||||
--
|
|
||||||
2.16.1
|
|
||||||
|
|
||||||
|
@ -370,6 +370,7 @@ Patch290: 00290-cryptmodule-Include-crypt.h-for-declaration-of-crypt.patch
|
|||||||
# Build fails with undefined references to dlopen / dlsym otherwise.
|
# Build fails with undefined references to dlopen / dlsym otherwise.
|
||||||
# See: https://bugzilla.redhat.com/show_bug.cgi?id=1537489
|
# See: https://bugzilla.redhat.com/show_bug.cgi?id=1537489
|
||||||
# and: https://src.fedoraproject.org/rpms/redhat-rpm-config/c/078af19
|
# and: https://src.fedoraproject.org/rpms/redhat-rpm-config/c/078af19
|
||||||
|
# Fixed upstream: https://bugs.python.org/issue32647
|
||||||
Patch291: 00291-setup-Link-ctypes-against-dl-explicitly.patch
|
Patch291: 00291-setup-Link-ctypes-against-dl-explicitly.patch
|
||||||
|
|
||||||
# 00292 #
|
# 00292 #
|
||||||
|
Loading…
Reference in New Issue
Block a user