Update to Python 3.6.2
Rebased patch 180. Dropped patches 249, 258, 269 as they have been upstreamed.
This commit is contained in:
parent
46034c8139
commit
4ff21139d7
@ -1,12 +1,13 @@
|
||||
diff -r de35eae9048a config.sub
|
||||
--- a/config.sub Wed Apr 24 23:33:20 2013 +0200
|
||||
+++ b/config.sub Thu Apr 25 08:51:00 2013 +0200
|
||||
@@ -1008,7 +1008,7 @@
|
||||
diff --git a/config.sub b/config.sub
|
||||
index 40ea5df..932128b 100755
|
||||
--- a/config.sub
|
||||
+++ b/config.sub
|
||||
@@ -1045,7 +1045,7 @@ case $basic_machine in
|
||||
;;
|
||||
ppc64) basic_machine=powerpc64-unknown
|
||||
;;
|
||||
- ppc64-*) basic_machine=powerpc64-`echo $basic_machine | sed 's/^[^-]*-//'`
|
||||
+ ppc64-* | ppc64p7-*) basic_machine=powerpc64-`echo $basic_machine | sed 's/^[^-]*-//'`
|
||||
;;
|
||||
ppc64le | powerpc64little | ppc64-le | powerpc64-little)
|
||||
ppc64le | powerpc64little)
|
||||
basic_machine=powerpc64le-unknown
|
||||
|
28
python3.spec
28
python3.spec
@ -132,8 +132,8 @@
|
||||
# ==================
|
||||
Summary: Version 3 of the Python programming language aka Python 3000
|
||||
Name: python3
|
||||
Version: %{pybasever}.1
|
||||
Release: 10%{?dist}
|
||||
Version: %{pybasever}.2
|
||||
Release: 1%{?dist}
|
||||
License: Python
|
||||
Group: Development/Languages
|
||||
|
||||
@ -411,12 +411,6 @@ Patch206: 00206-remove-hf-from-arm-triplet.patch
|
||||
# Fedora needs the default mips64-linux-gnu
|
||||
Patch243: 00243-fix-mips64-triplet.patch
|
||||
|
||||
# 00249 #
|
||||
# Fix builds using the --with-dtrace flag as the rpmbuild
|
||||
# of python is an out of tree build
|
||||
# Not yet fixed upstream: http://bugs.python.org/issue28787
|
||||
Patch249: 00249-fix-out-of-tree-dtrace-builds.patch
|
||||
|
||||
# 00251
|
||||
# Set values of prefix and exec_prefix in distutils install command
|
||||
# to /usr/local if executable is /usr/bin/python* and RPM build
|
||||
@ -430,12 +424,6 @@ Patch251: 00251-change-user-install-location.patch
|
||||
# Reported upstream: https://bugs.python.org/issue29411
|
||||
Patch252: 00252-add-executable-option.patch
|
||||
|
||||
# 00258 #
|
||||
# Kernel 4.9 introduced some changes to its crypto API
|
||||
# making test_aead_aes_gcm fail, so skipping the test for now
|
||||
# Reported upstream: http://bugs.python.org/issue29324
|
||||
Patch258: 00258-fix-test_aead_aes_gcm.patch
|
||||
|
||||
# 00262 #
|
||||
# Backport of PEP 538: Coercing the legacy C locale to a UTF-8 based locale
|
||||
# https://www.python.org/dev/peps/pep-0538/
|
||||
@ -450,12 +438,6 @@ Patch262: 00262-pep538_coerce_legacy_c_locale.patch
|
||||
# Reported upstream: http://bugs.python.org/issue29804
|
||||
Patch264: 00264-skip-test-failing-on-aarch64.patch
|
||||
|
||||
# 00269 #
|
||||
# Fix python's recompilation with common build commands when using
|
||||
# profile guided optimizations.
|
||||
# Fixed upstream: http://bugs.python.org/issue29243
|
||||
Patch269: 00269-fix-multiple-compilations-issue-with-pgo-builds.patch
|
||||
|
||||
# 00270 #
|
||||
# Fix test_alpn_protocols from test_ssl as openssl > 1.1.0f
|
||||
# changed the behaviour of the ALPN hook.
|
||||
@ -726,17 +708,14 @@ sed -r -i s/'_PIP_VERSION = "[0-9.]+"'/'_PIP_VERSION = "%{pip_version}"'/ Lib/en
|
||||
%patch205 -p1
|
||||
%patch206 -p1
|
||||
%patch243 -p1
|
||||
%patch249 -p1
|
||||
%patch251 -p1
|
||||
%patch252 -p1
|
||||
%patch258 -p1
|
||||
%patch262 -p1
|
||||
|
||||
%ifarch aarch64
|
||||
%patch264 -p1
|
||||
%endif
|
||||
|
||||
%patch269 -p1
|
||||
%patch270 -p1
|
||||
|
||||
# Currently (2010-01-15), http://docs.python.org/library is for 2.6, and there
|
||||
@ -1701,6 +1680,9 @@ fi
|
||||
# ======================================================
|
||||
|
||||
%changelog
|
||||
* Tue Jul 18 2017 Charalampos Stratakis <cstratak@redhat.com> - 3.6.2-1
|
||||
- Update to Python 3.6.2
|
||||
|
||||
* Tue Jun 27 2017 Charalampos Stratakis <cstratak@redhat.com> - 3.6.1-10
|
||||
- Update to the latest upstream implementation of PEP 538
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (Python-3.6.1.tar.xz) = 8605fb7019386fec227d4b06d06f00ae500a8a89df289bfe6141bb56196c75483a60cc0ee553930742b31cefce68add5ccf226e0f27b7b915f5026d597e1ac29
|
||||
SHA512 (Python-3.6.2.tar.xz) = a8270a09a9e9b39f69ece6cdade2fa964665d2107b5acbad4453f1b921107b329c697c137185928fb4a576fc0f2ae2a98dbf26a8b7ea17219e990ddbc216db8b
|
||||
|
Loading…
Reference in New Issue
Block a user