Merge lib64 patches into one (104 into 102)
It doean't make sense for these to be separate.
This commit is contained in:
parent
96a7bd540e
commit
2c6abcc9a3
@ -37,6 +37,20 @@ index 026cca7..6d3e077 100644
|
||||
if standard_lib:
|
||||
return libpython
|
||||
else:
|
||||
diff a/Lib/distutils/tests/test_install.py b/Lib/distutils/tests/test_install.py
|
||||
--- a/Lib/distutils/tests/test_install.py
|
||||
+++ b/Lib/distutils/tests/test_install.py
|
||||
@@ -57,8 +57,9 @@
|
||||
self.assertEqual(got, expected)
|
||||
|
||||
libdir = os.path.join(destination, "lib", "python")
|
||||
+ platlibdir = os.path.join(destination, "lib64", "python")
|
||||
check_path(cmd.install_lib, libdir)
|
||||
- check_path(cmd.install_platlib, libdir)
|
||||
+ check_path(cmd.install_platlib, platlibdir)
|
||||
check_path(cmd.install_purelib, libdir)
|
||||
check_path(cmd.install_headers,
|
||||
os.path.join(destination, "include", "python", "foopkg"))
|
||||
diff --git a/Lib/site.py b/Lib/site.py
|
||||
index a84e3bb..ba0d3ea 100644
|
||||
--- a/Lib/site.py
|
||||
|
@ -1,13 +0,0 @@
|
||||
--- Python-2.7.2/Lib/distutils/tests/test_install.py.lib64 2011-09-08 17:51:57.851405376 -0400
|
||||
+++ Python-2.7.2/Lib/distutils/tests/test_install.py 2011-09-08 18:40:46.754205096 -0400
|
||||
@@ -41,8 +41,9 @@ class InstallTestCase(support.TempdirMan
|
||||
self.assertEqual(got, expected)
|
||||
|
||||
libdir = os.path.join(destination, "lib", "python")
|
||||
+ platlibdir = os.path.join(destination, "lib64", "python")
|
||||
check_path(cmd.install_lib, libdir)
|
||||
- check_path(cmd.install_platlib, libdir)
|
||||
+ check_path(cmd.install_platlib, platlibdir)
|
||||
check_path(cmd.install_purelib, libdir)
|
||||
check_path(cmd.install_headers,
|
||||
os.path.join(destination, "include", "python", "foopkg"))
|
11
python3.spec
11
python3.spec
@ -259,12 +259,11 @@ Patch1: 00001-rpath.patch
|
||||
# (where sys.getfilesystemencoding() == 'ascii')
|
||||
Patch55: 00055-systemtap.patch
|
||||
|
||||
Patch102: 00102-lib64.patch
|
||||
|
||||
# 00104 #
|
||||
# 00102 #
|
||||
# Change the various install paths to use /usr/lib64/ instead or /usr/lib
|
||||
# Only used when "%{_lib}" == "lib64"
|
||||
# Another lib64 fix, for distutils/tests/test_install.py; not upstream:
|
||||
Patch104: 00104-lib64-fix-for-test_install.patch
|
||||
# Not yet sent upstream.
|
||||
Patch102: 00102-lib64.patch
|
||||
|
||||
# 00111 #
|
||||
# Patch the Makefile.pre.in so that the generated Makefile doesn't try to build
|
||||
@ -687,7 +686,6 @@ sed -r -i s/'_PIP_VERSION = "[0-9.]+"'/'_PIP_VERSION = "%{pip_version}"'/ Lib/en
|
||||
|
||||
%if "%{_lib}" == "lib64"
|
||||
%patch102 -p1
|
||||
%patch104 -p1
|
||||
%endif
|
||||
%patch111 -p1
|
||||
%patch132 -p1
|
||||
@ -1680,6 +1678,7 @@ fi
|
||||
* Mon Aug 28 2017 Petr Viktorin <pviktori@redhat.com> - 3.6.2-13
|
||||
- Rename patch files to be consistent
|
||||
- Run autotools to generate the configure script before building
|
||||
- Merge lib64 patches (104 into 102)
|
||||
|
||||
* Mon Aug 28 2017 Michal Cyprian <mcyprian@redhat.com> - 3.6.2-12
|
||||
- Use python3 style of calling super() without arguments in rpath
|
||||
|
Loading…
Reference in New Issue
Block a user