run selftests with "--verbose"; disable parts of test_io on ppc (rhbz#732998)
This commit is contained in:
parent
d0528e355d
commit
28391cb8f7
11
python-2.7.2-disable-tests-in-test_io.patch
Normal file
11
python-2.7.2-disable-tests-in-test_io.patch
Normal file
@ -0,0 +1,11 @@
|
||||
diff -up Python-2.7.2/Lib/test/test_io.py.disable-tests-in-test_io Python-2.7.2/Lib/test/test_io.py
|
||||
--- Python-2.7.2/Lib/test/test_io.py.disable-tests-in-test_io 2011-09-01 14:18:45.963304089 -0400
|
||||
+++ Python-2.7.2/Lib/test/test_io.py 2011-09-01 15:08:53.796098413 -0400
|
||||
@@ -2669,6 +2669,7 @@ class SignalsTest(unittest.TestCase):
|
||||
self.check_interrupted_read_retry(lambda x: x,
|
||||
mode="r")
|
||||
|
||||
+ @unittest.skip('rhbz#732998')
|
||||
@unittest.skipUnless(threading, 'Threading required for this test.')
|
||||
def check_interrupted_write_retry(self, item, **fdopen_kwargs):
|
||||
"""Check that a buffered write, when it gets interrupted (either
|
18
python3.spec
18
python3.spec
@ -118,7 +118,7 @@
|
||||
Summary: Version 3 of the Python programming language aka Python 3000
|
||||
Name: python3
|
||||
Version: %{pybasever}.1
|
||||
Release: 6%{?dist}
|
||||
Release: 7%{?dist}
|
||||
License: Python
|
||||
Group: Development/Languages
|
||||
|
||||
@ -271,6 +271,12 @@ Patch129: python-3.2.1-fix-test-subprocess-with-nonreadable-path-dir.patch
|
||||
# Sent upstream as http://bugs.python.org/issue12872
|
||||
Patch130: python-2.7.2-tsc-on-ppc.patch
|
||||
|
||||
# The four tests in test_io built on top of check_interrupted_write_retry
|
||||
# fail when built in Koji, for ppc and ppc64; for some reason, the SIGALRM
|
||||
# handlers are never called, and the call to write runs to completion
|
||||
# (rhbz#732998)
|
||||
Patch131: python-2.7.2-disable-tests-in-test_io.patch
|
||||
|
||||
# This is the generated patch to "configure"; see the description of
|
||||
# %{regenerate_autotooling_patch}
|
||||
# above:
|
||||
@ -431,6 +437,10 @@ rm -r Modules/zlib || exit 1
|
||||
%patch129 -p1
|
||||
%patch130 -p1 -b .tsc-on-ppc
|
||||
|
||||
%ifarch ppc ppc64
|
||||
%patch131 -p1
|
||||
%endif
|
||||
|
||||
# Currently (2010-01-15), http://docs.python.org/library is for 2.6, and there
|
||||
# are many differences between 2.6 and the Python 3 library.
|
||||
#
|
||||
@ -910,7 +920,7 @@ CheckPython() {
|
||||
|
||||
# Run the upstream test suite
|
||||
LD_LIBRARY_PATH=$ConfDir $ConfDir/python -m test.regrtest \
|
||||
--verbose3 --findleaks \
|
||||
--verbose --findleaks \
|
||||
-x $EXCLUDED_TESTS
|
||||
|
||||
echo FINISHED: CHECKING OF PYTHON FOR CONFIGURATION: $ConfName
|
||||
@ -1298,6 +1308,10 @@ rm -fr %{buildroot}
|
||||
# ======================================================
|
||||
|
||||
%changelog
|
||||
* Thu Sep 1 2011 David Malcolm <dmalcolm@redhat.com> - 3.2.1-7
|
||||
- run selftests with "--verbose"
|
||||
- disable parts of test_io on ppc (rhbz#732998)
|
||||
|
||||
* Wed Aug 31 2011 David Malcolm <dmalcolm@redhat.com> - 3.2.1-6
|
||||
- use "--findleaks --verbose3" when running test suite
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user