Remove arm specific test skip patches139&140 rhbz#1318565
This commit is contained in:
parent
83d6e884b3
commit
20b919fd08
@ -1,11 +0,0 @@
|
||||
diff -up Python-2.7.2/Lib/test/test_float.py.skip-test_float-known-failure-on-arm Python-2.7.2/Lib/test/test_float.py
|
||||
--- Python-2.7.2/Lib/test/test_float.py.skip-test_float-known-failure-on-arm 2011-09-08 19:34:09.000986128 -0400
|
||||
+++ Python-2.7.2/Lib/test/test_float.py 2011-09-08 19:34:57.969982779 -0400
|
||||
@@ -1072,6 +1072,7 @@ class HexFloatTestCase(unittest.TestCase
|
||||
self.identical(got, expected)
|
||||
|
||||
|
||||
+ @unittest.skip('Known failure on ARM: http://bugs.python.org/issue8265')
|
||||
def test_from_hex(self):
|
||||
MIN = self.MIN;
|
||||
MAX = self.MAX;
|
@ -1,12 +0,0 @@
|
||||
--- Python-3.3.2/Lib/test/test_gdb.py.orig 2013-07-26 09:52:15.533852708 -0500
|
||||
+++ Python-3.3.2/Lib/test/test_gdb.py 2013-07-26 15:07:53.733623014 -0500
|
||||
@@ -729,8 +729,7 @@
|
||||
foo\(1, 2, 3\)
|
||||
''')
|
||||
|
||||
- @unittest.skipUnless(_thread,
|
||||
- "Python was compiled without thread support")
|
||||
+ @unittest.skip('Known failure on ARM: https://bugzilla.redhat.com/show_bug.cgi?id=986713')
|
||||
def test_threads(self):
|
||||
'Verify that "py-bt" indicates threads that are waiting for the GIL'
|
||||
cmd = '''
|
12
python3.spec
12
python3.spec
@ -254,14 +254,6 @@ Patch132: 00132-add-rpmbuild-hooks-to-unittest.patch
|
||||
# Some tests within distutils fail when run in an rpmbuild:
|
||||
Patch137: 00137-skip-distutils-tests-that-fail-in-rpmbuild.patch
|
||||
|
||||
# 00139 #
|
||||
# ARM-specific: skip known failure in test_float:
|
||||
# http://bugs.python.org/issue8265 (rhbz#706253)
|
||||
Patch139: 00139-skip-test_float-known-failure-on-arm.patch
|
||||
|
||||
# ideally short lived patch disabling a test thats fragile on different arches
|
||||
Patch140: python3-arm-skip-failing-fragile-test.patch
|
||||
|
||||
# 00143 #
|
||||
# Fix the --with-tsc option on ppc64, and rework it on 32-bit ppc to avoid
|
||||
# aliasing violations (rhbz#698726)
|
||||
@ -655,10 +647,6 @@ sed -r -i s/'_PIP_VERSION = "[0-9.]+"'/'_PIP_VERSION = "%{pip_version}"'/ Lib/en
|
||||
%patch111 -p1
|
||||
%patch132 -p1
|
||||
%patch137 -p1
|
||||
%ifarch %{arm}
|
||||
%patch139 -p1
|
||||
%patch140 -p1
|
||||
%endif
|
||||
%patch143 -p1 -b .tsc-on-ppc
|
||||
%patch146 -p1
|
||||
%patch155 -p1
|
||||
|
Loading…
Reference in New Issue
Block a user