Hide the private _Py_atomic_xxx symbols from public header
This commit is contained in:
parent
b0795dd21b
commit
08374589d7
63
00207-hide-atomic-symbols.patch
Normal file
63
00207-hide-atomic-symbols.patch
Normal file
@ -0,0 +1,63 @@
|
|||||||
|
|
||||||
|
# HG changeset patch
|
||||||
|
# User Victor Stinner <victor.stinner@gmail.com>
|
||||||
|
# Date 1442581594 -7200
|
||||||
|
# Node ID d4fcb362f7c66b25b22ddc0d27db0cc96acc727b
|
||||||
|
# Parent d04a0954e142f873adee88ec5bc1c1d81cd46bc4
|
||||||
|
Issue #25150: Hide the private _Py_atomic_xxx symbols from the public
|
||||||
|
Python.h header to fix a compilation error with OpenMP. PyThreadState_GET()
|
||||||
|
becomes an alias to PyThreadState_Get() to avoid ABI incompatibilies.
|
||||||
|
|
||||||
|
It is important that the _PyThreadState_Current variable is always accessed
|
||||||
|
with the same implementation of pyatomic.h. Use the PyThreadState_Get()
|
||||||
|
function so extension modules will all reuse the same implementation.
|
||||||
|
|
||||||
|
diff --git a/Include/pyatomic.h b/Include/pyatomic.h
|
||||||
|
--- a/Include/pyatomic.h
|
||||||
|
+++ b/Include/pyatomic.h
|
||||||
|
@@ -1,8 +1,6 @@
|
||||||
|
-/* Issue #23644: <stdatomic.h> is incompatible with C++, see:
|
||||||
|
- https://gcc.gnu.org/bugzilla/show_bug.cgi?id=60932 */
|
||||||
|
-#if !defined(Py_LIMITED_API) && !defined(__cplusplus)
|
||||||
|
#ifndef Py_ATOMIC_H
|
||||||
|
#define Py_ATOMIC_H
|
||||||
|
+#ifdef Py_BUILD_CORE
|
||||||
|
|
||||||
|
#include "dynamic_annotations.h"
|
||||||
|
|
||||||
|
@@ -248,5 +246,5 @@ static __inline__ void
|
||||||
|
#define _Py_atomic_load_relaxed(ATOMIC_VAL) \
|
||||||
|
_Py_atomic_load_explicit(ATOMIC_VAL, _Py_memory_order_relaxed)
|
||||||
|
|
||||||
|
+#endif /* Py_BUILD_CORE */
|
||||||
|
#endif /* Py_ATOMIC_H */
|
||||||
|
-#endif /* Py_LIMITED_API */
|
||||||
|
diff --git a/Include/pystate.h b/Include/pystate.h
|
||||||
|
--- a/Include/pystate.h
|
||||||
|
+++ b/Include/pystate.h
|
||||||
|
@@ -177,20 +177,13 @@ PyAPI_FUNC(int) PyThreadState_SetAsyncEx
|
||||||
|
/* Variable and macro for in-line access to current thread state */
|
||||||
|
|
||||||
|
/* Assuming the current thread holds the GIL, this is the
|
||||||
|
- PyThreadState for the current thread.
|
||||||
|
-
|
||||||
|
- Issue #23644: pyatomic.h is incompatible with C++ (yet). Disable
|
||||||
|
- PyThreadState_GET() optimization: declare it as an alias to
|
||||||
|
- PyThreadState_Get(), as done for limited API. */
|
||||||
|
-#if !defined(Py_LIMITED_API) && !defined(__cplusplus)
|
||||||
|
+ PyThreadState for the current thread. */
|
||||||
|
+#ifdef Py_BUILD_CORE
|
||||||
|
PyAPI_DATA(_Py_atomic_address) _PyThreadState_Current;
|
||||||
|
-#endif
|
||||||
|
-
|
||||||
|
-#if defined(Py_DEBUG) || defined(Py_LIMITED_API) || defined(__cplusplus)
|
||||||
|
-#define PyThreadState_GET() PyThreadState_Get()
|
||||||
|
+# define PyThreadState_GET() \
|
||||||
|
+ ((PyThreadState*)_Py_atomic_load_relaxed(&_PyThreadState_Current))
|
||||||
|
#else
|
||||||
|
-#define PyThreadState_GET() \
|
||||||
|
- ((PyThreadState*)_Py_atomic_load_relaxed(&_PyThreadState_Current))
|
||||||
|
+# define PyThreadState_GET() PyThreadState_Get()
|
||||||
|
#endif
|
||||||
|
|
||||||
|
typedef
|
15
python3.spec
15
python3.spec
@ -140,7 +140,7 @@
|
|||||||
Summary: Version 3 of the Python programming language aka Python 3000
|
Summary: Version 3 of the Python programming language aka Python 3000
|
||||||
Name: python3
|
Name: python3
|
||||||
Version: %{pybasever}.0
|
Version: %{pybasever}.0
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
License: Python
|
License: Python
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
|
|
||||||
@ -744,6 +744,11 @@ Patch205: 00205-make-libpl-respect-lib64.patch
|
|||||||
# by debian but fedora infra uses only eabi without hf
|
# by debian but fedora infra uses only eabi without hf
|
||||||
Patch206: 00206-remove-hf-from-arm-triplet.patch
|
Patch206: 00206-remove-hf-from-arm-triplet.patch
|
||||||
|
|
||||||
|
# https://bugs.python.org/issue25150
|
||||||
|
# Hide the private _Py_atomic_xxx symbols from the public
|
||||||
|
# Python.h header to fix a compilation error with OpenMP.
|
||||||
|
Patch207: 00207-hide-atomic-symbols.patch
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
# (New patches go here ^^^)
|
# (New patches go here ^^^)
|
||||||
@ -1037,6 +1042,7 @@ sed -r -i s/'_PIP_VERSION = "[0-9.]+"'/'_PIP_VERSION = "%{pip_version}"'/ Lib/en
|
|||||||
# 00204: upstream as of 3.5.0b3
|
# 00204: upstream as of 3.5.0b3
|
||||||
%patch205 -p1
|
%patch205 -p1
|
||||||
%patch206 -p1
|
%patch206 -p1
|
||||||
|
%patch207 -p1
|
||||||
|
|
||||||
# Currently (2010-01-15), http://docs.python.org/library is for 2.6, and there
|
# Currently (2010-01-15), http://docs.python.org/library is for 2.6, and there
|
||||||
# are many differences between 2.6 and the Python 3 library.
|
# are many differences between 2.6 and the Python 3 library.
|
||||||
@ -1746,7 +1752,7 @@ rm -fr %{buildroot}
|
|||||||
%dir %{_includedir}/python%{LDVERSION_optimized}/
|
%dir %{_includedir}/python%{LDVERSION_optimized}/
|
||||||
%{_includedir}/python%{LDVERSION_optimized}/%{_pyconfig_h}
|
%{_includedir}/python%{LDVERSION_optimized}/%{_pyconfig_h}
|
||||||
|
|
||||||
#%{_libdir}/%{py_INSTSONAME_optimized}
|
%{_libdir}/%{py_INSTSONAME_optimized}
|
||||||
%{_libdir}/libpython3.so
|
%{_libdir}/libpython3.so
|
||||||
%if 0%{?with_systemtap}
|
%if 0%{?with_systemtap}
|
||||||
%dir %(dirname %{tapsetdir})
|
%dir %(dirname %{tapsetdir})
|
||||||
@ -1888,7 +1894,7 @@ rm -fr %{buildroot}
|
|||||||
# do for the regular build above (bug 531901), since they're all in one package
|
# do for the regular build above (bug 531901), since they're all in one package
|
||||||
# now; they're listed below, under "-devel":
|
# now; they're listed below, under "-devel":
|
||||||
|
|
||||||
#%{_libdir}/%{py_INSTSONAME_debug}
|
%{_libdir}/%{py_INSTSONAME_debug}
|
||||||
%if 0%{?with_systemtap}
|
%if 0%{?with_systemtap}
|
||||||
%dir %(dirname %{tapsetdir})
|
%dir %(dirname %{tapsetdir})
|
||||||
%dir %{tapsetdir}
|
%dir %{tapsetdir}
|
||||||
@ -1937,6 +1943,9 @@ rm -fr %{buildroot}
|
|||||||
# ======================================================
|
# ======================================================
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 11 2015 Robert Kuska <rkuska@redhat.com> - 3.5.0-3
|
||||||
|
- Hide the private _Py_atomic_xxx symbols from public header
|
||||||
|
|
||||||
* Wed Oct 14 2015 Robert Kuska <rkuska@redhat.com> - 3.5.0-2
|
* Wed Oct 14 2015 Robert Kuska <rkuska@redhat.com> - 3.5.0-2
|
||||||
- Rebuild with wheel set to 1
|
- Rebuild with wheel set to 1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user