Stop adding PYTHON_CFGDIR to LD_RUN_PATH and PYTHON_LDFLAGS
The patch is simplified unconditional version of the upstream patch https://github.com/GrahamDumpleton/mod_wsgi/pull/873
This commit is contained in:
parent
77842d1b6e
commit
337e91c2c2
@ -27,6 +27,11 @@ Source0: https://github.com/GrahamDumpleton/mod_wsgi/archive/%{version}.t
|
||||
Source1: wsgi.conf
|
||||
Source2: wsgi-python3.conf
|
||||
Patch1: mod_wsgi-4.5.20-exports.patch
|
||||
# Stop adding PYTHON_CFGDIR to LD_RUN_PATH and PYTHON_LDFLAGS
|
||||
# rpminspect reports invalid DT_RUNPATH: /usr/lib64/python3.12/config
|
||||
# Following patch is a simplified unconditional version of our upstream PR:
|
||||
# https://github.com/GrahamDumpleton/mod_wsgi/pull/873
|
||||
Patch2: stop-adding-PYTHON_CFGDIR-to-LD_RUN_PATH-and-PYTHON_LDFLAGS.patch
|
||||
|
||||
BuildRequires: httpd-devel
|
||||
BuildRequires: gcc
|
||||
|
@ -0,0 +1,22 @@
|
||||
diff --git a/setup.py b/setup.py
|
||||
index e0c8c84..f315b01 100644
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -300,7 +300,7 @@ else:
|
||||
if not os.path.exists(PYTHON_CFGDIR):
|
||||
PYTHON_CFGDIR = '%s-%s' % (PYTHON_CFGDIR, sys.platform)
|
||||
|
||||
- PYTHON_LDFLAGS = ['-L%s' % PYTHON_CFGDIR]
|
||||
+ PYTHON_LDFLAGS = []
|
||||
if PYTHON_LIBDIR != APXS_LIBDIR:
|
||||
PYTHON_LDFLAGS.insert(0, '-L%s' % PYTHON_LIBDIR)
|
||||
|
||||
@@ -326,7 +326,7 @@ EXTRA_LINK_ARGS = PYTHON_LDFLAGS + PYTHON_LDLIBS
|
||||
LD_RUN_PATHS = []
|
||||
if os.name != 'nt':
|
||||
LD_RUN_PATH = os.environ.get('LD_RUN_PATH', '')
|
||||
- LD_RUN_PATHS = [PYTHON_CFGDIR]
|
||||
+ LD_RUN_PATHS = []
|
||||
if PYTHON_LIBDIR != APXS_LIBDIR:
|
||||
LD_RUN_PATHS.insert(0, PYTHON_LIBDIR)
|
||||
LD_RUN_PATH += ':' + ':'.join(LD_RUN_PATHS)
|
Loading…
Reference in New Issue
Block a user