Import from Fedora python-lxml @ 55f5648

Resolves: RHEL-17738
This commit is contained in:
Tomáš Hrnčiar 2023-10-17 14:43:27 +02:00 committed by Miro Hrončok
parent 05c5a15c12
commit 15d5f1f6d7
14 changed files with 3514 additions and 0 deletions

1
.fmf/version Normal file
View File

@ -0,0 +1 @@
1

64
.gitignore vendored
View File

@ -0,0 +1,64 @@
lxml-2.2.7.tar.gz
lxml-2.2.7.tar.gz.asc
/lxml-2.2.8.tar.gz
/lxml-2.2.8.tar.gz.asc
/lxml-2.3.tar.gz
/lxml-2.3.tar.gz.asc
/lxml-2.3.1.tar.gz
/lxml-2.3.1.tar.gz.asc
/lxml-2.3.2.tar.gz
/lxml-2.3.2.tar.gz.asc
/lxml-2.3.3.tar.gz
/lxml-2.3.3.tar.gz.asc
/lxml-2.3.5.tar.gz
/lxml-2.3.5.tar.gz.asc
/lxml-3.0.tar.gz
/lxml-3.0.tar.gz.asc
/lxml-3.0.tgz
/lxml-3.0.tgz.asc
/lxml-3.0.1.tgz
/lxml-3.0.1.tgz.asc
/lxml-3.1.0.tgz
/lxml-3.1.0.tgz.asc
/lxml-3.2.0.tgz
/lxml-3.2.0.tgz.asc
/lxml-3.2.1.tgz
/lxml-3.2.1.tgz.asc
/lxml-3.2.3.tgz
/lxml-3.2.3.tgz.asc
/lxml-3.2.4.tgz
/lxml-3.2.4.tgz.asc
/lxml-3.3.0.tgz
/lxml-3.3.0.tgz.asc
/lxml-3.3.2.tgz
/lxml-3.3.2.tgz.asc
/lxml-3.3.3.tgz
/lxml-3.3.3.tgz.asc
/lxml-3.3.5.tgz
/lxml-3.3.5.tgz.asc
/lxml-3.3.6.tgz
/lxml-3.3.6.tgz.asc
/lxml-3.4.4.tgz
/lxml-3.4.4.tgz.asc
/lxml-3.6.4.tar.gz
/lxml-3.7.0.tar.gz
/lxml-3.7.1.tgz
/lxml-3.7.2.tgz
/lxml-3.8.0.tgz
/lxml-4.0.0.tgz
/lxml-4.1.1.tgz
/lxml-4.2.1.tgz
/lxml-4.2.3.tgz
/lxml-4.2.4.tgz
/lxml-4.2.5.tgz
/lxml-4.4.0.tgz
/lxml-4.4.1.tgz
/lxml-4.5.1.tgz
/lxml-4.6.2.tar.gz
/lxml-4.6.3.tar.gz
/lxml-4.7.1.tar.gz
/lxml-4.9.1.tar.gz
/lxml-4.9.2.tar.gz
/lxml-4.9.2-no-isoschematron.tar.gz
/lxml-4.9.2-no-isoschematron-rng.tar.gz
/lxml-4.9.3-no-isoschematron-rng.tar.gz

24
380.patch Normal file
View File

@ -0,0 +1,24 @@
From d18f2f22218ea0e0b5327b5a2bda789afdf16e41 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
Date: Fri, 14 Jul 2023 12:18:25 +0200
Subject: [PATCH] Skip test_isoschematron.test_schematron_invalid_schema_empty
without the RNG file
The expected SchematronParseError only happens when validate_schema is true.
---
src/lxml/tests/test_isoschematron.py | 2 ++
1 file changed, 2 insertions(+)
diff --git a/src/lxml/tests/test_isoschematron.py b/src/lxml/tests/test_isoschematron.py
index 6d2aa3fb6..900f257c3 100644
--- a/src/lxml/tests/test_isoschematron.py
+++ b/src/lxml/tests/test_isoschematron.py
@@ -55,6 +55,8 @@ def test_schematron_empty_pattern(self):
schema = isoschematron.Schematron(schema)
self.assertTrue(schema)
+ @unittest.skipIf(not isoschematron.schematron_schema_valid_supported,
+ 'SchematronParseError is risen only when validate_schema is true')
def test_schematron_invalid_schema_empty(self):
schema = self.parse('''\
<schema xmlns="http://purl.oclc.org/dsdl/schematron" />

View File

@ -0,0 +1,116 @@
From a500f721e3b34018f0a86af275427663dc337b5a Mon Sep 17 00:00:00 2001
From: Stefan Behnel <stefan_ml@behnel.de>
Date: Wed, 12 Jul 2023 16:59:07 +0200
Subject: [PATCH] Make the validation of ISO-Schematron files optional in lxml,
depending on the availability of the RNG validation file. Some lxml
distributions discard the validation schema file due to licensing issues.
See https://bugs.launchpad.net/lxml/+bug/2024343
---
CHANGES.txt | 11 +++++++++++
doc/validation.txt | 9 +++++++++
src/lxml/isoschematron/__init__.py | 24 +++++++++++++++++++-----
3 files changed, 39 insertions(+), 5 deletions(-)
diff --git a/CHANGES.txt b/CHANGES.txt
index 24052db..e68ee9a 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -2,6 +2,17 @@
lxml changelog
==============
+4.9.3+
+======
+
+* LP#2024343: The validation of the schema file itself is now optional in the
+ ISO-Schematron implementation. This was done because some lxml distributions
+ discard the RNG validation schema file due to licensing issues. The validation
+ can now always be disabled with ``Schematron(..., validate_schema=False)``.
+ It is enabled by default if available and disabled otherwise. The module
+ constant ``lxml.isoschematron.schematron_schema_valid_supported`` can be used
+ to detect whether schema file validation is available.
+
4.9.3 (2023-07-05)
==================
diff --git a/doc/validation.txt b/doc/validation.txt
index af9d007..27c0ccd 100644
--- a/doc/validation.txt
+++ b/doc/validation.txt
@@ -615,6 +615,15 @@ The usage of validation phases is a unique feature of ISO-Schematron and can be
a very powerful tool e.g. for establishing validation stages or to provide
different validators for different "validation audiences".
+Note: Some lxml distributions exclude the validation schema file due to licensing issues.
+Since lxml 4.9.2-8, the validation of the user provided schema can be disabled with
+``Schematron(..., validate_schema=False)``.
+It is enabled by default if available and disabled otherwise. Previous versions of
+lxml always had it enabled and failed at import time if the file was not available.
+Thus, some distributions chose to remove the entire ISO-Schematron support.
+The module constant ``lxml.isoschematron.schematron_schema_valid_supported`` can be used
+since lxml 4.9.2-8 to detect whether schema file validation is available.
+
(Pre-ISO-Schematron)
--------------------
diff --git a/src/lxml/isoschematron/__init__.py b/src/lxml/isoschematron/__init__.py
index 5967b10..2846a66 100644
--- a/src/lxml/isoschematron/__init__.py
+++ b/src/lxml/isoschematron/__init__.py
@@ -61,10 +61,16 @@ iso_svrl_for_xslt1 = _etree.XSLT(_etree.parse(
svrl_validation_errors = _etree.XPath(
'//svrl:failed-assert', namespaces={'svrl': SVRL_NS})
-
# RelaxNG validator for schematron schemas
-schematron_schema_valid = _etree.RelaxNG(
- file=os.path.join(_resources_dir, 'rng', 'iso-schematron.rng'))
+schematron_schema_valid_supported = False
+try:
+ schematron_schema_valid = _etree.RelaxNG(
+ file=os.path.join(_resources_dir, 'rng', 'iso-schematron.rng'))
+ schematron_schema_valid_supported = True
+except _etree.RelaxNGParseError:
+ # Some distributions delete the file due to licensing issues.
+ def schematron_schema_valid(arg):
+ raise NotImplementedError("Validating the ISO schematron requires iso-schematron.rng")
def stylesheet_params(**kwargs):
@@ -153,6 +159,13 @@ class Schematron(_etree._Validator):
report document gets stored and can be accessed as the ``validation_report``
property.
+ If ``validate_schema`` is set to False, the validation of the schema file
+ itself is disabled. Validation happens by default after building the full
+ schema, unless the schema validation file cannot be found at import time,
+ in which case the validation gets disabled. Some lxml distributions exclude
+ this file due to licensing issues. ISO-Schematron validation can then still
+ be used normally, but the schemas themselves cannot be validated.
+
Here is a usage example::
>>> from lxml import etree
@@ -234,7 +247,8 @@ class Schematron(_etree._Validator):
def __init__(self, etree=None, file=None, include=True, expand=True,
include_params={}, expand_params={}, compile_params={},
store_schematron=False, store_xslt=False, store_report=False,
- phase=None, error_finder=ASSERTS_ONLY):
+ phase=None, error_finder=ASSERTS_ONLY,
+ validate_schema=schematron_schema_valid_supported):
super(Schematron, self).__init__()
self._store_report = store_report
@@ -273,7 +287,7 @@ class Schematron(_etree._Validator):
schematron = self._include(schematron, **include_params)
if expand:
schematron = self._expand(schematron, **expand_params)
- if not schematron_schema_valid(schematron):
+ if validate_schema and not schematron_schema_valid(schematron):
raise _etree.SchematronParseError(
"invalid schematron schema: %s" %
schematron_schema_valid.error_log)
--
2.40.1

View File

@ -0,0 +1,34 @@
From 91729cf581f764c3321f644206568f18d0fc92f4 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Tom=C3=A1=C5=A1=20Hrn=C4=8Diar?= <thrnciar@redhat.com>
Date: Thu, 18 May 2023 08:00:48 +0200
Subject: [PATCH] Skip failing test test_html_prefix_nsmap
Upstream issue: https://bugs.launchpad.net/lxml/+bug/2016939
---
src/lxml/tests/test_etree.py | 3 +++
1 file changed, 3 insertions(+)
diff --git a/src/lxml/tests/test_etree.py b/src/lxml/tests/test_etree.py
index 0339796..1994a7f 100644
--- a/src/lxml/tests/test_etree.py
+++ b/src/lxml/tests/test_etree.py
@@ -27,6 +27,8 @@ from .common_imports import SillyFileLike, LargeFileLikeUnicode, doctest, make_d
from .common_imports import canonicalize, _str, _bytes
from .common_imports import SimpleFSPath
+from unittest import skip
+
print("""
TESTED VERSION: %s""" % etree.__version__ + """
Python: %r""" % (sys.version_info,) + """
@@ -3067,6 +3069,7 @@ class ETreeOnlyTestCase(HelperTestCase):
self.assertEqual(re, e.nsmap)
self.assertEqual(r, s.nsmap)
+ @skip
def test_html_prefix_nsmap(self):
etree = self.etree
el = etree.HTML('<hha:page-description>aa</hha:page-description>').find('.//page-description')
--
2.40.1

View File

@ -0,0 +1,402 @@
From a03a4b3c6b906d33c5ef1a15f3d5ca5fff600c76 Mon Sep 17 00:00:00 2001
From: Stefan Behnel <stefan_ml@behnel.de>
Date: Fri, 23 Dec 2022 10:46:32 +0100
Subject: [PATCH] Use "noexcept" modifiers for callback functions and fix some
exception value declaration bugs found by Cython 3.0.
---
src/lxml/extensions.pxi | 6 +++---
src/lxml/includes/tree.pxd | 10 +++++-----
src/lxml/includes/xmlerror.pxd | 4 ++--
src/lxml/includes/xmlparser.pxd | 24 ++++++++++++------------
src/lxml/parser.pxi | 10 +++++-----
src/lxml/saxparser.pxi | 26 +++++++++++++-------------
src/lxml/serializer.pxi | 4 ++--
src/lxml/xmlerror.pxi | 14 +++++++-------
src/lxml/xpath.pxi | 2 +-
9 files changed, 50 insertions(+), 50 deletions(-)
diff --git a/src/lxml/extensions.pxi b/src/lxml/extensions.pxi
index 35a321b7a..80e53d7b5 100644
--- a/src/lxml/extensions.pxi
+++ b/src/lxml/extensions.pxi
@@ -393,7 +393,7 @@ cdef tuple LIBXML2_XPATH_ERROR_MESSAGES = (
b"?? Unknown error ??\n",
)
-cdef void _forwardXPathError(void* c_ctxt, xmlerror.xmlError* c_error) with gil:
+cdef void _forwardXPathError(void* c_ctxt, xmlerror.xmlError* c_error) noexcept with gil:
cdef xmlerror.xmlError error
cdef int xpath_code
if c_error.message is not NULL:
@@ -414,7 +414,7 @@ cdef void _forwardXPathError(void* c_ctxt, xmlerror.xmlError* c_error) with gil:
(<_BaseContext>c_ctxt)._error_log._receive(&error)
-cdef void _receiveXPathError(void* c_context, xmlerror.xmlError* error) nogil:
+cdef void _receiveXPathError(void* c_context, xmlerror.xmlError* error) noexcept nogil:
if not __DEBUG:
return
if c_context is NULL:
@@ -851,7 +851,7 @@ cdef void _extension_function_call(_BaseContext context, function,
# lookup the function by name and call it
cdef void _xpath_function_call(xpath.xmlXPathParserContext* ctxt,
- int nargs) with gil:
+ int nargs) noexcept with gil:
cdef _BaseContext context
cdef xpath.xmlXPathContext* rctxt = ctxt.context
context = <_BaseContext> rctxt.userData
diff --git a/src/lxml/includes/tree.pxd b/src/lxml/includes/tree.pxd
index 03d558a33..312537cbd 100644
--- a/src/lxml/includes/tree.pxd
+++ b/src/lxml/includes/tree.pxd
@@ -65,7 +65,7 @@ cdef extern from "libxml/chvalid.h" nogil:
cdef extern from "libxml/hash.h":
ctypedef struct xmlHashTable
- ctypedef void (*xmlHashScanner)(void* payload, void* data, const_xmlChar* name) # may require GIL!
+ ctypedef void (*xmlHashScanner)(void* payload, void* data, const_xmlChar* name) noexcept # may require GIL!
void xmlHashScan(xmlHashTable* table, xmlHashScanner f, void* data) nogil
void* xmlHashLookup(xmlHashTable* table, const_xmlChar* name) nogil
ctypedef void (*xmlHashDeallocator)(void *payload, xmlChar *name)
@@ -411,12 +411,12 @@ cdef extern from "libxml/xmlIO.h":
cdef int xmlOutputBufferClose(xmlOutputBuffer* out) nogil
ctypedef int (*xmlInputReadCallback)(void* context,
- char* buffer, int len) nogil
- ctypedef int (*xmlInputCloseCallback)(void* context) nogil
+ char* buffer, int len) except -1 nogil
+ ctypedef int (*xmlInputCloseCallback)(void* context) except -1 nogil
ctypedef int (*xmlOutputWriteCallback)(void* context,
- char* buffer, int len)
- ctypedef int (*xmlOutputCloseCallback)(void* context)
+ char* buffer, int len) except -1
+ ctypedef int (*xmlOutputCloseCallback)(void* context) except -1
cdef xmlOutputBuffer* xmlAllocOutputBuffer(
xmlCharEncodingHandler* encoder) nogil
diff --git a/src/lxml/includes/xmlerror.pxd b/src/lxml/includes/xmlerror.pxd
index c5ac6a0aa..6967378b7 100644
--- a/src/lxml/includes/xmlerror.pxd
+++ b/src/lxml/includes/xmlerror.pxd
@@ -838,9 +838,9 @@ cdef extern from "libxml/xmlerror.h" nogil:
int int2
void* node
- ctypedef void (*xmlGenericErrorFunc)(void* ctxt, char* msg, ...)
+ ctypedef void (*xmlGenericErrorFunc)(void* ctxt, char* msg, ...) noexcept
ctypedef void (*xmlStructuredErrorFunc)(void* userData,
- xmlError* error)
+ xmlError* error) noexcept
cdef void xmlSetGenericErrorFunc(
void* ctxt, xmlGenericErrorFunc func)
diff --git a/src/lxml/includes/xmlparser.pxd b/src/lxml/includes/xmlparser.pxd
index 9f3056248..c94212cee 100644
--- a/src/lxml/includes/xmlparser.pxd
+++ b/src/lxml/includes/xmlparser.pxd
@@ -15,37 +15,37 @@ cdef extern from "libxml/parser.h" nogil:
const_xmlChar** namespaces,
int nb_attributes,
int nb_defaulted,
- const_xmlChar** attributes)
+ const_xmlChar** attributes) noexcept
ctypedef void (*endElementNsSAX2Func)(void* ctx,
const_xmlChar* localname,
const_xmlChar* prefix,
- const_xmlChar* URI)
+ const_xmlChar* URI) noexcept
- ctypedef void (*startElementSAXFunc)(void* ctx, const_xmlChar* name, const_xmlChar** atts)
+ ctypedef void (*startElementSAXFunc)(void* ctx, const_xmlChar* name, const_xmlChar** atts) noexcept
- ctypedef void (*endElementSAXFunc)(void* ctx, const_xmlChar* name)
+ ctypedef void (*endElementSAXFunc)(void* ctx, const_xmlChar* name) noexcept
- ctypedef void (*charactersSAXFunc)(void* ctx, const_xmlChar* ch, int len)
+ ctypedef void (*charactersSAXFunc)(void* ctx, const_xmlChar* ch, int len) noexcept
- ctypedef void (*cdataBlockSAXFunc)(void* ctx, const_xmlChar* value, int len)
+ ctypedef void (*cdataBlockSAXFunc)(void* ctx, const_xmlChar* value, int len) noexcept
- ctypedef void (*commentSAXFunc)(void* ctx, const_xmlChar* value)
+ ctypedef void (*commentSAXFunc)(void* ctx, const_xmlChar* value) noexcept
ctypedef void (*processingInstructionSAXFunc)(void* ctx,
const_xmlChar* target,
- const_xmlChar* data)
+ const_xmlChar* data) noexcept
ctypedef void (*internalSubsetSAXFunc)(void* ctx,
const_xmlChar* name,
const_xmlChar* externalID,
- const_xmlChar* systemID)
+ const_xmlChar* systemID) noexcept
- ctypedef void (*endDocumentSAXFunc)(void* ctx)
+ ctypedef void (*endDocumentSAXFunc)(void* ctx) noexcept
- ctypedef void (*startDocumentSAXFunc)(void* ctx)
+ ctypedef void (*startDocumentSAXFunc)(void* ctx) noexcept
- ctypedef void (*referenceSAXFunc)(void * ctx, const_xmlChar* name)
+ ctypedef void (*referenceSAXFunc)(void * ctx, const_xmlChar* name) noexcept
cdef int XML_SAX2_MAGIC
diff --git a/src/lxml/parser.pxi b/src/lxml/parser.pxi
index f0c8c6b64..e1e9da9f0 100644
--- a/src/lxml/parser.pxi
+++ b/src/lxml/parser.pxi
@@ -402,10 +402,10 @@ cdef class _FileReaderContext:
finally:
return c_byte_count # swallow any exceptions
-cdef int _readFilelikeParser(void* ctxt, char* c_buffer, int c_size) with gil:
+cdef int _readFilelikeParser(void* ctxt, char* c_buffer, int c_size) except -1 with gil:
return (<_FileReaderContext>ctxt).copyToBuffer(c_buffer, c_size)
-cdef int _readFileParser(void* ctxt, char* c_buffer, int c_size) nogil:
+cdef int _readFileParser(void* ctxt, char* c_buffer, int c_size) except -1 nogil:
return stdio.fread(c_buffer, 1, c_size, <stdio.FILE*>ctxt)
############################################################
@@ -626,10 +626,10 @@ cdef _initParserContext(_ParserContext context,
if c_ctxt is not NULL:
context._initParserContext(c_ctxt)
-cdef void _forwardParserError(xmlparser.xmlParserCtxt* _parser_context, xmlerror.xmlError* error) with gil:
+cdef void _forwardParserError(xmlparser.xmlParserCtxt* _parser_context, xmlerror.xmlError* error) noexcept with gil:
(<_ParserContext>_parser_context._private)._error_log._receive(error)
-cdef void _receiveParserError(void* c_context, xmlerror.xmlError* error) nogil:
+cdef void _receiveParserError(void* c_context, xmlerror.xmlError* error) noexcept nogil:
if __DEBUG:
if c_context is NULL or (<xmlparser.xmlParserCtxt*>c_context)._private is NULL:
_forwardError(NULL, error)
@@ -1207,7 +1207,7 @@ cdef class _BaseParser:
context.cleanup()
-cdef void _initSaxDocument(void* ctxt) with gil:
+cdef void _initSaxDocument(void* ctxt) noexcept with gil:
xmlparser.xmlSAX2StartDocument(ctxt)
c_ctxt = <xmlparser.xmlParserCtxt*>ctxt
c_doc = c_ctxt.myDoc
diff --git a/src/lxml/saxparser.pxi b/src/lxml/saxparser.pxi
index 49e72beaf..1737f0801 100644
--- a/src/lxml/saxparser.pxi
+++ b/src/lxml/saxparser.pxi
@@ -294,7 +294,7 @@ cdef void _handleSaxStart(
const_xmlChar* c_namespace, int c_nb_namespaces,
const_xmlChar** c_namespaces,
int c_nb_attributes, int c_nb_defaulted,
- const_xmlChar** c_attributes) with gil:
+ const_xmlChar** c_attributes) noexcept with gil:
cdef int i
cdef size_t c_len
c_ctxt = <xmlparser.xmlParserCtxt*>ctxt
@@ -336,7 +336,7 @@ cdef void _handleSaxTargetStart(
const_xmlChar* c_namespace, int c_nb_namespaces,
const_xmlChar** c_namespaces,
int c_nb_attributes, int c_nb_defaulted,
- const_xmlChar** c_attributes) with gil:
+ const_xmlChar** c_attributes) noexcept with gil:
cdef int i
cdef size_t c_len
c_ctxt = <xmlparser.xmlParserCtxt*>ctxt
@@ -407,7 +407,7 @@ cdef void _handleSaxTargetStart(
cdef void _handleSaxStartNoNs(void* ctxt, const_xmlChar* c_name,
- const_xmlChar** c_attributes) with gil:
+ const_xmlChar** c_attributes) noexcept with gil:
c_ctxt = <xmlparser.xmlParserCtxt*>ctxt
if c_ctxt._private is NULL or c_ctxt.disableSAX:
return
@@ -426,7 +426,7 @@ cdef void _handleSaxStartNoNs(void* ctxt, const_xmlChar* c_name,
cdef void _handleSaxTargetStartNoNs(void* ctxt, const_xmlChar* c_name,
- const_xmlChar** c_attributes) with gil:
+ const_xmlChar** c_attributes) noexcept with gil:
c_ctxt = <xmlparser.xmlParserCtxt*>ctxt
if c_ctxt._private is NULL or c_ctxt.disableSAX:
return
@@ -483,7 +483,7 @@ cdef int _pushSaxStartEvent(_SaxParserContext context,
cdef void _handleSaxEnd(void* ctxt, const_xmlChar* c_localname,
const_xmlChar* c_prefix,
- const_xmlChar* c_namespace) with gil:
+ const_xmlChar* c_namespace) noexcept with gil:
c_ctxt = <xmlparser.xmlParserCtxt*>ctxt
if c_ctxt._private is NULL or c_ctxt.disableSAX:
return
@@ -506,7 +506,7 @@ cdef void _handleSaxEnd(void* ctxt, const_xmlChar* c_localname,
return # swallow any further exceptions
-cdef void _handleSaxEndNoNs(void* ctxt, const_xmlChar* c_name) with gil:
+cdef void _handleSaxEndNoNs(void* ctxt, const_xmlChar* c_name) noexcept with gil:
c_ctxt = <xmlparser.xmlParserCtxt*>ctxt
if c_ctxt._private is NULL or c_ctxt.disableSAX:
return
@@ -558,7 +558,7 @@ cdef int _pushSaxEndEvent(_SaxParserContext context,
return 0
-cdef void _handleSaxData(void* ctxt, const_xmlChar* c_data, int data_len) with gil:
+cdef void _handleSaxData(void* ctxt, const_xmlChar* c_data, int data_len) noexcept with gil:
# can only be called if parsing with a target
c_ctxt = <xmlparser.xmlParserCtxt*>ctxt
if c_ctxt._private is NULL or c_ctxt.disableSAX:
@@ -575,7 +575,7 @@ cdef void _handleSaxData(void* ctxt, const_xmlChar* c_data, int data_len) with g
cdef void _handleSaxTargetDoctype(void* ctxt, const_xmlChar* c_name,
const_xmlChar* c_public,
- const_xmlChar* c_system) with gil:
+ const_xmlChar* c_system) noexcept with gil:
# can only be called if parsing with a target
c_ctxt = <xmlparser.xmlParserCtxt*>ctxt
if c_ctxt._private is NULL or c_ctxt.disableSAX:
@@ -592,7 +592,7 @@ cdef void _handleSaxTargetDoctype(void* ctxt, const_xmlChar* c_name,
return # swallow any further exceptions
-cdef void _handleSaxStartDocument(void* ctxt) with gil:
+cdef void _handleSaxStartDocument(void* ctxt) noexcept with gil:
c_ctxt = <xmlparser.xmlParserCtxt*>ctxt
if c_ctxt._private is NULL or c_ctxt.disableSAX:
return
@@ -608,7 +608,7 @@ cdef void _handleSaxStartDocument(void* ctxt) with gil:
cdef void _handleSaxTargetPI(void* ctxt, const_xmlChar* c_target,
- const_xmlChar* c_data) with gil:
+ const_xmlChar* c_data) noexcept with gil:
# can only be called if parsing with a target
c_ctxt = <xmlparser.xmlParserCtxt*>ctxt
if c_ctxt._private is NULL or c_ctxt.disableSAX:
@@ -627,7 +627,7 @@ cdef void _handleSaxTargetPI(void* ctxt, const_xmlChar* c_target,
cdef void _handleSaxPIEvent(void* ctxt, const_xmlChar* target,
- const_xmlChar* data) with gil:
+ const_xmlChar* data) noexcept with gil:
# can only be called when collecting pi events
c_ctxt = <xmlparser.xmlParserCtxt*>ctxt
if c_ctxt._private is NULL or c_ctxt.disableSAX:
@@ -645,7 +645,7 @@ cdef void _handleSaxPIEvent(void* ctxt, const_xmlChar* target,
return # swallow any further exceptions
-cdef void _handleSaxTargetComment(void* ctxt, const_xmlChar* c_data) with gil:
+cdef void _handleSaxTargetComment(void* ctxt, const_xmlChar* c_data) noexcept with gil:
# can only be called if parsing with a target
c_ctxt = <xmlparser.xmlParserCtxt*>ctxt
if c_ctxt._private is NULL or c_ctxt.disableSAX:
@@ -661,7 +661,7 @@ cdef void _handleSaxTargetComment(void* ctxt, const_xmlChar* c_data) with gil:
return # swallow any further exceptions
-cdef void _handleSaxComment(void* ctxt, const_xmlChar* text) with gil:
+cdef void _handleSaxComment(void* ctxt, const_xmlChar* text) noexcept with gil:
# can only be called when collecting comment events
c_ctxt = <xmlparser.xmlParserCtxt*>ctxt
if c_ctxt._private is NULL or c_ctxt.disableSAX:
diff --git a/src/lxml/serializer.pxi b/src/lxml/serializer.pxi
index 79a02829e..e1c76e1ba 100644
--- a/src/lxml/serializer.pxi
+++ b/src/lxml/serializer.pxi
@@ -699,10 +699,10 @@ cdef class _FilelikeWriter:
finally:
return retval # and swallow any further exceptions
-cdef int _writeFilelikeWriter(void* ctxt, char* c_buffer, int length):
+cdef int _writeFilelikeWriter(void* ctxt, char* c_buffer, int length) except -1:
return (<_FilelikeWriter>ctxt).write(c_buffer, length)
-cdef int _closeFilelikeWriter(void* ctxt):
+cdef int _closeFilelikeWriter(void* ctxt) except -1:
return (<_FilelikeWriter>ctxt).close()
cdef _tofilelike(f, _Element element, encoding, doctype, method,
diff --git a/src/lxml/xmlerror.pxi b/src/lxml/xmlerror.pxi
index 1b50444fb..793e1d923 100644
--- a/src/lxml/xmlerror.pxi
+++ b/src/lxml/xmlerror.pxi
@@ -634,7 +634,7 @@ def use_global_python_log(PyErrorLog log not None):
# local log functions: forward error to logger object
-cdef void _forwardError(void* c_log_handler, xmlerror.xmlError* error) with gil:
+cdef void _forwardError(void* c_log_handler, xmlerror.xmlError* error) noexcept with gil:
cdef _BaseErrorLog log_handler
if c_log_handler is not NULL:
log_handler = <_BaseErrorLog>c_log_handler
@@ -645,27 +645,27 @@ cdef void _forwardError(void* c_log_handler, xmlerror.xmlError* error) with gil:
log_handler._receive(error)
-cdef void _receiveError(void* c_log_handler, xmlerror.xmlError* error) nogil:
+cdef void _receiveError(void* c_log_handler, xmlerror.xmlError* error) noexcept nogil:
# no Python objects here, may be called without thread context !
if __DEBUG:
_forwardError(c_log_handler, error)
-cdef void _receiveXSLTError(void* c_log_handler, char* msg, ...) nogil:
+cdef void _receiveXSLTError(void* c_log_handler, char* msg, ...) noexcept nogil:
# no Python objects here, may be called without thread context !
cdef cvarargs.va_list args
cvarargs.va_start(args, msg)
_receiveGenericError(c_log_handler, xmlerror.XML_FROM_XSLT, msg, args)
cvarargs.va_end(args)
-cdef void _receiveRelaxNGParseError(void* c_log_handler, char* msg, ...) nogil:
+cdef void _receiveRelaxNGParseError(void* c_log_handler, char* msg, ...) noexcept nogil:
# no Python objects here, may be called without thread context !
cdef cvarargs.va_list args
cvarargs.va_start(args, msg)
_receiveGenericError(c_log_handler, xmlerror.XML_FROM_RELAXNGP, msg, args)
cvarargs.va_end(args)
-cdef void _receiveRelaxNGValidationError(void* c_log_handler, char* msg, ...) nogil:
+cdef void _receiveRelaxNGValidationError(void* c_log_handler, char* msg, ...) noexcept nogil:
# no Python objects here, may be called without thread context !
cdef cvarargs.va_list args
cvarargs.va_start(args, msg)
@@ -673,7 +673,7 @@ cdef void _receiveRelaxNGValidationError(void* c_log_handler, char* msg, ...) no
cvarargs.va_end(args)
# dummy function: no log output at all
-cdef void _nullGenericErrorFunc(void* ctxt, char* msg, ...) nogil:
+cdef void _nullGenericErrorFunc(void* ctxt, char* msg, ...) noexcept nogil:
pass
@@ -694,7 +694,7 @@ cdef void _connectGenericErrorLog(log, int c_domain=-1):
cdef void _receiveGenericError(void* c_log_handler, int c_domain,
- char* msg, cvarargs.va_list args) nogil:
+ char* msg, cvarargs.va_list args) noexcept nogil:
# no Python objects here, may be called without thread context !
cdef xmlerror.xmlError c_error
cdef char* c_text
diff --git a/src/lxml/xpath.pxi b/src/lxml/xpath.pxi
index a7cae4bff..704338e89 100644
--- a/src/lxml/xpath.pxi
+++ b/src/lxml/xpath.pxi
@@ -99,7 +99,7 @@ cdef class _XPathContext(_BaseContext):
cdef void _registerExsltFunctionsForNamespaces(
- void* _c_href, void* _ctxt, const_xmlChar* c_prefix):
+ void* _c_href, void* _ctxt, const_xmlChar* c_prefix) noexcept:
c_href = <const_xmlChar*> _c_href
ctxt = <xpath.xmlXPathContext*> _ctxt

1
ci.fmf Normal file
View File

@ -0,0 +1 @@
resultsdb-testcase: separate

File diff suppressed because it is too large Load Diff

8
gating.yaml Normal file
View File

@ -0,0 +1,8 @@
--- !Policy
product_versions:
- fedora-*
decision_contexts:
- bodhi_update_push_testing
- bodhi_update_push_stable
rules:
- !PassingTestCaseRule {test_case_name: fedora-ci.koji-build./plans/smoke.functional}

28
get-lxml-source.sh Executable file
View File

@ -0,0 +1,28 @@
#! /bin/bash -ex
# Download a release of lxml (if missing) and remove the isoschematron module from it
version=$1
if [ -z "${version}" ]; then
echo "Usage: $0 VERSION" >& 2
echo "" >& 2
echo "example: $0 4.9.2" >& 2
exit 1
fi
versionedname=lxml-${version}
orig_archive=${versionedname}.tar.gz
new_archive=${versionedname}-no-isoschematron-rng.tar.gz
if [ ! -e ${orig_archive} ]; then
wget -N https://files.pythonhosted.org/packages/source/l/lxml/${orig_archive}
fi
deleted_directory=lxml-${version}/src/lxml/isoschematron/resources/rng
# tar --delete does not operate on compressed archives, so do
# gz decompression explicitly
gzip --decompress ${orig_archive}
tar -v --delete -f ${orig_archive//.gz} ${deleted_directory}
gzip -cf ${orig_archive//.gz} > ${new_archive}

View File

@ -0,0 +1,7 @@
import lxml.etree as et
s = '<foo><bar baz="xyzzy">a<![CDATA[b]]>c</bar></foo>'
x = et.fromstring(s)
t = x.find('bar').text
print(t)
if t != 'abc':
raise Exception()

12
plans/smoke.fmf Normal file
View File

@ -0,0 +1,12 @@
summary: Basic smoke test
discover:
how: shell
tests:
- name: /smoke/import-python-module
test: |
python3 -c 'import importlib as il; print(il.import_module("lxml"))'
- name: /smoke/etree-fromstring
test: |
python3 plans/etree-fromstring.py
execute:
how: tmt

1728
python-lxml.spec Normal file

File diff suppressed because it is too large Load Diff

1
sources Normal file
View File

@ -0,0 +1 @@
SHA512 (lxml-4.9.3-no-isoschematron-rng.tar.gz) = e3e289ad0aa4bec75fbdee5682d1047c2f98f48f9fd39571175f6a758a10ab2266ed4591bf9dcb65a387ee22cf9de4adac57997dca57b95e0bae07268aff33fe