import python3.11-requests-2.28.1-1.el8
This commit is contained in:
commit
10ebe7ba94
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/requests-v2.28.1.tar.gz
|
1
.python3.11-requests.metadata
Normal file
1
.python3.11-requests.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
9b366622e4d5f270f6a920a754f6b6ceeb211a47 SOURCES/requests-v2.28.1.tar.gz
|
37
SOURCES/requests-2.28.1-system-certs.patch
Normal file
37
SOURCES/requests-2.28.1-system-certs.patch
Normal file
@ -0,0 +1,37 @@
|
|||||||
|
--- requests-2.28.1/requests/certs.py 2022-07-12 13:55:25.378079641 -0700
|
||||||
|
+++ requests-2.28.1/requests/certs.py.new 2022-07-12 13:57:03.834621295 -0700
|
||||||
|
@@ -9,8 +9,13 @@
|
||||||
|
If you are packaging Requests, e.g., for a Linux distribution or a managed
|
||||||
|
environment, you can change the definition of where() to return a separately
|
||||||
|
packaged CA bundle.
|
||||||
|
+
|
||||||
|
+This Fedora-patched package returns "/etc/pki/tls/certs/ca-bundle.crt" provided
|
||||||
|
+by the ca-certificates RPM package.
|
||||||
|
"""
|
||||||
|
-from certifi import where
|
||||||
|
+def where():
|
||||||
|
+ """Return the absolute path to the system CA bundle."""
|
||||||
|
+ return '/etc/pki/tls/certs/ca-bundle.crt'
|
||||||
|
|
||||||
|
if __name__ == "__main__":
|
||||||
|
print(where())
|
||||||
|
--- requests-2.28.1/setup.py 2022-06-29 08:09:11.000000000 -0700
|
||||||
|
+++ requests-2.28.1/setup.py.new 2022-07-12 13:58:33.830116402 -0700
|
||||||
|
@@ -62,7 +62,6 @@
|
||||||
|
"charset_normalizer>=2,<3",
|
||||||
|
"idna>=2.5,<4",
|
||||||
|
"urllib3>=1.21.1,<1.27",
|
||||||
|
- "certifi>=2017.4.17",
|
||||||
|
]
|
||||||
|
test_requirements = [
|
||||||
|
"pytest-httpbin==0.0.7",
|
||||||
|
--- requests-2.28.1/setup.cfg 2022-06-29 08:09:11.000000000 -0700
|
||||||
|
+++ requests-2.28.1/setup.cfg.new 2022-07-12 13:58:19.619038220 -0700
|
||||||
|
@@ -4,7 +4,6 @@
|
||||||
|
socks
|
||||||
|
use_chardet_on_py3
|
||||||
|
requires-dist =
|
||||||
|
- certifi>=2017.4.17
|
||||||
|
charset_normalizer>=2,<3
|
||||||
|
idna>=2.5,<4
|
||||||
|
urllib3>=1.21.1,<1.27
|
108
SPECS/python3.11-requests.spec
Normal file
108
SPECS/python3.11-requests.spec
Normal file
@ -0,0 +1,108 @@
|
|||||||
|
%global __python3 /usr/bin/python3.11
|
||||||
|
%global python3_pkgversion 3.11
|
||||||
|
|
||||||
|
# RHEL: Tests disabled due to missing dependencies
|
||||||
|
%bcond_with tests
|
||||||
|
|
||||||
|
Name: python%{python3_pkgversion}-requests
|
||||||
|
Version: 2.28.1
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: HTTP library, written in Python, for human beings
|
||||||
|
|
||||||
|
License: ASL 2.0
|
||||||
|
URL: https://pypi.io/project/requests
|
||||||
|
Source0: https://github.com/requests/requests/archive/v%{version}/requests-v%{version}.tar.gz
|
||||||
|
# Explicitly use the system certificates in ca-certificates.
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=904614
|
||||||
|
Patch0: requests-2.28.1-system-certs.patch
|
||||||
|
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
BuildRequires: python%{python3_pkgversion}-devel
|
||||||
|
BuildRequires: python%{python3_pkgversion}-rpm-macros
|
||||||
|
BuildRequires: python%{python3_pkgversion}-charset-normalizer
|
||||||
|
BuildRequires: python%{python3_pkgversion}-urllib3
|
||||||
|
BuildRequires: python%{python3_pkgversion}-idna
|
||||||
|
# pygments is used for syntax highlighting in the docs - disabled due to missing deps
|
||||||
|
#BuildRequires: python%%{python3_pkgversion}-pygments
|
||||||
|
BuildRequires: python%{python3_pkgversion}-setuptools
|
||||||
|
|
||||||
|
%if %{with tests}
|
||||||
|
BuildRequires: python%{python3_pkgversion}-pytest
|
||||||
|
BuildRequires: python%{python3_pkgversion}-pytest-httpbin
|
||||||
|
BuildRequires: python%{python3_pkgversion}-pytest-mock
|
||||||
|
BuildRequires: python%{python3_pkgversion}-trustme
|
||||||
|
%endif
|
||||||
|
|
||||||
|
Requires: python%{python3_pkgversion}-charset-normalizer
|
||||||
|
Requires: python%{python3_pkgversion}-urllib3
|
||||||
|
Requires: python%{python3_pkgversion}-idna
|
||||||
|
|
||||||
|
%description
|
||||||
|
Most existing Python modules for sending HTTP requests are extremely verbose and
|
||||||
|
cumbersome. Python’s built-in urllib2 module provides most of the HTTP
|
||||||
|
capabilities you should need, but the API is thoroughly broken. This library is
|
||||||
|
designed to make HTTP requests easy for developers.
|
||||||
|
|
||||||
|
|
||||||
|
%{?python_extras_subpkg:%python_extras_subpkg -n python%{python3_pkgversion}-requests -i %{python3_sitelib}/*.egg-info security socks}
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -p1 -n requests-%{version}
|
||||||
|
|
||||||
|
# env shebang in nonexecutable file
|
||||||
|
sed -i '/#!\/usr\/.*python/d' requests/certs.py
|
||||||
|
|
||||||
|
# Some doctests use the internet and fail to pass in Koji. Since doctests don't have names, I don't
|
||||||
|
# know a way to skip them. We also don't want to patch them out, because patching them out will
|
||||||
|
# change the docs. Thus, we set pytest not to run doctests at all.
|
||||||
|
sed -i 's/ --doctest-modules//' pyproject.toml
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
%py3_build
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
%py3_install
|
||||||
|
|
||||||
|
|
||||||
|
%if %{with tests}
|
||||||
|
%check
|
||||||
|
%pytest -v
|
||||||
|
%endif
|
||||||
|
|
||||||
|
|
||||||
|
%files -n python%{python3_pkgversion}-requests
|
||||||
|
%license LICENSE
|
||||||
|
%doc README.md HISTORY.md
|
||||||
|
%{python3_sitelib}/*.egg-info/
|
||||||
|
%{python3_sitelib}/requests/
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Nov 29 2022 Charalampos Stratakis <cstratak@redhat.com> - 2.28.1-1
|
||||||
|
- Initial package
|
||||||
|
- Fedora contributions by:
|
||||||
|
Adam Williamson <awilliam@redhat.com>
|
||||||
|
Arun SAG <sagarun@gmail.com>
|
||||||
|
Charalampos Stratakis <cstratak@redhat.com>
|
||||||
|
David Malcolm <dmalcolm@redhat.com>
|
||||||
|
Dennis Gilmore <dennis@ausil.us>
|
||||||
|
Igor Gnatenko <ignatenkobrain@fedoraproject.org>
|
||||||
|
Iryna Shcherbina <shcherbina.iryna@gmail.com>
|
||||||
|
Jeremy Cline <jeremy@jcline.org>
|
||||||
|
Karolina Surma <ksurma@redhat.com>
|
||||||
|
Kevin Fenzi <kevin@scrye.com>
|
||||||
|
Lumir Balhar <lbalhar@redhat.com>
|
||||||
|
Miro Hrončok <miro@hroncok.cz>
|
||||||
|
Petr Viktorin <pviktori@redhat.com>
|
||||||
|
Ralph Bean <rbean@redhat.com>
|
||||||
|
Randy Barlow <randy@electronsweatshop.com>
|
||||||
|
Rex Dieter <rdieter@math.unl.edu>
|
||||||
|
Robert Kuska <rkuska@redhat.com>
|
||||||
|
Slavek Kabrda <bkabrda@redhat.com>
|
||||||
|
Stephen Gallagher <sgallagh@redhat.com>
|
||||||
|
Tom Callaway <spot@fedoraproject.org>
|
||||||
|
Toshio Kuratomi <toshio@fedoraproject.org>
|
||||||
|
yatinkarel <ykarel@redhat.com>
|
Loading…
Reference in New Issue
Block a user