diff --git a/SPECS/python3.11-pybind11.spec b/SPECS/python3.11-pybind11.spec
index d2ab215..bc0d6bb 100644
--- a/SPECS/python3.11-pybind11.spec
+++ b/SPECS/python3.11-pybind11.spec
@@ -7,6 +7,9 @@
 # https://fedoraproject.org/wiki/Packaging:Guidelines#Packaging_Header_Only_Libraries
 %global debug_package %{nil}
 
+# Exclude automatic provides without python3.11 in the name
+%global __provides_exclude cmake|pkgconfig
+
 # Whether to run the tests, enabled by default
 # ppc64le tests cannot be compiled with lto enabled so we disable them
 # there for now
@@ -20,7 +23,7 @@
 
 Name:    python%{python3_pkgversion}-pybind11
 Version: 2.10.3
-Release: 2%{?dist}
+Release: 3%{?dist}
 Summary: Seamless operability between C++11 and Python
 License: BSD
 URL:   https://github.com/pybind/pybind11
@@ -63,11 +66,12 @@ Summary:  Development headers for pybind11
 # pybind11-devel subpackage in any other stack as well, the files from these
 # packages will conflict. The package name is namespaced so that customers can
 # decide which to install, but the packages will conflict with each other.
-Provides:   %{modname}-devel = %{version}-%{release}
+# Whenever python3.X-pybind11-devel is introduced, it needs to explicitly
+# conflict with all the previous python3.X-pybind11-devel packages as well as
+# the non-namespaced pybind11-devel package from the main Python stack.
 Conflicts:  %{modname}-devel < %{version}-%{release} 
 
 # https://fedoraproject.org/wiki/Packaging:Guidelines#Packaging_Header_Only_Libraries
-Provides: %{modname}-static = %{version}-%{release}
 Provides: %{name}-static = %{version}-%{release}
 # For dir ownership
 Requires: cmake
@@ -122,6 +126,10 @@ PYBIND11_USE_CMAKE=true %py3_install "--install-purelib" "%{python3_sitearch}"
 %{python3_sitearch}/%{modname}-%{version}-py%{python3_version}.egg-info
 
 %changelog
+* Fri Nov 24 2023 Lumír Balhar <lbalhar@redhat.com> - 2.10.3-3
+- Remove provides without python3.11 in the name
+Resolves: RHEL-5571
+
 * Mon Feb 20 2023 Charalampos Stratakis <cstratak@redhat.com> - 2.10.3-2
 - Enable tests