129 lines
4.6 KiB
RPMSpec
129 lines
4.6 KiB
RPMSpec
%bcond_without tests
|
|
|
|
%global pypi_name wcwidth
|
|
|
|
Name: python-%{pypi_name}
|
|
Version: 0.1.7
|
|
Release: 16%{?dist}
|
|
Summary: Measures number of Terminal column cells of wide-character codes
|
|
|
|
License: MIT
|
|
URL: https://github.com/jquast/wcwidth
|
|
Source0: %pypi_source
|
|
BuildArch: noarch
|
|
# Exclude i686 arch. Due to a modularity issue it's being added to the
|
|
# x86_64 compose of CRB, but we don't want to ship it at all.
|
|
# See: https://projects.engineering.redhat.com/browse/RCM-72605
|
|
ExcludeArch: i686
|
|
|
|
%description
|
|
This API is mainly for Terminal Emulator implementors, or those writing programs
|
|
that expect to interpreted by a terminal emulator and wish to determine the
|
|
printable width of a string on a Terminal.
|
|
|
|
%package -n python%{python3_pkgversion}-%{pypi_name}
|
|
Summary: %{summary}
|
|
BuildRequires: python%{python3_pkgversion}-devel
|
|
BuildRequires: python%{python3_pkgversion}-setuptools
|
|
BuildRequires: python%{python3_pkgversion}-rpm-macros
|
|
%if %{with tests}
|
|
BuildRequires: python%{python3_pkgversion}-pytest
|
|
%endif
|
|
%{?python_provide:%python_provide python%{python3_pkgversion}-%{pypi_name}}
|
|
|
|
%description -n python%{python3_pkgversion}-%{pypi_name}
|
|
This API is mainly for Terminal Emulator implementors, or those writing programs
|
|
that expect to interpreted by a terminal emulator and wish to determine the
|
|
printable width of a string on a Terminal.
|
|
|
|
%prep
|
|
%setup -q -n %{pypi_name}-%{version}
|
|
|
|
%build
|
|
%py3_build
|
|
|
|
%install
|
|
%py3_install
|
|
|
|
%if %{with tests}
|
|
%check
|
|
%{__python3} -m pytest -v
|
|
%endif # with tests
|
|
|
|
%files -n python%{python3_pkgversion}-%{pypi_name}
|
|
%doc README.rst
|
|
%license LICENSE.txt
|
|
%{python3_sitelib}/%{pypi_name}
|
|
%{python3_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info
|
|
|
|
%changelog
|
|
* Fri Dec 13 2019 Tomas Orsava <torsava@redhat.com> - 0.1.7-16
|
|
- Exclude unsupported i686 arch
|
|
|
|
* Tue Nov 19 2019 Lumír Balhar <lbalhar@redhat.com> - 0.1.7-15
|
|
- Adjusted for Python 3.8 module in RHEL 8
|
|
|
|
* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 0.1.7-14
|
|
- Rebuilt for Python 3.8.0rc1 (#1748018)
|
|
- Resolves: rhbz#1772819
|
|
|
|
* Sun Aug 18 2019 Miro Hrončok <mhroncok@redhat.com> - 0.1.7-13
|
|
- Rebuilt for Python 3.8
|
|
|
|
* Thu Aug 15 2019 Miro Hrončok <mhroncok@redhat.com> - 0.1.7-12
|
|
- Bootstrap for Python 3.8
|
|
|
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.7-11
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
|
|
|
* Wed Mar 13 2019 Miro Hrončok <mhroncok@redhat.com> - 0.1.7-10
|
|
- Subpackage python2-wcwidth has been removed
|
|
See https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal
|
|
|
|
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.7-9
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
|
|
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.7-8
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
|
|
|
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 0.1.7-7
|
|
- Rebuilt for Python 3.7
|
|
|
|
* Wed Feb 28 2018 Iryna Shcherbina <ishcherb@redhat.com> - 0.1.7-6
|
|
- Update Python 2 dependency declarations to new packaging standards
|
|
(See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
|
|
|
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.7-5
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
|
|
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.7-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
|
|
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.7-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
|
|
|
* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 0.1.7-2
|
|
- Rebuild for Python 3.6
|
|
|
|
* Tue Dec 13 2016 Fabio Alessandro Locati <fale@fedoraproject.org> - 0.1.7-1
|
|
- Update to 0.1.7
|
|
|
|
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.6-4
|
|
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
|
|
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.6-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
|
|
|
* Tue Jan 12 2016 Fabio Alessandro Locati <fale@fedoraproject.org> - 0.1.6-2
|
|
- Provide python-wcwidth for EL6
|
|
|
|
* Sat Jan 09 2016 Fabio Alessandro Locati <fale@fedoraproject.org> - 0.1.6-1
|
|
- Update to new upstream
|
|
- Remove external LICENSE thanks to the new version
|
|
|
|
* Wed Jan 06 2016 Fabio Alessandro Locati <fale@fedoraproject.org> - 0.1.5-2
|
|
- Remove shabang from file that was not executable
|
|
|
|
* Tue Dec 29 2015 Fabio Alessandro Locati <fale@fedoraproject.org> - 0.1.5-1
|
|
- Initial package.
|