Latest upstream.
This commit is contained in:
parent
89b18071bd
commit
4a646b98e0
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
/urllib3-1.5.tar.gz
|
||||
/urllib3-1.7.tar.gz
|
||||
/urllib3-1.7.1.tar.gz
|
||||
|
@ -1,20 +1,17 @@
|
||||
From 2d80688fab4ae0af2d4bd20568c328bd2aae128c Mon Sep 17 00:00:00 2001
|
||||
From 1c27fda076e6ef4b82dc1b0b604b920ce6251633 Mon Sep 17 00:00:00 2001
|
||||
From: Ralph Bean <rbean@redhat.com>
|
||||
Date: Thu, 22 Aug 2013 14:18:45 -0400
|
||||
Subject: [PATCH] Require SSL certificate validation by default by using
|
||||
CERT_REQUIRED and using the system /etc/ssl/certs/ca-certificates.crt
|
||||
Date: Wed, 25 Sep 2013 13:21:32 -0400
|
||||
Subject: [PATCH 1/3] default-ssl-cert-validate
|
||||
|
||||
Bug-Fedora: https://bugzilla.redhat.com/show_bug.cgi?id=855320
|
||||
Bug-Ubuntu: https://launchpad.net/bugs/1047054
|
||||
---
|
||||
urllib3/connectionpool.py | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/urllib3/connectionpool.py b/urllib3/connectionpool.py
|
||||
index 621e1a8..7f4c322 100644
|
||||
index 691d4e2..551b6fd 100644
|
||||
--- a/urllib3/connectionpool.py
|
||||
+++ b/urllib3/connectionpool.py
|
||||
@@ -556,8 +556,8 @@ class HTTPSConnectionPool(HTTPConnectionPool):
|
||||
@@ -644,8 +644,8 @@ class HTTPSConnectionPool(HTTPConnectionPool):
|
||||
strict=False, timeout=None, maxsize=1,
|
||||
block=False, headers=None,
|
||||
_proxy=None, _proxy_headers=None,
|
||||
@ -24,7 +21,7 @@ index 621e1a8..7f4c322 100644
|
||||
+ ca_certs='/etc/ssl/certs/ca-certificates.crt', ssl_version=None,
|
||||
assert_hostname=None, assert_fingerprint=None):
|
||||
|
||||
HTTPConnectionPool.__init__(self, host, port,
|
||||
HTTPConnectionPool.__init__(self, host, port, strict, timeout, maxsize,
|
||||
--
|
||||
1.8.3.1
|
||||
|
||||
|
@ -1,22 +1,23 @@
|
||||
From e5a73988f6790fb6961801f0db5992d8bd353e67 Mon Sep 17 00:00:00 2001
|
||||
From d1b64a6dc91bc9c350ac503febc34340c94c9066 Mon Sep 17 00:00:00 2001
|
||||
From: Ralph Bean <rbean@redhat.com>
|
||||
Date: Thu, 22 Aug 2013 14:42:58 -0400
|
||||
Subject: [PATCH] old nose compat
|
||||
Date: Wed, 25 Sep 2013 13:28:37 -0400
|
||||
Subject: [PATCH 3/3] old nose compat
|
||||
|
||||
---
|
||||
setup.cfg | 2 --
|
||||
1 file changed, 2 deletions(-)
|
||||
setup.cfg | 3 ---
|
||||
1 file changed, 3 deletions(-)
|
||||
|
||||
diff --git a/setup.cfg b/setup.cfg
|
||||
index 8f6983c..a8b1d1d 100644
|
||||
index 8f1fee7..a8b1d1d 100644
|
||||
--- a/setup.cfg
|
||||
+++ b/setup.cfg
|
||||
@@ -1,8 +1,6 @@
|
||||
@@ -1,9 +1,6 @@
|
||||
[nosetests]
|
||||
-logging-clear-handlers = true
|
||||
with-coverage = true
|
||||
cover-package = urllib3
|
||||
-cover-min-percentage = 100
|
||||
-cover-erase = true
|
||||
|
||||
[egg_info]
|
||||
tag_build =
|
||||
|
@ -1,24 +1,22 @@
|
||||
From 67a50e427b3feef042ce9817b0ad0a05f01fefb7 Mon Sep 17 00:00:00 2001
|
||||
From 8b8da1946efc6327f8a9e8bb478cb10f05cb24b5 Mon Sep 17 00:00:00 2001
|
||||
From: Ralph Bean <rbean@redhat.com>
|
||||
Date: Thu, 22 Aug 2013 14:37:02 -0400
|
||||
Subject: [PATCH] unbundle
|
||||
Date: Wed, 25 Sep 2013 13:27:45 -0400
|
||||
Subject: [PATCH 2/3] unbundle
|
||||
|
||||
---
|
||||
setup.py | 1 -
|
||||
test-requirements.txt | 2 ++
|
||||
test/test_collections.py | 2 +-
|
||||
test/test_connectionpool.py | 9 ++++++++-
|
||||
test/test_fields.py | 2 +-
|
||||
test/test_filepost.py | 3 ++-
|
||||
urllib3.egg-info/PKG-INFO | 2 +-
|
||||
urllib3.egg-info/SOURCES.txt | 6 +-----
|
||||
test/test_collections.py | 7 ++++++-
|
||||
test/test_connectionpool.py | 8 +++++++-
|
||||
test/test_fields.py | 3 ++-
|
||||
test/test_filepost.py | 2 +-
|
||||
urllib3/_collections.py | 2 +-
|
||||
urllib3/connectionpool.py | 10 ++++++++--
|
||||
urllib3/connectionpool.py | 12 ++++++++++--
|
||||
urllib3/fields.py | 2 +-
|
||||
urllib3/filepost.py | 4 ++--
|
||||
urllib3/response.py | 2 +-
|
||||
urllib3/util.py | 2 +-
|
||||
14 files changed, 30 insertions(+), 19 deletions(-)
|
||||
12 files changed, 34 insertions(+), 13 deletions(-)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index 392b885..82af89c 100644
|
||||
@ -33,38 +31,42 @@ index 392b885..82af89c 100644
|
||||
],
|
||||
requires=requirements,
|
||||
diff --git a/test-requirements.txt b/test-requirements.txt
|
||||
index 1c90c10..e9a71d9 100644
|
||||
index f7c3a50..0fea32c 100644
|
||||
--- a/test-requirements.txt
|
||||
+++ b/test-requirements.txt
|
||||
@@ -1,3 +1,5 @@
|
||||
nose==1.3
|
||||
@@ -2,3 +2,5 @@ nose==1.3
|
||||
mock==1.0.1
|
||||
tornado==2.4.1
|
||||
coverage==3.6
|
||||
+six
|
||||
+backports.ssl_match_hostname
|
||||
diff --git a/test/test_collections.py b/test/test_collections.py
|
||||
index b44c58a..a8f2e55 100644
|
||||
index b44c58a..962b6fd 100644
|
||||
--- a/test/test_collections.py
|
||||
+++ b/test/test_collections.py
|
||||
@@ -1,7 +1,7 @@
|
||||
@@ -1,7 +1,12 @@
|
||||
import unittest
|
||||
|
||||
from urllib3._collections import RecentlyUsedContainer as Container
|
||||
-from urllib3.packages import six
|
||||
+import six
|
||||
+
|
||||
+try:
|
||||
+ import six
|
||||
+except ImportError:
|
||||
+ from urllib3.packages import six
|
||||
+
|
||||
xrange = six.moves.xrange
|
||||
|
||||
|
||||
diff --git a/test/test_connectionpool.py b/test/test_connectionpool.py
|
||||
index a7e104a..876b4ee 100644
|
||||
index ac1768e..c386798 100644
|
||||
--- a/test/test_connectionpool.py
|
||||
+++ b/test/test_connectionpool.py
|
||||
@@ -1,7 +1,14 @@
|
||||
import unittest
|
||||
|
||||
from urllib3.connectionpool import connection_from_url, HTTPConnectionPool
|
||||
@@ -6,7 +6,13 @@ from urllib3.connectionpool import (
|
||||
HTTPConnectionPool,
|
||||
)
|
||||
from urllib3.util import Timeout
|
||||
-from urllib3.packages.ssl_match_hostname import CertificateError
|
||||
+
|
||||
+try:
|
||||
+ # python3.2+
|
||||
+ from ssl import CertificateError
|
||||
@ -76,58 +78,32 @@ index a7e104a..876b4ee 100644
|
||||
ClosedPoolError,
|
||||
EmptyPoolError,
|
||||
diff --git a/test/test_fields.py b/test/test_fields.py
|
||||
index 888c2d5..73dcd91 100644
|
||||
index 888c2d5..ddda1cf 100644
|
||||
--- a/test/test_fields.py
|
||||
+++ b/test/test_fields.py
|
||||
@@ -1,7 +1,7 @@
|
||||
@@ -1,7 +1,8 @@
|
||||
import unittest
|
||||
|
||||
from urllib3.fields import guess_content_type, RequestField
|
||||
-from urllib3.packages.six import b, u
|
||||
+from six import b, u
|
||||
|
||||
|
||||
class TestRequestField(unittest.TestCase):
|
||||
diff --git a/test/test_filepost.py b/test/test_filepost.py
|
||||
index ca33d61..7176a29 100644
|
||||
--- a/test/test_filepost.py
|
||||
+++ b/test/test_filepost.py
|
||||
@@ -2,7 +2,8 @@ import unittest
|
||||
|
||||
from urllib3.filepost import encode_multipart_formdata, iter_fields
|
||||
from urllib3.fields import RequestField
|
||||
-from urllib3.packages.six import b, u
|
||||
+
|
||||
+from six import b, u
|
||||
|
||||
|
||||
class TestRequestField(unittest.TestCase):
|
||||
diff --git a/test/test_filepost.py b/test/test_filepost.py
|
||||
index ca33d61..1b884c3 100644
|
||||
--- a/test/test_filepost.py
|
||||
+++ b/test/test_filepost.py
|
||||
@@ -2,7 +2,7 @@ import unittest
|
||||
|
||||
from urllib3.filepost import encode_multipart_formdata, iter_fields
|
||||
from urllib3.fields import RequestField
|
||||
-from urllib3.packages.six import b, u
|
||||
+from six import b, u
|
||||
|
||||
|
||||
BOUNDARY = '!! test boundary !!'
|
||||
diff --git a/urllib3.egg-info/PKG-INFO b/urllib3.egg-info/PKG-INFO
|
||||
index 13a467c..8232870 100644
|
||||
--- a/urllib3.egg-info/PKG-INFO
|
||||
+++ b/urllib3.egg-info/PKG-INFO
|
||||
@@ -1,4 +1,4 @@
|
||||
-Metadata-Version: 1.0
|
||||
+Metadata-Version: 1.1
|
||||
Name: urllib3
|
||||
Version: 1.7
|
||||
Summary: HTTP library with thread-safe connection pooling, file post, and more.
|
||||
diff --git a/urllib3.egg-info/SOURCES.txt b/urllib3.egg-info/SOURCES.txt
|
||||
index 32759d9..9545027 100644
|
||||
--- a/urllib3.egg-info/SOURCES.txt
|
||||
+++ b/urllib3.egg-info/SOURCES.txt
|
||||
@@ -38,8 +38,4 @@ urllib3.egg-info/dependency_links.txt
|
||||
urllib3.egg-info/top_level.txt
|
||||
urllib3/contrib/__init__.py
|
||||
urllib3/contrib/ntlmpool.py
|
||||
-urllib3/contrib/pyopenssl.py
|
||||
-urllib3/packages/__init__.py
|
||||
-urllib3/packages/ordered_dict.py
|
||||
-urllib3/packages/six.py
|
||||
-urllib3/packages/ssl_match_hostname/__init__.py
|
||||
\ No newline at end of file
|
||||
+urllib3/contrib/pyopenssl.py
|
||||
\ No newline at end of file
|
||||
diff --git a/urllib3/_collections.py b/urllib3/_collections.py
|
||||
index 282b8d5..9210312 100644
|
||||
--- a/urllib3/_collections.py
|
||||
@ -142,15 +118,16 @@ index 282b8d5..9210312 100644
|
||||
|
||||
__all__ = ['RecentlyUsedContainer']
|
||||
diff --git a/urllib3/connectionpool.py b/urllib3/connectionpool.py
|
||||
index 7f4c322..21dec73 100644
|
||||
index 551b6fd..f2c1438 100644
|
||||
--- a/urllib3/connectionpool.py
|
||||
+++ b/urllib3/connectionpool.py
|
||||
@@ -57,8 +57,14 @@ from .exceptions import (
|
||||
@@ -54,8 +54,16 @@ from .exceptions import (
|
||||
ReadTimeoutError,
|
||||
ProxyError,
|
||||
)
|
||||
|
||||
-from .packages.ssl_match_hostname import match_hostname, CertificateError
|
||||
-from .packages.ssl_match_hostname import CertificateError, match_hostname
|
||||
-from .packages import six
|
||||
+
|
||||
+try:
|
||||
+ # python3.2+
|
||||
+ from ssl import match_hostname, CertificateError
|
||||
@ -159,9 +136,10 @@ index 7f4c322..21dec73 100644
|
||||
+ from backports.ssl_match_hostname import match_hostname, CertificateError
|
||||
+
|
||||
+import six
|
||||
|
||||
|
||||
xrange = six.moves.xrange
|
||||
+
|
||||
from .request import RequestMethods
|
||||
from .response import HTTPResponse
|
||||
from .util import (
|
||||
diff --git a/urllib3/fields.py b/urllib3/fields.py
|
||||
index ed01765..7a33b95 100644
|
||||
--- a/urllib3/fields.py
|
||||
@ -191,7 +169,7 @@ index 4575582..bc4a161 100644
|
||||
|
||||
writer = codecs.lookup('utf-8')[3]
|
||||
diff --git a/urllib3/response.py b/urllib3/response.py
|
||||
index c7f93b8..a257cd7 100644
|
||||
index 4efff5a..32b2b3e 100644
|
||||
--- a/urllib3/response.py
|
||||
+++ b/urllib3/response.py
|
||||
@@ -10,7 +10,7 @@ import zlib
|
||||
@ -204,16 +182,16 @@ index c7f93b8..a257cd7 100644
|
||||
|
||||
|
||||
diff --git a/urllib3/util.py b/urllib3/util.py
|
||||
index 39bceab..55faae5 100644
|
||||
index 266c9ed..49de5fb 100644
|
||||
--- a/urllib3/util.py
|
||||
+++ b/urllib3/util.py
|
||||
@@ -31,7 +31,7 @@ try: # Test for SSL features
|
||||
@@ -32,7 +32,7 @@ try: # Test for SSL features
|
||||
except ImportError:
|
||||
pass
|
||||
|
||||
-from .packages import six
|
||||
+import six
|
||||
from .exceptions import LocationParseError, SSLError
|
||||
from .exceptions import LocationParseError, SSLError, TimeoutStateError
|
||||
|
||||
|
||||
--
|
||||
|
@ -7,8 +7,8 @@
|
||||
%global srcname urllib3
|
||||
|
||||
Name: python-%{srcname}
|
||||
Version: 1.7
|
||||
Release: 3%{?dist}
|
||||
Version: 1.7.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Python HTTP library with thread-safe connection pooling and file post
|
||||
|
||||
License: MIT
|
||||
@ -40,6 +40,7 @@ Requires: python-ordereddict
|
||||
BuildRequires: python2-devel
|
||||
# For unittests
|
||||
BuildRequires: python-nose
|
||||
BuildRequires: python-mock
|
||||
BuildRequires: python-six
|
||||
BuildRequires: python-tornado
|
||||
BuildRequires: python-backports-ssl_match_hostname
|
||||
@ -48,6 +49,7 @@ BuildRequires: python-backports-ssl_match_hostname
|
||||
BuildRequires: python3-devel
|
||||
# For unittests
|
||||
BuildRequires: python3-nose
|
||||
BuildRequires: python3-mock
|
||||
BuildRequires: python3-six
|
||||
BuildRequires: python3-tornado
|
||||
%endif # with_python3
|
||||
@ -129,6 +131,9 @@ popd
|
||||
%endif # with_python3
|
||||
|
||||
%changelog
|
||||
* Wed Sep 25 2013 Ralph Bean <rbean@redhat.com> - 1.7.1-1
|
||||
- Latest upstream with support for a new timeout class and py3.4.
|
||||
|
||||
* Wed Aug 28 2013 Ralph Bean <rbean@redhat.com> - 1.7-3
|
||||
- Bump release again, just to push an unpaired update.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user