python-sure package is retired on c9s for CS-569
This commit is contained in:
parent
b62b09d51e
commit
ef62c60f9a
15
.gitignore
vendored
15
.gitignore
vendored
@ -1,15 +0,0 @@
|
|||||||
/sure-0.10.3-tests.tgz
|
|
||||||
/sure-0.10.3.tar.gz
|
|
||||||
/sure-1.0.6.tar.gz
|
|
||||||
/sure-1.0.6-tests.tgz
|
|
||||||
/sure-1.1.7-tests.tgz
|
|
||||||
/sure-1.1.7.tar.gz
|
|
||||||
/sure-1.2.3.tar.gz
|
|
||||||
/sure-1.2.3-tests.tgz
|
|
||||||
/sure-1.2.5-tests.tgz
|
|
||||||
/sure-1.2.5.tar.gz
|
|
||||||
/sure-1.2.7-tests.tgz
|
|
||||||
/sure-1.2.7.tar.gz
|
|
||||||
/sure-1.4.0.tar.gz
|
|
||||||
/sure-1.4.10.tar.gz
|
|
||||||
/sure-1.4.11.tar.gz
|
|
@ -1,64 +0,0 @@
|
|||||||
From 9f0e834b2e5eea5dfe21d5be4ea6a3df47baf0b9 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Timo Furrer <timo.furrer@roche.com>
|
|
||||||
Date: Wed, 20 Feb 2019 13:26:46 +0100
|
|
||||||
Subject: [PATCH] Import ABCs from collections.abc. Closes #150
|
|
||||||
|
|
||||||
---
|
|
||||||
.travis.yml | 10 +++++++---
|
|
||||||
sure/compat.py | 5 +++++
|
|
||||||
sure/old.py | 5 +----
|
|
||||||
tests/test_assertion_builder.py | 2 +-
|
|
||||||
4 files changed, 14 insertions(+), 8 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/sure/compat.py b/sure/compat.py
|
|
||||||
index df8d323..c53ab28 100644
|
|
||||||
--- a/sure/compat.py
|
|
||||||
+++ b/sure/compat.py
|
|
||||||
@@ -5,6 +5,11 @@
|
|
||||||
import six
|
|
||||||
from collections import OrderedDict
|
|
||||||
|
|
||||||
+try:
|
|
||||||
+ from collections.abc import Iterable
|
|
||||||
+except ImportError:
|
|
||||||
+ from collections import Iterable
|
|
||||||
+
|
|
||||||
from sure.terminal import red, green, yellow
|
|
||||||
|
|
||||||
|
|
||||||
diff --git a/sure/old.py b/sure/old.py
|
|
||||||
index e861b26..53e4ee4 100644
|
|
||||||
--- a/sure/old.py
|
|
||||||
+++ b/sure/old.py
|
|
||||||
@@ -22,10 +22,6 @@
|
|
||||||
from copy import deepcopy
|
|
||||||
from pprint import pformat
|
|
||||||
from functools import wraps
|
|
||||||
-try:
|
|
||||||
- from collections import Iterable
|
|
||||||
-except ImportError:
|
|
||||||
- Iterable = (list, dict, tuple, set)
|
|
||||||
|
|
||||||
try:
|
|
||||||
import __builtin__ as builtins
|
|
||||||
@@ -43,6 +39,7 @@
|
|
||||||
from sure.core import _get_file_name
|
|
||||||
from sure.core import _get_line_number
|
|
||||||
from sure.core import itemize_length
|
|
||||||
+from sure.compat import Iterable
|
|
||||||
|
|
||||||
|
|
||||||
def identify_callable_location(callable_object):
|
|
||||||
diff --git a/tests/test_assertion_builder.py b/tests/test_assertion_builder.py
|
|
||||||
index 4dc00fc..c043648 100644
|
|
||||||
--- a/tests/test_assertion_builder.py
|
|
||||||
+++ b/tests/test_assertion_builder.py
|
|
||||||
@@ -137,7 +137,7 @@ def test_should_be_a():
|
|
||||||
("this(None).should.be.none")
|
|
||||||
|
|
||||||
assert this(1).should.be.an(int)
|
|
||||||
- assert this([]).should.be.a('collections.Iterable')
|
|
||||||
+ assert this([]).should.be.a('sure.compat.Iterable')
|
|
||||||
assert this({}).should_not.be.a(list)
|
|
||||||
|
|
||||||
def opposite():
|
|
1
dead.package
Normal file
1
dead.package
Normal file
@ -0,0 +1 @@
|
|||||||
|
python-sure package is retired on c9s for CS-569
|
193
python-sure.spec
193
python-sure.spec
@ -1,193 +0,0 @@
|
|||||||
%global pypi_name sure
|
|
||||||
|
|
||||||
Name: python-%{pypi_name}
|
|
||||||
Version: 1.4.11
|
|
||||||
Release: 13%{?dist}
|
|
||||||
Summary: Utility belt for automated testing in Python
|
|
||||||
|
|
||||||
License: GPLv3+
|
|
||||||
URL: https://github.com/gabrielfalcao/sure
|
|
||||||
Source0: %{pypi_source}
|
|
||||||
|
|
||||||
# Python 3.9 compatibility
|
|
||||||
# https://github.com/gabrielfalcao/sure/commit/9f0e834b2e5eea5dfe21d5be4ea6a3df47baf0b9
|
|
||||||
Patch1: 9f0e834b2e5eea5dfe21d5be4ea6a3df47baf0b9.patch
|
|
||||||
|
|
||||||
# Python 3.10 workaround
|
|
||||||
# In test_context_is_not_optional(), only check the exception type
|
|
||||||
# https://github.com/gabrielfalcao/sure/issues/169
|
|
||||||
Patch2: python3.10-workaround.patch
|
|
||||||
|
|
||||||
BuildArch: noarch
|
|
||||||
|
|
||||||
BuildRequires: python3-devel
|
|
||||||
BuildRequires: python3-mock
|
|
||||||
BuildRequires: python3-nose
|
|
||||||
BuildRequires: python3-setuptools
|
|
||||||
BuildRequires: python3-six
|
|
||||||
|
|
||||||
%description
|
|
||||||
A testing library for Python with powerful and flexible assertions. Sure is
|
|
||||||
heavily inspired by should.js.
|
|
||||||
|
|
||||||
|
|
||||||
%package -n python3-%{pypi_name}
|
|
||||||
Summary: %{summary} 3
|
|
||||||
%{?python_provide:%python_provide python3-%{pypi_name}}
|
|
||||||
Requires: python3-six
|
|
||||||
|
|
||||||
%description -n python3-%{pypi_name}
|
|
||||||
A testing library for Python with powerful and flexible assertions. Sure is
|
|
||||||
heavily inspired by should.js.
|
|
||||||
|
|
||||||
|
|
||||||
%prep
|
|
||||||
%autosetup -p1 -n %{pypi_name}-%{version}
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
|
||||||
%py3_build
|
|
||||||
|
|
||||||
|
|
||||||
%install
|
|
||||||
%py3_install
|
|
||||||
|
|
||||||
|
|
||||||
%check
|
|
||||||
%{__python3} -m nose --verbosity 2
|
|
||||||
|
|
||||||
|
|
||||||
%files -n python3-%{pypi_name}
|
|
||||||
%doc COPYING
|
|
||||||
%{python3_sitelib}/%{pypi_name}/
|
|
||||||
%{python3_sitelib}/%{pypi_name}-%{version}-py%{python3_version}.egg-info/
|
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
|
||||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 1.4.11-13
|
|
||||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
|
||||||
|
|
||||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.11-12
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
|
||||||
|
|
||||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.11-11
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
|
||||||
|
|
||||||
* Fri May 22 2020 Miro Hrončok <mhroncok@redhat.com> - 1.4.11-10
|
|
||||||
- Rebuilt for Python 3.9
|
|
||||||
|
|
||||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.11-9
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
|
||||||
|
|
||||||
* Sat Sep 21 2019 Miro Hrončok <mhroncok@redhat.com> - 1.4.11-8
|
|
||||||
- Subpackage python2-sure has been removed
|
|
||||||
See https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal
|
|
||||||
|
|
||||||
* Thu Aug 15 2019 Richard Shaw <hobbes1069@gmail.com> - 1.4.11-7
|
|
||||||
- Rebuild for Python 3.8.
|
|
||||||
|
|
||||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.11-6
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
|
||||||
|
|
||||||
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.11-5
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
|
||||||
|
|
||||||
* Mon Dec 03 2018 Miro Hrončok <mhroncok@redhat.com> - 1.4.11-4
|
|
||||||
- Fix ambiguous Python requires
|
|
||||||
|
|
||||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.11-3
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
|
||||||
|
|
||||||
* Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 1.4.11-2
|
|
||||||
- Rebuilt for Python 3.7
|
|
||||||
|
|
||||||
* Thu May 17 2018 Miro Hrončok <mhroncok@redhat.com> - 1.4.11-1
|
|
||||||
- Updated to 1.4.11 (#1421319)
|
|
||||||
|
|
||||||
* Thu May 17 2018 Miro Hrončok <mhroncok@redhat.com> - 1.4.10-1
|
|
||||||
- Updated to 1.4.10 that supports Python 3.7 (#1578530)
|
|
||||||
- Stop py3dir pushd/popd, it is not needed
|
|
||||||
- Removed an unneeded shebeng sed
|
|
||||||
- Drop %%sum macro, use %%summary
|
|
||||||
- Drop forbidden SCL macros
|
|
||||||
- Drop unneeded python3 conditional
|
|
||||||
|
|
||||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-5
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
|
||||||
|
|
||||||
* Fri Sep 29 2017 Troy Dawson <tdawson@redhat.com> - 1.4.0-4
|
|
||||||
- Cleanup spec file conditionals
|
|
||||||
|
|
||||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-3
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
|
||||||
|
|
||||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-2
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
|
||||||
|
|
||||||
* Wed Dec 21 2016 Adam Williamson <awilliam@redhat.com> - 1.4.0-1
|
|
||||||
- New release 1.4.0 (builds against Python 3.6)
|
|
||||||
- Drop sources merged upstream
|
|
||||||
- Modernize spec a bit (use modern macros)
|
|
||||||
- Rename python2 package to python2-sure
|
|
||||||
|
|
||||||
* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 1.2.7-6
|
|
||||||
- Rebuild for Python 3.6
|
|
||||||
|
|
||||||
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.7-5
|
|
||||||
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
|
||||||
|
|
||||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.7-4
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
|
||||||
|
|
||||||
* Wed Oct 14 2015 Robert Kuska <rkuska@redhat.com> - 1.2.7-3
|
|
||||||
- Rebuilt for Python3.5 rebuild
|
|
||||||
|
|
||||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.7-2
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
|
||||||
|
|
||||||
* Fri Nov 14 2014 Slavek Kabrda <bkabrda@redhat.com> - 1.2.7-1
|
|
||||||
- Updated to 1.2.7
|
|
||||||
|
|
||||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.5-4
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
|
||||||
|
|
||||||
* Wed May 14 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 1.2.5-3
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
|
|
||||||
|
|
||||||
* Mon Mar 31 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 1.2.5-2
|
|
||||||
- Remove unneeded dependencies from setup.py.
|
|
||||||
Resolves: rhbz#1082400
|
|
||||||
|
|
||||||
* Fri Mar 07 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 1.2.5-1
|
|
||||||
- Updated to 1.2.5
|
|
||||||
- Fix with_python3 macro definition to work correctly on EPEL, too.
|
|
||||||
|
|
||||||
* Fri Nov 29 2013 Miro Hrončok <mhroncok@redhat.com> - 1.2.3-1
|
|
||||||
- Updated
|
|
||||||
- Introduced Python 3 subpackage
|
|
||||||
|
|
||||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.7-3
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
|
||||||
|
|
||||||
* Thu May 30 2013 Bohuslav Kabrda <bkabrda@redhat.com> - 1.1.7-2
|
|
||||||
- Introduce SCL macros in the specfile.
|
|
||||||
|
|
||||||
* Mon Feb 18 2013 Bohuslav Kabrda <bkabrda@redhat.com> - 1.1.7-1
|
|
||||||
- Update to 1.1.7.
|
|
||||||
- License change from MIT to GPLv3.
|
|
||||||
|
|
||||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.6-2
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
|
||||||
|
|
||||||
* Mon Nov 05 2012 Bohuslav Kabrda <bkabrda@redhat.com> - 1.0.6-1
|
|
||||||
- Update to 1.0.6.
|
|
||||||
|
|
||||||
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.3-3
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
|
||||||
|
|
||||||
* Tue Jun 26 2012 Bohuslav Kabrda <bkabrda@redhat.com> - 0.10.3-2
|
|
||||||
- python-devel should be python2-devel
|
|
||||||
- URL now points to the real homepage of the project
|
|
||||||
|
|
||||||
* Fri Jun 22 2012 Bohuslav Kabrda <bkabrda@redhat.com> - 0.10.3-1
|
|
||||||
- Initial package.
|
|
@ -1,19 +0,0 @@
|
|||||||
diff --git a/tests/test_old_api.py b/tests/test_old_api.py
|
|
||||||
index d63d8fe..2f93bc5 100644
|
|
||||||
--- a/tests/test_old_api.py
|
|
||||||
+++ b/tests/test_old_api.py
|
|
||||||
@@ -57,10 +57,10 @@ def test_context_is_not_optional():
|
|
||||||
assert True
|
|
||||||
|
|
||||||
assert that(it_crashes).raises(
|
|
||||||
- TypeError, (
|
|
||||||
- "the function it_crashes defined at test_old_api.py line 56, is being "
|
|
||||||
- "decorated by either @that_with_context or @scenario, so it should "
|
|
||||||
- "take at least 1 parameter, which is the test context"),
|
|
||||||
+ TypeError,
|
|
||||||
+ # intentionally empty line 1
|
|
||||||
+ # intentionally empty line 2
|
|
||||||
+ # intentionally empty line 3
|
|
||||||
)
|
|
||||||
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user