- Update to 0.5.1.
This commit is contained in:
parent
da46b54d5d
commit
252cc90d40
@ -1 +1 @@
|
|||||||
SQLAlchemy-0.5.0rc4.tar.gz
|
SQLAlchemy-0.5.1.tar.gz
|
||||||
|
@ -2,18 +2,17 @@
|
|||||||
%{!?pyver: %define pyver %(%{__python} -c "import sys ; print sys.version[:3]")}
|
%{!?pyver: %define pyver %(%{__python} -c "import sys ; print sys.version[:3]")}
|
||||||
|
|
||||||
%define srcname SQLAlchemy
|
%define srcname SQLAlchemy
|
||||||
%define alphatag rc4
|
|
||||||
|
|
||||||
Name: python-sqlalchemy
|
Name: python-sqlalchemy
|
||||||
Version: 0.5.0
|
Version: 0.5.1
|
||||||
Release: 0.1.%{alphatag}%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Modular and flexible ORM library for python
|
Summary: Modular and flexible ORM library for python
|
||||||
|
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: http://www.sqlalchemy.org/
|
URL: http://www.sqlalchemy.org/
|
||||||
Source0: http://pypi.python.org/packages/source/S/%{srcname}/%{srcname}-%{version}%{?alphatag}.tar.gz
|
Source0: http://pypi.python.org/packages/source/S/%{srcname}/%{srcname}-%{version}.tar.gz
|
||||||
Patch0: sqlalchemy-sqlite-unicode-test.patch
|
#Patch0: sqlalchemy-sqlite-unicode-test.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
@ -31,7 +30,7 @@ domain.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{srcname}-%{version}%{?alphatag}
|
%setup -q -n %{srcname}-%{version}%{?alphatag}
|
||||||
%patch0 -p1 -b .unicode
|
#%patch0 -p1 -b .unicode
|
||||||
|
|
||||||
%build
|
%build
|
||||||
CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
|
CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
|
||||||
@ -58,6 +57,9 @@ python test/alltests.py
|
|||||||
%{python_sitelib}/*
|
%{python_sitelib}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jan 21 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.1-1
|
||||||
|
- Update to 0.5.1.
|
||||||
|
|
||||||
* Mon Dec 1 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5-0.1.rc4
|
* Mon Dec 1 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5-0.1.rc4
|
||||||
- Update to 0.5.0rc4 which works with the new pysqlite
|
- Update to 0.5.0rc4 which works with the new pysqlite
|
||||||
- And update test cases to work with the new pysqlite
|
- And update test cases to work with the new pysqlite
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
f931e6d0de35b4c63b04d4daa6a4910c SQLAlchemy-0.5.0rc4.tar.gz
|
3374e8c7af39696eed26367631960d22 SQLAlchemy-0.5.1.tar.gz
|
||||||
|
@ -1,30 +0,0 @@
|
|||||||
diff -up SQLAlchemy-0.5.0rc4/test/sql/testtypes.py.unicode SQLAlchemy-0.5.0rc4/test/sql/testtypes.py
|
|
||||||
--- SQLAlchemy-0.5.0rc4/test/sql/testtypes.py.unicode 2008-12-01 13:36:48.000000000 -0800
|
|
||||||
+++ SQLAlchemy-0.5.0rc4/test/sql/testtypes.py 2008-12-01 13:38:21.000000000 -0800
|
|
||||||
@@ -294,7 +294,7 @@ class UnicodeTest(TestBase, AssertsExecu
|
|
||||||
unicodedata = rawdata.decode('utf-8')
|
|
||||||
unicode_table.insert().execute(unicode_varchar=unicodedata,
|
|
||||||
unicode_text=unicodedata,
|
|
||||||
- plain_varchar=rawdata)
|
|
||||||
+ plain_varchar=unicodedata)
|
|
||||||
x = unicode_table.select().execute().fetchone()
|
|
||||||
self.assert_(isinstance(x['unicode_varchar'], unicode) and x['unicode_varchar'] == unicodedata)
|
|
||||||
self.assert_(isinstance(x['unicode_text'], unicode) and x['unicode_text'] == unicodedata)
|
|
||||||
@@ -313,7 +313,7 @@ class UnicodeTest(TestBase, AssertsExecu
|
|
||||||
unicodedata = rawdata.decode('utf-8')
|
|
||||||
unicode_table.insert().execute(unicode_varchar=unicodedata,
|
|
||||||
unicode_text=unicodedata,
|
|
||||||
- plain_varchar=rawdata)
|
|
||||||
+ plain_varchar=unicodedata)
|
|
||||||
|
|
||||||
x = union(select([unicode_table.c.unicode_varchar]), select([unicode_table.c.unicode_varchar])).execute().fetchone()
|
|
||||||
self.assert_(isinstance(x['unicode_varchar'], unicode) and x['unicode_varchar'] == unicodedata)
|
|
||||||
@@ -360,7 +360,7 @@ class UnicodeTest(TestBase, AssertsExecu
|
|
||||||
unicodedata = rawdata.decode('utf-8')
|
|
||||||
unicode_table.insert().execute(unicode_varchar=unicodedata,
|
|
||||||
unicode_text=unicodedata,
|
|
||||||
- plain_varchar=rawdata)
|
|
||||||
+ plain_varchar=unicodedata)
|
|
||||||
x = unicode_table.select().execute().fetchone()
|
|
||||||
print 0, repr(unicodedata)
|
|
||||||
print 1, repr(x['unicode_varchar'])
|
|
Loading…
Reference in New Issue
Block a user