upstream release 1.4.0: http://pythonhosted.org/sphinxcontrib-httpdomain/#version-1-4-0
This commit is contained in:
parent
1aa7d75144
commit
556c2a6c4c
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
|||||||
/sphinxcontrib-httpdomain-1.1.7.tar.gz
|
/sphinxcontrib-httpdomain-1.1.7.tar.gz
|
||||||
/sphinxcontrib-httpdomain-1.1.8.tar.gz
|
/sphinxcontrib-httpdomain-1.1.8.tar.gz
|
||||||
/sphinxcontrib-httpdomain-1.3.0.tar.gz
|
/sphinxcontrib-httpdomain-1.3.0.tar.gz
|
||||||
|
/sphinxcontrib-httpdomain-1.4.0.tar.gz
|
||||||
|
28
0001-httpdomain-bump-domain-data-version.patch
Normal file
28
0001-httpdomain-bump-domain-data-version.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
From bca04322b420cca6d8d7956d5c8a430d65e6aac5 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Dan Callaghan <dcallagh@redhat.com>
|
||||||
|
Date: Sun, 27 Sep 2015 20:21:49 +1000
|
||||||
|
Subject: [PATCH] httpdomain: bump domain data version
|
||||||
|
|
||||||
|
Upstream should have bumped this to 1 (or something greater than 0) for
|
||||||
|
the 1.4.0 release since the expected contents of the data dict changed.
|
||||||
|
Using '0.1' here in Fedora with the expectation that it will be bumped
|
||||||
|
properly in a future upstream release.
|
||||||
|
---
|
||||||
|
httpdomain/sphinxcontrib/httpdomain.py | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/httpdomain/sphinxcontrib/httpdomain.py b/httpdomain/sphinxcontrib/httpdomain.py
|
||||||
|
index d7cdcc9..c8f6850 100644
|
||||||
|
--- a/httpdomain/sphinxcontrib/httpdomain.py
|
||||||
|
+++ b/httpdomain/sphinxcontrib/httpdomain.py
|
||||||
|
@@ -627,6 +627,7 @@ class HTTPDomain(Domain):
|
||||||
|
'copy': {},
|
||||||
|
'any': {}
|
||||||
|
}
|
||||||
|
+ data_version = '0.1'
|
||||||
|
|
||||||
|
indices = [HTTPIndex]
|
||||||
|
|
||||||
|
--
|
||||||
|
2.4.3
|
||||||
|
|
@ -1,21 +0,0 @@
|
|||||||
diff -ur sphinxcontrib-httpdomain-1.1.7.orig/sphinxcontrib/httpdomain.py sphinxcontrib-httpdomain-1.1.7/sphinxcontrib/httpdomain.py
|
|
||||||
--- sphinxcontrib-httpdomain-1.1.7.orig/sphinxcontrib/httpdomain.py 2012-03-28 16:10:58.000000000 +1000
|
|
||||||
+++ sphinxcontrib-httpdomain-1.1.7/sphinxcontrib/httpdomain.py 2013-03-04 13:20:09.941831182 +1000
|
|
||||||
@@ -44,7 +44,7 @@
|
|
||||||
location of the RFC which defines some HTTP method.
|
|
||||||
|
|
||||||
"""
|
|
||||||
- return '{}#{}{}'.format(self.base_url, self.anchor, self.section)
|
|
||||||
+ return '%s#%s%s' % (self.base_url, self.anchor, self.section)
|
|
||||||
|
|
||||||
|
|
||||||
#: The URL of the HTTP/1.1 RFC which defines the HTTP methods OPTIONS, GET,
|
|
||||||
@@ -319,7 +319,7 @@
|
|
||||||
for prefix in self.ignore:
|
|
||||||
if letters[:len(prefix)] == prefix:
|
|
||||||
return '/' + '/'.join(letters[:len(prefix) + 1])
|
|
||||||
- return '/%s' % (letters[0] if letters else '',)
|
|
||||||
+ return '/%s' % (letters and letters[0] or '',)
|
|
||||||
|
|
||||||
def generate(self, docnames=None):
|
|
||||||
content = {}
|
|
@ -6,15 +6,13 @@
|
|||||||
%global upstream_name sphinxcontrib-httpdomain
|
%global upstream_name sphinxcontrib-httpdomain
|
||||||
|
|
||||||
Name: python-%{upstream_name}
|
Name: python-%{upstream_name}
|
||||||
Version: 1.3.0
|
Version: 1.4.0
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Sphinx domain for documenting HTTP APIs
|
Summary: Sphinx domain for documenting HTTP APIs
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: http://packages.python.org/sphinxcontrib-httpdomain/
|
URL: http://packages.python.org/sphinxcontrib-httpdomain/
|
||||||
Source0: http://pypi.python.org/packages/source/s/%{upstream_name}/%{upstream_name}-%{version}.tar.gz
|
Source0: http://pypi.python.org/packages/source/s/%{upstream_name}/%{upstream_name}-%{version}.tar.gz
|
||||||
%if ! (0%{?rhel} >= 7 || 0%{?fedora})
|
Patch1: 0001-httpdomain-bump-domain-data-version.patch
|
||||||
Patch0: %{name}-old-python.patch
|
|
||||||
%endif
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
BuildRequires: python2-devel
|
BuildRequires: python2-devel
|
||||||
BuildRequires: python-setuptools
|
BuildRequires: python-setuptools
|
||||||
@ -30,6 +28,7 @@ Requires: python-sphinx10
|
|||||||
%else
|
%else
|
||||||
Requires: python-sphinx
|
Requires: python-sphinx
|
||||||
%endif
|
%endif
|
||||||
|
Requires: python-six
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Using this Sphinx domain you can document your HTTP API. It includes support
|
Using this Sphinx domain you can document your HTTP API. It includes support
|
||||||
@ -42,10 +41,8 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{upstream_name}-%{version}
|
%setup -q -n %{upstream_name}-%{version}
|
||||||
|
%patch1 -p2
|
||||||
rm -r *.egg-info
|
rm -r *.egg-info
|
||||||
%if ! (0%{?rhel} >= 7 || 0%{?fedora})
|
|
||||||
%patch0 -p1
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%{__python} setup.py build
|
%{__python} setup.py build
|
||||||
@ -57,10 +54,15 @@ rm -rf %{buildroot}
|
|||||||
%{__python} setup.py install --skip-build --root %{buildroot}
|
%{__python} setup.py install --skip-build --root %{buildroot}
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%doc README.rst LICENSE
|
%{!?_licensedir:%global license %doc}
|
||||||
|
%doc README.rst
|
||||||
|
%license LICENSE
|
||||||
%{python_sitelib}/*
|
%{python_sitelib}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Sep 27 2015 Dan Callaghan <dcallagh@redhat.com> - 1.4.0-1
|
||||||
|
- upstream release 1.4.0: http://pythonhosted.org/sphinxcontrib-httpdomain/#version-1-4-0
|
||||||
|
|
||||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-2
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user