Remove a patch to drop the runtime dependency on Sphinx

It is no longer needed, python3-sphinx-7.2.6-2+ no longer Requires this
This commit is contained in:
Miro Hrončok 2023-11-16 12:26:59 +01:00
parent d1be730bbf
commit 916f19f251
2 changed files with 6 additions and 45 deletions

View File

@ -1,32 +0,0 @@
From e680b4403819e0afbf5bef6a95227899cade6ae9 Mon Sep 17 00:00:00 2001
From: Karolina Surma <ksurma@redhat.com>
Date: Fri, 20 Oct 2023 14:03:31 +0200
Subject: [PATCH] Prevent circular dependency with Sphinx
---
pyproject.toml | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/pyproject.toml b/pyproject.toml
index a8cbb00..6518bb6 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -39,14 +39,12 @@ classifiers = [
"Topic :: Text Processing",
"Topic :: Utilities",
]
-dependencies = [
- "Sphinx>=5",
-]
dynamic = ["version"]
[project.optional-dependencies]
test = [
"pytest",
+ "Sphinx",
]
lint = [
"flake8",
--
2.41.0

View File

@ -1,21 +1,12 @@
# when bootstrapping sphinx, we cannot run tests yet
%bcond_without check
Name: python-sphinxcontrib-devhelp
Version: 1.0.5
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Sphinx extension for Devhelp documents
License: BSD-2-Clause
URL: http://sphinx-doc.org/
Source: %{pypi_source sphinxcontrib_devhelp}
BuildArch: noarch
# Sphinx requires sphinxcontrib-* packages, they've started requiring Sphinx
# In the RPM environment the dependencies are handled correctly without it
# Remove the runtime requirement on Sphinx from this package
# See: https://github.com/sphinx-doc/sphinx/issues/11567
Patch: Prevent-circular-dependency-with-Sphinx.patch
BuildRequires: gettext
BuildRequires: python%{python3_pkgversion}-devel
@ -32,7 +23,7 @@ sphinxcontrib-devhelp is a sphinx extension which outputs Devhelp document.
%generate_buildrequires
%pyproject_buildrequires %{?with_check: -x test}
%pyproject_buildrequires -x test
%prep
@ -66,10 +57,8 @@ popd
%find_lang sphinxcontrib.devhelp
%if %{with check}
%check
%pytest
%endif
%files -n python%{python3_pkgversion}-sphinxcontrib-devhelp -f sphinxcontrib.devhelp.lang
@ -80,6 +69,10 @@ popd
%changelog
* Thu Nov 16 2023 Miro Hrončok <mhroncok@redhat.com> - 1.0.5-2
- Remove a patch to drop the runtime dependency on Sphinx
- It is no longer needed, python3-sphinx-7.2.6-2+ no longer Requires this
* Mon Aug 21 2023 Karolina Surma <ksurma@redhat.com> - 1.0.5-1
- Update to 1.0.5
Fixes: rhbz#2230147