RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/python-sphinx_rtd_theme#bed24229d1e071065fc12488b2b78dbf35183965
This commit is contained in:
parent
94816b3a9f
commit
f4c88a4447
2
.gitignore
vendored
2
.gitignore
vendored
@ -0,0 +1,2 @@
|
||||
/sphinx_rtd_theme-*.tar.gz
|
||||
/objects.inv
|
39
python-sphinx_rtd_theme-script.patch
Normal file
39
python-sphinx_rtd_theme-script.patch
Normal file
@ -0,0 +1,39 @@
|
||||
Remove deprecated use of script_files
|
||||
|
||||
Fixes sphinx-doc/sphinx#6088
|
||||
|
||||
* Add script block
|
||||
* Fix build error
|
||||
|
||||
--- sphinx_rtd_theme/layout.html.orig 2019-02-12 12:37:47.000000000 -0700
|
||||
+++ sphinx_rtd_theme/layout.html 2019-08-06 09:02:26.103136905 -0600
|
||||
@@ -29,6 +29,7 @@
|
||||
{% endif %}
|
||||
|
||||
{# JAVASCRIPTS #}
|
||||
+ {%- block scripts %}
|
||||
<script type="text/javascript" src="{{ pathto('_static/js/modernizr.min.js', 1) }}"></script>
|
||||
{%- if not embedded %}
|
||||
{# XXX Sphinx 1.8.0 made this an external js-file, quick fix until we refactor the template to inherert more blocks directly from sphinx #}
|
||||
@@ -62,6 +63,7 @@
|
||||
href="{{ pathto('_static/opensearch.xml', 1) }}"/>
|
||||
{%- endif %}
|
||||
{%- endif %}
|
||||
+ {%- endblock %}
|
||||
|
||||
{# CSS #}
|
||||
<link rel="stylesheet" href="{{ pathto('_static/' + style, 1) }}" type="text/css" />
|
||||
--- sphinx_rtd_theme/search.html.orig 2019-02-12 12:37:47.000000000 -0700
|
||||
+++ sphinx_rtd_theme/search.html 2019-08-06 09:03:25.597117851 -0600
|
||||
@@ -9,7 +9,10 @@
|
||||
#}
|
||||
{%- extends "layout.html" %}
|
||||
{% set title = _('Search') %}
|
||||
-{% set script_files = script_files + ['_static/searchtools.js'] %}
|
||||
+{%- block scripts %}
|
||||
+ {{ super() }}
|
||||
+ <script type="text/javascript" src="{{ pathto('_static/searchtools.js', 1) }}"></script>
|
||||
+{%- endblock %}
|
||||
{% block footer %}
|
||||
<script type="text/javascript">
|
||||
jQuery(function() { Search.loadIndex("{{ pathto('searchindex.js', 1) }}"); });
|
8
python-sphinx_rtd_theme.rpmlintrc
Normal file
8
python-sphinx_rtd_theme.rpmlintrc
Normal file
@ -0,0 +1,8 @@
|
||||
# THIS FILE IS FOR WHITELISTING RPMLINT ERRORS AND WARNINGS IN TASKOTRON
|
||||
# https://fedoraproject.org/wiki/Taskotron/Tasks/dist.rpmlint#Whitelisting_errors
|
||||
|
||||
# Words not in the dictionary
|
||||
addFilter(r'W: spelling-error .* (readthedocs|rtd)')
|
||||
|
||||
# Dangling font symlinks: the Requires ensure they will not dangle
|
||||
addFilter(r'W: dangling-symlink .*fonts')
|
255
python-sphinx_rtd_theme.spec
Normal file
255
python-sphinx_rtd_theme.spec
Normal file
@ -0,0 +1,255 @@
|
||||
%global srcname sphinx_rtd_theme
|
||||
|
||||
# Disables tests and docs
|
||||
%bcond_with bootstrap
|
||||
|
||||
Name: python-%{srcname}
|
||||
Version: 0.4.3
|
||||
Release: 14%{?dist}
|
||||
Summary: Sphinx theme for readthedocs.org
|
||||
|
||||
License: MIT
|
||||
URL: https://github.com/rtfd/%{srcname}
|
||||
Source0: https://github.com/rtfd/%{srcname}/archive/%{version}/%{srcname}-%{version}.tar.gz
|
||||
# The koji builders do not have network access, and this file is not included
|
||||
# in any Fedora package, so we retrieve it for offline use.
|
||||
Source1: https://docs.readthedocs.io/en/latest/objects.inv
|
||||
# Remove deprecated use of script_files. See:
|
||||
# - https://github.com/readthedocs/sphinx_rtd_theme/pull/728
|
||||
# - https://github.com/readthedocs/sphinx_rtd_theme/commit/a49a812c8821123091166fae1897d702cdc2d627
|
||||
Patch0: %{name}-script.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: python3dist(docutils)
|
||||
BuildRequires: python3dist(setuptools)
|
||||
%if %{without bootstrap}
|
||||
BuildRequires: python3dist(pytest)
|
||||
BuildRequires: python3dist(readthedocs-sphinx-ext)
|
||||
BuildRequires: python3dist(sphinx)
|
||||
BuildRequires: python3dist(sphinxcontrib-httpdomain)
|
||||
BuildRequires: python-sphinx-doc
|
||||
%endif
|
||||
|
||||
%description
|
||||
This is a prototype mobile-friendly sphinx theme for readthedocs.org.
|
||||
It's currently in development and includes some rtd variable checks that
|
||||
can be ignored if you're just trying to use it on your project outside
|
||||
of that site.
|
||||
|
||||
%package -n python3-%{srcname}
|
||||
Summary: Sphinx theme for readthedocs.org
|
||||
Requires: fontawesome-fonts-web
|
||||
Requires: font(fontawesome)
|
||||
Requires: font(lato)
|
||||
Requires: font(robotoslab)
|
||||
|
||||
%{?python_provide:%python_provide python3-%{srcname}}
|
||||
|
||||
%description -n python3-%{srcname}
|
||||
This is a prototype mobile-friendly sphinx theme for readthedocs.org.
|
||||
It's currently in development and includes some rtd variable checks that
|
||||
can be ignored if you're just trying to use it on your project outside
|
||||
of that site.
|
||||
|
||||
%if %{without bootstrap}
|
||||
%package doc
|
||||
Summary: Documentation for the Sphinx theme for readthedocs.org
|
||||
Requires: fontawesome-fonts-web
|
||||
Requires: font(fontawesome)
|
||||
Requires: font(lato)
|
||||
Requires: font(robotoslab)
|
||||
|
||||
%description doc
|
||||
This package contains documentation for the Sphinx theme for
|
||||
readthedocs.org.
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%autosetup -p0 -n %{srcname}-%{version}
|
||||
|
||||
# Use local objects.inv for intersphinx
|
||||
sed -e "s|\('https://docs\.readthedocs\.io/en/latest/', \)None|\1'%{SOURCE1}'|" \
|
||||
-e "s|\('http://www\.sphinx-doc\.org/en/stable/', \)None|\1'%{_docdir}/python-sphinx-doc/html/objects.inv'|" \
|
||||
-i docs/conf.py
|
||||
|
||||
%build
|
||||
%py3_build
|
||||
|
||||
%if %{without bootstrap}
|
||||
# Build the documentation
|
||||
make -C docs html
|
||||
%endif
|
||||
|
||||
rst2html --no-datestamp README.rst README.html
|
||||
|
||||
%install
|
||||
%py3_install
|
||||
|
||||
# Link to the required fonts and copy the parts not shipped by Fedora
|
||||
pushd %{buildroot}%{python3_sitelib}/%{srcname}/static/fonts
|
||||
mkdir Lato RobotoSlab
|
||||
rm -f fontawesome-webfont.*
|
||||
ln -s %{_datadir}/fonts/fontawesome/fontawesome-webfont.eot .
|
||||
ln -s %{_datadir}/fonts/fontawesome/fontawesome-webfont.svg .
|
||||
ln -s %{_datadir}/fonts/fontawesome/fontawesome-webfont.ttf .
|
||||
ln -s %{_datadir}/fonts/fontawesome/fontawesome-webfont.woff .
|
||||
ln -s %{_datadir}/fonts/fontawesome/fontawesome-webfont.woff2 .
|
||||
ln -s %{_datadir}/fonts/google-roboto-slab-fonts/RobotoSlab-Bold.ttf RobotoSlab/roboto-slab-v7-bold.ttf
|
||||
ln -s %{_datadir}/fonts/google-roboto-slab-fonts/RobotoSlab-Regular.ttf RobotoSlab/roboto-slab-v7-regular.ttf
|
||||
ln -s %{_datadir}/fonts/lato/Lato-Bold.ttf Lato/lato-bold.ttf
|
||||
ln -s %{_datadir}/fonts/lato/Lato-BoldItalic.ttf Lato/lato-bolditalic.ttf
|
||||
ln -s %{_datadir}/fonts/lato/Lato-Italic.ttf Lato/lato-italic.ttf
|
||||
ln -s %{_datadir}/fonts/lato/Lato-Regular.ttf Lato/lato-regular.ttf
|
||||
popd
|
||||
cp -p fonts/RobotoSlab/*.{eot,woff,woff2} \
|
||||
%{buildroot}%{python3_sitelib}/%{srcname}/static/fonts/RobotoSlab
|
||||
cp -p fonts/Lato/*.{eot,woff,woff2} \
|
||||
%{buildroot}%{python3_sitelib}/%{srcname}/static/fonts/Lato
|
||||
|
||||
%if %{without bootstrap}
|
||||
rm docs/build/html/.buildinfo
|
||||
rm -fr docs/build/html/_static/fonts
|
||||
cp -a %{buildroot}%{python3_sitelib}/%{srcname}/static/fonts \
|
||||
docs/build/html/_static
|
||||
%endif
|
||||
|
||||
%if %{without bootstrap}
|
||||
%check
|
||||
pytest
|
||||
%endif
|
||||
|
||||
%files -n python3-%{srcname}
|
||||
%doc README.html
|
||||
%license LICENSE
|
||||
%{python3_sitelib}/%{srcname}*
|
||||
|
||||
%if %{without bootstrap}
|
||||
%files doc
|
||||
%doc docs/build/html
|
||||
%license LICENSE
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.3-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Sat May 23 2020 Miro Hrončok <mhroncok@redhat.com> - 0.4.3-13
|
||||
- Rebuilt for Python 3.9
|
||||
|
||||
* Fri May 22 2020 Miro Hrončok <mhroncok@redhat.com> - 0.4.3-12
|
||||
- Bootstrap for Python 3.9
|
||||
|
||||
* Wed Mar 18 2020 Jerry James <loganjerry@gmail.com> - 0.4.3-11
|
||||
- Fix symlinks to the Roboto fonts
|
||||
|
||||
* Tue Feb 4 2020 Jerry James <loganjerry@gmail.com> - 0.4.3-10
|
||||
- BR readthedocs-sphinx-ext so the tests can be run
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.3-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Fri Jan 24 2020 Jerry James <loganjerry@gmail.com> - 0.4.3-8
|
||||
- Add -doc subpackage
|
||||
|
||||
* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 0.4.3-7
|
||||
- Rebuilt for Python 3.8.0rc1 (#1748018)
|
||||
|
||||
* Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 0.4.3-6
|
||||
- Rebuilt for Python 3.8
|
||||
|
||||
* Thu Aug 15 2019 Miro Hrončok <mhroncok@redhat.com> - 0.4.3-5
|
||||
- Bootstrap for Python 3.8
|
||||
|
||||
* Tue Aug 6 2019 Jerry James <loganjerry@gmail.com> - 0.4.3-4
|
||||
- Add -script patch to silence deprecation warnings
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Wed Mar 06 2019 Miro Hrončok <mhroncok@redhat.com> - 0.4.3-2
|
||||
- Subpackage python2-sphinx_rtd_theme has been removed
|
||||
See https://fedoraproject.org/wiki/Changes/Sphinx2
|
||||
|
||||
* Tue Feb 12 2019 Jerry James <loganjerry@gmail.com> - 0.4.3-1
|
||||
- New upstream version
|
||||
- Use the github tarball, which has docs, instead of the pypi tarball
|
||||
- Add %%check script
|
||||
|
||||
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Mon Oct 22 2018 Jerry James <loganjerry@gmail.com> - 0.4.2-1
|
||||
- New upstream version
|
||||
|
||||
* Tue Jul 31 2018 Jerry James <loganjerry@gmail.com> - 0.4.1-1
|
||||
- New upstream version
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Mon Jul 2 2018 Jerry James <loganjerry@gmail.com> - 0.4.0-1
|
||||
- New upstream version
|
||||
|
||||
* Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 0.3.1-2
|
||||
- Rebuilt for Python 3.7
|
||||
|
||||
* Wed May 2 2018 Jerry James <loganjerry@gmail.com> - 0.3.1-1
|
||||
- New upstream version
|
||||
|
||||
* Sat Apr 7 2018 Jerry James <loganjerry@gmail.com> - 0.3.0-1
|
||||
- New upstream version
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Mon Mar 6 2017 Jerry James <loganjerry@gmail.com> - 0.2.4-1
|
||||
- New upstream version
|
||||
|
||||
* Sat Mar 4 2017 Jerry James <loganjerry@gmail.com> - 0.2.2-1
|
||||
- New upstream version
|
||||
|
||||
* Fri Mar 3 2017 Jerry James <loganjerry@gmail.com> - 0.2.0-1
|
||||
- New upstream version
|
||||
- Unbundle the roboto fonts
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.9-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Fri Dec 09 2016 Charalampos Stratakis <cstratak@redhat.com> - 0.1.9-3
|
||||
- Rebuild for Python 3.6
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.9-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Mon Feb 1 2016 Jerry James <loganjerry@gmail.com> - 0.1.9-1
|
||||
- Comply with latest python packaging guidelines
|
||||
|
||||
* Tue Nov 24 2015 Jerry James <loganjerry@gmail.com> - 0.1.9-1
|
||||
- New upstream version
|
||||
|
||||
* Mon Nov 16 2015 Piotr Popieluch <piotr1212@gmail.com> - 0.1.8-4
|
||||
- Add Requires: fontawesome-web (rhbz#1282297)
|
||||
|
||||
* Tue Oct 13 2015 Robert Kuska <rkuska@redhat.com> - 0.1.8-3
|
||||
- Rebuilt for Python3.5 rebuild
|
||||
|
||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.8-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Wed May 13 2015 Jerry James <loganjerry@gmail.com> - 0.1.8-1
|
||||
- New upstream version
|
||||
- Unbundle the Lato fonts
|
||||
|
||||
* Wed Mar 11 2015 Jerry James <loganjerry@gmail.com> - 0.1.7-1
|
||||
- New upstream version
|
||||
|
||||
* Sat Feb 21 2015 Jerry James <loganjerry@gmail.com> - 0.1.6-2
|
||||
- Use license macro
|
||||
|
||||
* Thu Jul 3 2014 Jerry James <loganjerry@gmail.com> - 0.1.6-1
|
||||
- Initial RPM
|
2
sources
Normal file
2
sources
Normal file
@ -0,0 +1,2 @@
|
||||
SHA512 (sphinx_rtd_theme-0.4.3.tar.gz) = 6e5d4d0c44ea8acdf382dd589a194be2777e4c4f66f27705eb32d0507cf71b9d289df860bc3d9845242629cd92d62154040f9063f1c05ff6f329e210e14a6a9a
|
||||
SHA512 (objects.inv) = 29b2885c23f0d9697f6fa88ded72d7d622a0807ea34f4fe04fefe3809dc44486333cdfade4dc5bc99d18ff50423f6291d63d704c5a74b1d755eb52fbbc617c08
|
Loading…
Reference in New Issue
Block a user