import python-sphinx_rtd_theme-0.5.1-4.el9
This commit is contained in:
commit
0408df7e34
2
.gitignore
vendored
Normal file
2
.gitignore
vendored
Normal file
@ -0,0 +1,2 @@
|
|||||||
|
SOURCES/objects.inv
|
||||||
|
SOURCES/sphinx_rtd_theme-0.5.1.tar.gz
|
2
.python-sphinx_rtd_theme.metadata
Normal file
2
.python-sphinx_rtd_theme.metadata
Normal file
@ -0,0 +1,2 @@
|
|||||||
|
8572b8e45ad362a9dac225c7512e960d634f186d SOURCES/objects.inv
|
||||||
|
0a7a5203dc9e888d22fd1bb44e59e0f8f5ffad71 SOURCES/sphinx_rtd_theme-0.5.1.tar.gz
|
58
SOURCES/python-sphinx_rtd_theme-html5shiv.patch
Normal file
58
SOURCES/python-sphinx_rtd_theme-html5shiv.patch
Normal file
@ -0,0 +1,58 @@
|
|||||||
|
--- package.json.orig 2020-06-17 09:58:25.000000000 -0600
|
||||||
|
+++ package.json 2020-12-10 08:27:04.247691945 -0700
|
||||||
|
@@ -16,7 +16,6 @@
|
||||||
|
"css-loader": "^3.1.0",
|
||||||
|
"file-loader": "^3.0.1",
|
||||||
|
"font-awesome": "^4.7.0",
|
||||||
|
- "html5shiv": "^3.7.3",
|
||||||
|
"imports-loader": "^0.8.0",
|
||||||
|
"jquery": "^3.4.1",
|
||||||
|
"lato-font": "^3.0.0",
|
||||||
|
--- package-lock.json.orig 2020-06-17 09:58:25.000000000 -0600
|
||||||
|
+++ package-lock.json 2020-12-10 08:27:28.658644927 -0700
|
||||||
|
@@ -3614,12 +3614,6 @@
|
||||||
|
"integrity": "sha1-DfKTUfByEWNRXfueVUPl9u7VFi8=",
|
||||||
|
"dev": true
|
||||||
|
},
|
||||||
|
- "html5shiv": {
|
||||||
|
- "version": "3.7.3",
|
||||||
|
- "resolved": "https://registry.npmjs.org/html5shiv/-/html5shiv-3.7.3.tgz",
|
||||||
|
- "integrity": "sha1-14qEo2e8uacQEA1XgCw4ewhGMdI=",
|
||||||
|
- "dev": true
|
||||||
|
- },
|
||||||
|
"http-deceiver": {
|
||||||
|
"version": "1.2.7",
|
||||||
|
"resolved": "https://registry.npmjs.org/http-deceiver/-/http-deceiver-1.2.7.tgz",
|
||||||
|
--- sphinx_rtd_theme/layout.html.orig 2020-06-17 09:58:25.000000000 -0600
|
||||||
|
+++ sphinx_rtd_theme/layout.html 2020-12-10 08:28:12.607551700 -0700
|
||||||
|
@@ -45,9 +45,6 @@
|
||||||
|
|
||||||
|
{# JAVASCRIPTS #}
|
||||||
|
{%- block scripts %}
|
||||||
|
- <!--[if lt IE 9]>
|
||||||
|
- <script src="{{ pathto('_static/js/html5shiv.min.js', 1) }}"></script>
|
||||||
|
- <![endif]-->
|
||||||
|
{%- if not embedded %}
|
||||||
|
{# XXX Sphinx 1.8.0 made this an external js-file, quick fix until we refactor the template to inherert more blocks directly from sphinx #}
|
||||||
|
{% if sphinx_version >= "1.8.0" %}
|
||||||
|
--- webpack.common.js.orig 2020-06-17 09:58:25.000000000 -0600
|
||||||
|
+++ webpack.common.js 2020-12-10 08:26:44.191730575 -0700
|
||||||
|
@@ -1,6 +1,5 @@
|
||||||
|
const path = require("path");
|
||||||
|
const MiniCssExtractPlugin = require("mini-css-extract-plugin");
|
||||||
|
-const CopyPlugin = require('copy-webpack-plugin');
|
||||||
|
|
||||||
|
module.exports = {
|
||||||
|
entry: {
|
||||||
|
@@ -66,11 +65,5 @@ module.exports = {
|
||||||
|
filename: "css/[name].css?[hash]",
|
||||||
|
chunkFilename: "css/[name].css?[hash]"
|
||||||
|
}),
|
||||||
|
- new CopyPlugin([
|
||||||
|
- {
|
||||||
|
- from: 'node_modules/html5shiv/dist/*.min.js',
|
||||||
|
- flatten: true,
|
||||||
|
- to: path.resolve(__dirname,'sphinx_rtd_theme/static/js') },
|
||||||
|
- ]),
|
||||||
|
]
|
||||||
|
};
|
31
SOURCES/python-sphinx_rtd_theme-unbundle-fonts.patch
Normal file
31
SOURCES/python-sphinx_rtd_theme-unbundle-fonts.patch
Normal file
File diff suppressed because one or more lines are too long
282
SPECS/python-sphinx_rtd_theme.spec
Normal file
282
SPECS/python-sphinx_rtd_theme.spec
Normal file
@ -0,0 +1,282 @@
|
|||||||
|
%global srcname sphinx_rtd_theme
|
||||||
|
|
||||||
|
# Disables tests and docs
|
||||||
|
%bcond_with bootstrap
|
||||||
|
|
||||||
|
Name: python-%{srcname}
|
||||||
|
Version: 0.5.1
|
||||||
|
Release: 4%{?dist}
|
||||||
|
Summary: Sphinx theme for readthedocs.org
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://github.com/rtfd/%{srcname}
|
||||||
|
Source0: https://github.com/rtfd/%{srcname}/archive/%{version}/%{srcname}-%{version}.tar.gz
|
||||||
|
# The koji builders do not have network access, and this file is not included
|
||||||
|
# in any Fedora package, so we retrieve it for offline use.
|
||||||
|
Source1: https://docs.readthedocs.io/en/latest/objects.inv
|
||||||
|
# Remove all traces of html5shiv. We have no interest in supporting ancient
|
||||||
|
# versions of Internet Explorer.
|
||||||
|
Patch0: %{name}-html5shiv.patch
|
||||||
|
# Unbundle fonts. Refer to local fonts instead.
|
||||||
|
Patch1: %{name}-unbundle-fonts.patch
|
||||||
|
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
BuildRequires: font(fontawesome)
|
||||||
|
BuildRequires: font(lato)
|
||||||
|
BuildRequires: font(robotoslab)
|
||||||
|
BuildRequires: make
|
||||||
|
BuildRequires: python%{python3_pkgversion}-devel
|
||||||
|
BuildRequires: %{py3_dist docutils}
|
||||||
|
BuildRequires: %{py3_dist readthedocs-sphinx-ext}
|
||||||
|
BuildRequires: %{py3_dist setuptools}
|
||||||
|
%if %{without bootstrap}
|
||||||
|
BuildRequires: %{py3_dist pytest}
|
||||||
|
BuildRequires: %{py3_dist sphinx}
|
||||||
|
BuildRequires: %{py3_dist sphinxcontrib-httpdomain}
|
||||||
|
BuildRequires: python-sphinx-doc
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%description
|
||||||
|
This is a prototype mobile-friendly sphinx theme for readthedocs.org.
|
||||||
|
It's currently in development and includes some rtd variable checks that
|
||||||
|
can be ignored if you're just trying to use it on your project outside
|
||||||
|
of that site.
|
||||||
|
|
||||||
|
%package -n python%{python3_pkgversion}-%{srcname}
|
||||||
|
Summary: Sphinx theme for readthedocs.org
|
||||||
|
Requires: font(fontawesome)
|
||||||
|
Requires: font(lato)
|
||||||
|
Requires: font(robotoslab)
|
||||||
|
|
||||||
|
%description -n python%{python3_pkgversion}-%{srcname}
|
||||||
|
This is a prototype mobile-friendly sphinx theme for readthedocs.org.
|
||||||
|
It's currently in development and includes some rtd variable checks that
|
||||||
|
can be ignored if you're just trying to use it on your project outside
|
||||||
|
of that site.
|
||||||
|
|
||||||
|
%if %{without bootstrap}
|
||||||
|
%package doc
|
||||||
|
Summary: Documentation for the Sphinx theme for readthedocs.org
|
||||||
|
Requires: font(fontawesome)
|
||||||
|
Requires: font(lato)
|
||||||
|
Requires: font(robotoslab)
|
||||||
|
|
||||||
|
%description doc
|
||||||
|
This package contains documentation for the Sphinx theme for
|
||||||
|
readthedocs.org.
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -p0 -n %{srcname}-%{version}
|
||||||
|
|
||||||
|
# Use local objects.inv for intersphinx
|
||||||
|
sed -e "s|\('https://docs\.readthedocs\.io/en/latest/', \)None|\1'%{SOURCE1}'|" \
|
||||||
|
-e "s|\('http://www\.sphinx-doc\.org/en/stable/', \)None|\1'%{_docdir}/python-sphinx-doc/html/objects.inv'|" \
|
||||||
|
-i docs/conf.py
|
||||||
|
|
||||||
|
# We cannot build the Javascript from source at this time, due to many missing
|
||||||
|
# dependencies. Convince the build script to skip building the Javascript and
|
||||||
|
# go on to the python.
|
||||||
|
mkdir -p build/lib/%{srcname}/static/js
|
||||||
|
cp -p sphinx_rtd_theme/static/js/badge_only.js build/lib/%{srcname}/static/js
|
||||||
|
cp -p sphinx_rtd_theme/static/js/theme.js build/lib/%{srcname}/static/js
|
||||||
|
sed -i "/'build_py'/d" setup.py
|
||||||
|
|
||||||
|
%build
|
||||||
|
%py3_build
|
||||||
|
|
||||||
|
%if %{without bootstrap}
|
||||||
|
# Build the documentation
|
||||||
|
make -C docs html
|
||||||
|
%endif
|
||||||
|
|
||||||
|
rst2html --no-datestamp README.rst README.html
|
||||||
|
|
||||||
|
%install
|
||||||
|
%py3_install
|
||||||
|
|
||||||
|
%if %{without bootstrap}
|
||||||
|
rm docs/build/html/.buildinfo
|
||||||
|
%endif
|
||||||
|
|
||||||
|
# Unbundle fonts
|
||||||
|
rm -fr %{buildroot}%{python3_sitelib}/%{srcname}/static/css/fonts
|
||||||
|
|
||||||
|
%if %{without bootstrap}
|
||||||
|
%check
|
||||||
|
pytest
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%files -n python%{python3_pkgversion}-%{srcname}
|
||||||
|
%doc README.html
|
||||||
|
%license LICENSE
|
||||||
|
%{python3_sitelib}/%{srcname}-*.egg-info/
|
||||||
|
%dir %{python3_sitelib}/%{srcname}/
|
||||||
|
%{python3_sitelib}/%{srcname}/__pycache__/
|
||||||
|
%{python3_sitelib}/%{srcname}/static/
|
||||||
|
%{python3_sitelib}/%{srcname}/*.html
|
||||||
|
%{python3_sitelib}/%{srcname}/*.py
|
||||||
|
%{python3_sitelib}/%{srcname}/theme.conf
|
||||||
|
%dir %{python3_sitelib}/%{srcname}/locale/
|
||||||
|
%{python3_sitelib}/%{srcname}/locale/sphinx.pot
|
||||||
|
%lang(de) %{python3_sitelib}/%{srcname}/locale/de/
|
||||||
|
%lang(en) %{python3_sitelib}/%{srcname}/locale/en/
|
||||||
|
%lang(es) %{python3_sitelib}/%{srcname}/locale/es/
|
||||||
|
%lang(et) %{python3_sitelib}/%{srcname}/locale/et/
|
||||||
|
%lang(fr) %{python3_sitelib}/%{srcname}/locale/fr/
|
||||||
|
%lang(nl) %{python3_sitelib}/%{srcname}/locale/nl/
|
||||||
|
%lang(pt) %{python3_sitelib}/%{srcname}/locale/pt_BR/
|
||||||
|
%lang(ru) %{python3_sitelib}/%{srcname}/locale/ru/
|
||||||
|
%lang(sv) %{python3_sitelib}/%{srcname}/locale/sv/
|
||||||
|
%lang(tr) %{python3_sitelib}/%{srcname}/locale/tr/
|
||||||
|
%lang(zh) %{python3_sitelib}/%{srcname}/locale/zh_CN/
|
||||||
|
|
||||||
|
%if %{without bootstrap}
|
||||||
|
%files doc
|
||||||
|
%doc docs/build/html
|
||||||
|
%license LICENSE
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 0.5.1-4
|
||||||
|
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||||
|
Related: rhbz#1991688
|
||||||
|
|
||||||
|
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 0.5.1-3
|
||||||
|
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||||
|
|
||||||
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jan 4 2021 Jerry James <loganjerry@gmail.com> - 0.5.1-1
|
||||||
|
- Version 0.5.1
|
||||||
|
- Do not list language files twice
|
||||||
|
|
||||||
|
* Thu Dec 10 2020 Jerry James <loganjerry@gmail.com> - 0.5.0-1
|
||||||
|
- Version 0.5.0
|
||||||
|
- Drop upstreamed -script patch
|
||||||
|
- Do not even link to fonts; modify the CSS to point to system fonts
|
||||||
|
- Remove all traces of html5shiv
|
||||||
|
|
||||||
|
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.3-14
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat May 23 2020 Miro Hrončok <mhroncok@redhat.com> - 0.4.3-13
|
||||||
|
- Rebuilt for Python 3.9
|
||||||
|
|
||||||
|
* Fri May 22 2020 Miro Hrončok <mhroncok@redhat.com> - 0.4.3-12
|
||||||
|
- Bootstrap for Python 3.9
|
||||||
|
|
||||||
|
* Wed Mar 18 2020 Jerry James <loganjerry@gmail.com> - 0.4.3-11
|
||||||
|
- Fix symlinks to the Roboto fonts
|
||||||
|
|
||||||
|
* Tue Feb 4 2020 Jerry James <loganjerry@gmail.com> - 0.4.3-10
|
||||||
|
- BR readthedocs-sphinx-ext so the tests can be run
|
||||||
|
|
||||||
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.3-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 24 2020 Jerry James <loganjerry@gmail.com> - 0.4.3-8
|
||||||
|
- Add -doc subpackage
|
||||||
|
|
||||||
|
* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 0.4.3-7
|
||||||
|
- Rebuilt for Python 3.8.0rc1 (#1748018)
|
||||||
|
|
||||||
|
* Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 0.4.3-6
|
||||||
|
- Rebuilt for Python 3.8
|
||||||
|
|
||||||
|
* Thu Aug 15 2019 Miro Hrončok <mhroncok@redhat.com> - 0.4.3-5
|
||||||
|
- Bootstrap for Python 3.8
|
||||||
|
|
||||||
|
* Tue Aug 6 2019 Jerry James <loganjerry@gmail.com> - 0.4.3-4
|
||||||
|
- Add -script patch to silence deprecation warnings
|
||||||
|
|
||||||
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.3-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Mar 06 2019 Miro Hrončok <mhroncok@redhat.com> - 0.4.3-2
|
||||||
|
- Subpackage python2-sphinx_rtd_theme has been removed
|
||||||
|
See https://fedoraproject.org/wiki/Changes/Sphinx2
|
||||||
|
|
||||||
|
* Tue Feb 12 2019 Jerry James <loganjerry@gmail.com> - 0.4.3-1
|
||||||
|
- New upstream version
|
||||||
|
- Use the github tarball, which has docs, instead of the pypi tarball
|
||||||
|
- Add %%check script
|
||||||
|
|
||||||
|
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.2-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Oct 22 2018 Jerry James <loganjerry@gmail.com> - 0.4.2-1
|
||||||
|
- New upstream version
|
||||||
|
|
||||||
|
* Tue Jul 31 2018 Jerry James <loganjerry@gmail.com> - 0.4.1-1
|
||||||
|
- New upstream version
|
||||||
|
|
||||||
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jul 2 2018 Jerry James <loganjerry@gmail.com> - 0.4.0-1
|
||||||
|
- New upstream version
|
||||||
|
|
||||||
|
* Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 0.3.1-2
|
||||||
|
- Rebuilt for Python 3.7
|
||||||
|
|
||||||
|
* Wed May 2 2018 Jerry James <loganjerry@gmail.com> - 0.3.1-1
|
||||||
|
- New upstream version
|
||||||
|
|
||||||
|
* Sat Apr 7 2018 Jerry James <loganjerry@gmail.com> - 0.3.0-1
|
||||||
|
- New upstream version
|
||||||
|
|
||||||
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.4-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.4-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Mar 6 2017 Jerry James <loganjerry@gmail.com> - 0.2.4-1
|
||||||
|
- New upstream version
|
||||||
|
|
||||||
|
* Sat Mar 4 2017 Jerry James <loganjerry@gmail.com> - 0.2.2-1
|
||||||
|
- New upstream version
|
||||||
|
|
||||||
|
* Fri Mar 3 2017 Jerry James <loganjerry@gmail.com> - 0.2.0-1
|
||||||
|
- New upstream version
|
||||||
|
- Unbundle the roboto fonts
|
||||||
|
|
||||||
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.9-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Dec 09 2016 Charalampos Stratakis <cstratak@redhat.com> - 0.1.9-3
|
||||||
|
- Rebuild for Python 3.6
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.9-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Feb 1 2016 Jerry James <loganjerry@gmail.com> - 0.1.9-1
|
||||||
|
- Comply with latest python packaging guidelines
|
||||||
|
|
||||||
|
* Tue Nov 24 2015 Jerry James <loganjerry@gmail.com> - 0.1.9-1
|
||||||
|
- New upstream version
|
||||||
|
|
||||||
|
* Mon Nov 16 2015 Piotr Popieluch <piotr1212@gmail.com> - 0.1.8-4
|
||||||
|
- Add Requires: fontawesome-web (rhbz#1282297)
|
||||||
|
|
||||||
|
* Tue Oct 13 2015 Robert Kuska <rkuska@redhat.com> - 0.1.8-3
|
||||||
|
- Rebuilt for Python3.5 rebuild
|
||||||
|
|
||||||
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.8-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed May 13 2015 Jerry James <loganjerry@gmail.com> - 0.1.8-1
|
||||||
|
- New upstream version
|
||||||
|
- Unbundle the Lato fonts
|
||||||
|
|
||||||
|
* Wed Mar 11 2015 Jerry James <loganjerry@gmail.com> - 0.1.7-1
|
||||||
|
- New upstream version
|
||||||
|
|
||||||
|
* Sat Feb 21 2015 Jerry James <loganjerry@gmail.com> - 0.1.6-2
|
||||||
|
- Use license macro
|
||||||
|
|
||||||
|
* Thu Jul 3 2014 Jerry James <loganjerry@gmail.com> - 0.1.6-1
|
||||||
|
- Initial RPM
|
Loading…
Reference in New Issue
Block a user