Python documentation generator
Go to file
Zbigniew Jędrzejewski-Szmek de4211c65d Drop explicit locale setting
Python3 now sets unicode locale automatically, this workaround
should not be necessary anymore. For python2, let's use the lighter locale.
2018-11-18 22:08:30 +01:00
.gitignore Update to 1.7.6 2018-07-23 18:00:01 +02:00
default-sphinx-command.in environment-modules is less featureful than Lmod. 2017-01-31 11:52:19 -08:00
python2-sphinx Add environment-module related files 2016-12-30 12:46:55 -08:00
python3-sphinx Add environment-module related files 2016-12-30 12:46:55 -08:00
python-sphinx.spec Drop explicit locale setting 2018-11-18 22:08:30 +01:00
README.fedora Add recipe for setting the system default to the README.fedora 2017-01-26 18:13:59 -08:00
sources Update to 1.7.6 2018-07-23 18:00:01 +02:00
sphinx-test_theming.diff Update to 1.7.6 2018-07-23 18:00:01 +02:00
xfail-test_latex_remote_images.patch Update to 1.6.3 (rhbz#1426928) 2017-07-20 19:58:34 +02:00
zz-modules-python-sphinx.csh environment-modules is less featureful than Lmod. 2017-01-31 11:52:19 -08:00
zz-modules-python-sphinx.sh environment-modules is less featureful than Lmod. 2017-01-31 11:52:19 -08:00

Sphinx with autodoc is sensitive to whether it is run via Python2 or Python3
as it uses the Python version that it is invoked with to parse the source
files for docstrings.  Unfortunately, there's no logic to detect this within
the sphinx commands and the standard Makefiles generated by sphinx-quickstart
don't give the user any hint that it might be a problem.

The Fedora package tries to mitigate this problem by allowing the user to
switch between the Python2 and Python3 versions using environment-modules.  To
switch to the Python3 commands, use::

    module swap python-sphinx/python3-sphinx

To switch to the Python2 version, use::

    module swap python-sphinx/python2-sphinx

The default install uses the python2 version of the modules.
If the system administrator wishes to change the default, edit the
/etc/profile.d/zz-modules-python-sphinx.sh and
/etc/profile.d/zz-modules-python-sphinx.csh files to specify a specific
alternative to use.  For instance, to make the python3 version the default,
modify it like so::

    @@ -1,2 +1,2 @@
     # Add path to the default python-sphinx scripts on this version of Fedora
    -module load python-sphinx
    +module load python-sphinx/python3-sphinx