Python documentation generator
Go to file
2018-07-13 17:17:13 +02:00
.gitignore Update to 1.7.5 (bz#1570451) 2018-06-19 17:50:51 +02:00
b553c23ab1cadfe75db6637ca95daa11abc87049.patch Add patch to fix build and another for #1589868 2018-07-05 18:51:53 +02:00
default-sphinx-command.in environment-modules is less featureful than Lmod. 2017-01-31 11:52:19 -08:00
python2-sphinx Add environment-module related files 2016-12-30 12:46:55 -08:00
python3-sphinx Add environment-module related files 2016-12-30 12:46:55 -08:00
python-sphinx.spec Remove unused dependencies on xapian and simplejson 2018-07-13 17:17:13 +02:00
README.fedora Add recipe for setting the system default to the README.fedora 2017-01-26 18:13:59 -08:00
sources Update to 1.7.5 (bz#1570451) 2018-06-19 17:50:51 +02:00
sphinx-test_theming.diff Add patch to fix build and another for #1589868 2018-07-05 18:51:53 +02:00
xfail-test_latex_remote_images.patch Update to 1.6.3 (rhbz#1426928) 2017-07-20 19:58:34 +02:00
zz-modules-python-sphinx.csh environment-modules is less featureful than Lmod. 2017-01-31 11:52:19 -08:00
zz-modules-python-sphinx.sh environment-modules is less featureful than Lmod. 2017-01-31 11:52:19 -08:00

Sphinx with autodoc is sensitive to whether it is run via Python2 or Python3
as it uses the Python version that it is invoked with to parse the source
files for docstrings.  Unfortunately, there's no logic to detect this within
the sphinx commands and the standard Makefiles generated by sphinx-quickstart
don't give the user any hint that it might be a problem.

The Fedora package tries to mitigate this problem by allowing the user to
switch between the Python2 and Python3 versions using environment-modules.  To
switch to the Python3 commands, use::

    module swap python-sphinx/python3-sphinx

To switch to the Python2 version, use::

    module swap python-sphinx/python2-sphinx

The default install uses the python2 version of the modules.
If the system administrator wishes to change the default, edit the
/etc/profile.d/zz-modules-python-sphinx.sh and
/etc/profile.d/zz-modules-python-sphinx.csh files to specify a specific
alternative to use.  For instance, to make the python3 version the default,
modify it like so::

    @@ -1,2 +1,2 @@
     # Add path to the default python-sphinx scripts on this version of Fedora
    -module load python-sphinx
    +module load python-sphinx/python3-sphinx