Merged update from upstream sources

This is an automated DistroBaker update from upstream sources.
If you do not know what this is about or would like to opt out,
contact the OSCI team.

Source: https://src.fedoraproject.org/rpms/python-sphinx.git#67bdc19f103aca62fb949ed3f4c5a50c5fe4a97e
This commit is contained in:
DistroBaker 2020-11-25 10:45:34 +00:00
parent 99336d2a58
commit 3871ba7abd
4 changed files with 26 additions and 85 deletions

1
.gitignore vendored
View File

@ -25,3 +25,4 @@
/Sphinx-3.1.1.tar.gz
/Sphinx-3.1.2.tar.gz
/Sphinx-3.2.1.tar.gz
/Sphinx-3.3.1.tar.gz

View File

@ -1,36 +0,0 @@
From 85b24a2e88ea71edc728aff3b078d34c2f374f06 Mon Sep 17 00:00:00 2001
From: Takeshi KOMIYA <i.tkomiya@gmail.com>
Date: Sun, 13 Sep 2020 09:16:32 +0900
Subject: [PATCH] Fix our test failed with pygments-2.7.0
Since pygments-2.7.0, it has changed the style of output HTML.
That makes our test broken. This fixes it to pass with new pygments.
---
tests/test_build_html.py | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/tests/test_build_html.py b/tests/test_build_html.py
index e949f11572..1efc6c14a6 100644
--- a/tests/test_build_html.py
+++ b/tests/test_build_html.py
@@ -10,8 +10,10 @@
import os
import re
+from distutils.version import LooseVersion
from itertools import cycle, chain
+import pygments
import pytest
from html5lib import HTMLParser
@@ -1591,4 +1593,8 @@ def test_html_codeblock_linenos_style_inline(app):
app.build()
content = (app.outdir / 'index.html').read_text()
- assert '<span class="lineno">1 </span>' in content
+ pygments_version = tuple(LooseVersion(pygments.__version__).version)
+ if pygments_version > (2, 7):
+ assert '<span class="linenos">1</span>' in content
+ else:
+ assert '<span class="lineno">1 </span>' in content

View File

@ -21,11 +21,11 @@
%global upstream_name Sphinx
Name: python-sphinx
%global general_version 3.2.1
%global general_version 3.3.1
#global prerel ...
%global upstream_version %{general_version}%{?prerel}
Version: %{general_version}%{?prerel:~%{prerel}}
Release: 2%{?dist}
Release: 1%{?dist}
Epoch: 1
Summary: Python documentation generator
@ -42,30 +42,10 @@ Source0: %{pypi_source %{upstream_name} %{upstream_version}}
# which causes that test to fail.
Patch1: sphinx-test_theming.diff
# Latest version of python-pygments (2.7.1) breaks python-sphinx.
# It is already fixed in upstream and this patch can be removed
# once new version of python-sphinx is released.
Patch2: https://github.com/sphinx-doc/sphinx/commit/85b24a2e88ea71edc728aff3b078d34c2f374f06.patch
BuildArch: noarch
BuildRequires: python%{python3_pkgversion}-devel
BuildRequires: python%{python3_pkgversion}-setuptools
BuildRequires: python%{python3_pkgversion}-babel
BuildRequires: python%{python3_pkgversion}-docutils
BuildRequires: python%{python3_pkgversion}-imagesize
BuildRequires: python%{python3_pkgversion}-jinja2
BuildRequires: python%{python3_pkgversion}-packaging
BuildRequires: python%{python3_pkgversion}-pygments
BuildRequires: python%{python3_pkgversion}-requests
BuildRequires: python%{python3_pkgversion}-sphinxcontrib-applehelp
BuildRequires: python%{python3_pkgversion}-sphinxcontrib-devhelp
BuildRequires: python%{python3_pkgversion}-sphinxcontrib-htmlhelp
BuildRequires: python%{python3_pkgversion}-sphinxcontrib-jsmath
BuildRequires: python%{python3_pkgversion}-sphinxcontrib-qthelp
BuildRequires: python%{python3_pkgversion}-sphinxcontrib-serializinghtml
BuildRequires: python%{python3_pkgversion}-sphinx-theme-alabaster
BuildRequires: pyproject-rpm-macros
%if %{with websupport}
BuildRequires: python%{python3_pkgversion}-sphinxcontrib-websupport
@ -78,11 +58,7 @@ BuildRequires: dos2unix
# tests import _testcapi
BuildRequires: python%{python3_pkgversion}-test
BuildRequires: python%{python3_pkgversion}-html5lib
BuildRequires: python%{python3_pkgversion}-mock
BuildRequires: python%{python3_pkgversion}-pytest
BuildRequires: python%{python3_pkgversion}-snowballstemmer
BuildRequires: gcc
BuildRequires: gettext
BuildRequires: graphviz
BuildRequires: texinfo
@ -159,22 +135,12 @@ Summary: Python documentation generator
Recommends: graphviz
Recommends: ImageMagick
%{?python_provide:%python_provide python%{python3_pkgversion}-sphinx}
# Bundled JavaScript
Provides: bundled(jquery) = 3.2.1
Provides: bundled(jquery) = 3.5.1
Provides: bundled(underscore) = 1.3.1
Provides: bundled(css3-mediaqueries) = 1.0
# Remove in F33
Obsoletes: python-sphinx-locale < 1:2
Provides: python-sphinx-locale = %{epoch}:%{version}-%{release}
Obsoletes: python%{python3_pkgversion}-sphinxcontrib-napoleon < 0.3.0
Provides: python%{python3_pkgversion}-sphinxcontrib-napoleon = %{epoch}:%{version}-%{release}
Conflicts: python2-Sphinx < 1:2
Conflicts: python2-sphinx < 1:2
Provides: python(Sphinx) = %{epoch}:%{version}-%{release}
%description -n python%{python3_pkgversion}-sphinx
Sphinx is a tool that makes it easy to create intelligent and
beautiful documentation for Python projects (or other documents
@ -238,11 +204,8 @@ Requires: tex(upquote.sty)
Requires: tex(utf8x.def)
Requires: tex(wrapfig.sty)
%{?python_provide:%python_provide python%{python3_pkgversion}-sphinx-latex}
# Remove in F33
Obsoletes: python-sphinx-latex < 1:2
Provides: python-sphinx-latex = %{epoch}:%{version}-%{release}
# No files in this package, automatic provides don't work:
%py_provides python%{python3_pkgversion}-sphinx-latex
%description -n python%{python3_pkgversion}-sphinx-latex
Sphinx is a tool that makes it easy to create intelligent and
@ -282,13 +245,22 @@ dos2unix -k ./sphinx/themes/basic/static/jquery.js
rm tests/test_ext_imgconverter.py
%endif
# Don't measure coverage:
sed -i '/pytest-cov/d' setup.py
# Not needed on recent Pythons, https://github.com/sphinx-doc/sphinx/pull/8483
sed -i '/typed_ast/d' setup.py
%generate_buildrequires
%pyproject_buildrequires %{?with_tests:-x test}
%build
%py3_build
%pyproject_wheel
export PYTHONPATH=$PWD
pushd doc
export SPHINXBUILD="%{__python3} ../sphinx/cmd/build.py"
export SPHINXBUILD="%{python3} ../sphinx/cmd/build.py"
make html SPHINXBUILD="$SPHINXBUILD"
make man SPHINXBUILD="$SPHINXBUILD"
rm -rf _build/html/.buildinfo
@ -297,7 +269,7 @@ popd
%install
%py3_install
%pyproject_install
# For backwards compatibility. Remove with care, if at all
for i in sphinx-{apidoc,autogen,build,quickstart}; do
@ -371,7 +343,7 @@ mkdir %{buildroot}%{python3_sitelib}/sphinxcontrib
%{_bindir}/sphinx-*
%{python3_sitelib}/sphinx/
%dir %{python3_sitelib}/sphinxcontrib/
%{python3_sitelib}/Sphinx-%{upstream_version}-py%{python3_version}.egg-info/
%{python3_sitelib}/Sphinx-%{upstream_version}.dist-info/
%dir %{_datadir}/sphinx/
%dir %{_datadir}/sphinx/locale
%dir %{_datadir}/sphinx/locale/*
@ -388,6 +360,10 @@ mkdir %{buildroot}%{python3_sitelib}/sphinxcontrib
%changelog
* Mon Nov 23 2020 Miro Hrončok <mhroncok@redhat.com> - 1:3.3.1-1
- Update to 3.3.1
- Fixes: rhbz#1893752
* Wed Oct 14 2020 Tomas Hrnciar <thrnciar@redhat.com> - 1:3.2.1-2
- Backport commit to fix python-sphinx with python-pygments v2.7.1

View File

@ -1 +1 @@
SHA512 (Sphinx-3.2.1.tar.gz) = 3f0f49036a44938abd470c2f825a0eeeeb818daf3dfbb3bc5c746b64305b5fe66c1c34d9703eb9420b2b347247c122825ddae1b6c28c88c249206151f39e3bdb
SHA512 (Sphinx-3.3.1.tar.gz) = bb1fb0780b741c0162ca014cb996dcdaac06985d14b6cc645a835679d7cf2680912784a815a027caf3fe902f721f9707bc9e9daaaf2c2d43051d31fe00584f78