diff --git a/html-parser-HTMLParserError-removed.patch b/html-parser-HTMLParserError-removed.patch
new file mode 100644
index 0000000..d44ef22
--- /dev/null
+++ b/html-parser-HTMLParserError-removed.patch
@@ -0,0 +1,18 @@
+diff -up Sphinx-1.2.3/sphinx/builders/linkcheck.py.old Sphinx-1.2.3/sphinx/builders/linkcheck.py
+--- Sphinx-1.2.3/sphinx/builders/linkcheck.py.old 2015-10-13 15:15:40.767811124 +0200
++++ Sphinx-1.2.3/sphinx/builders/linkcheck.py 2015-10-13 15:14:41.916145677 +0200
+@@ -17,7 +17,13 @@ import threading
+ from os import path
+ from urllib2 import build_opener, unquote, Request, \
+ HTTPError, HTTPRedirectHandler
+-from HTMLParser import HTMLParser, HTMLParseError
++from HTMLParser import HTMLParser
++
++try:
++ from HTMLParser import HTMLParseError
++except ImportError:
++ class HTMLParseError(Exception):
++ pass
+
+ from docutils import nodes
+
diff --git a/python-sphinx.spec b/python-sphinx.spec
index 01980cb..13894ec 100644
--- a/python-sphinx.spec
+++ b/python-sphinx.spec
@@ -9,7 +9,7 @@
Name: python-sphinx
Version: 1.2.3
-Release: 4%{?dist}
+Release: 5%{?dist}
Summary: Python documentation generator
Group: Development/Tools
@@ -23,6 +23,7 @@ URL: http://sphinx.pocoo.org/
Source0: http://pypi.python.org/packages/source/S/%{upstream_name}/%{upstream_name}-%{version}.tar.gz
Patch0: Sphinx-1.2.1-mantarget.patch
Patch1: Sphinx-1.2.2-verbosetests.patch
+Patch2: html-parser-HTMLParserError-removed.patch
BuildArch: noarch
BuildRequires: python2-devel >= 2.4
@@ -219,6 +220,7 @@ This package contains documentation in reST and HTML formats.
# not backing up since every executable file in tests/ results in
# an additional "skipped" test
%patch1 -p1
+%patch2 -p1
sed '1d' -i sphinx/pycode/pgen2/token.py
# fix line encoding of bundled jquery.js
@@ -356,6 +358,10 @@ popd
%changelog
+* Tue Oct 13 2015 Robert Kuska - 1.2.3-5
+- Rebuilt for Python3.5 rebuild
+- add patch to reflect that Python3.5 dropped HTMLParserError
+
* Mon Jul 20 2015 Michel Alexandre Salim - 1.2.3-4
- Fix line encoding of bundled jquery.js