d01f5faf1f
Before: /usr/lib/python3.12/site-packages/setuptools/_distutils/cmd.py:66: SetuptoolsDeprecationWarning: setup.py install is deprecated. !! ******************************************************************************** Please avoid running ``setup.py`` directly. Instead, use pypa/build, pypa/installer, pypa/build or other standards-based tools. See https://blog.ganssle.io/articles/2021/10/setup-py-deprecated.html for details. ******************************************************************************** !! After: /usr/lib/python3.12/site-packages/setuptools/_distutils/cmd.py:66: SetuptoolsDeprecationWarning: setup.py install is deprecated. !! ******************************************************************************** Please avoid running ``setup.py`` directly. Instead, use pypa/build, pypa/installer, pypa/build or other standards-based tools. Follow the current Python packaging guidelines when building Python RPM packages. See https://blog.ganssle.io/articles/2021/10/setup-py-deprecated.html and https://docs.fedoraproject.org/en-US/packaging-guidelines/Python/ for details. ******************************************************************************** !!
42 lines
1.6 KiB
Diff
42 lines
1.6 KiB
Diff
From 797316bb195387962758faaf85d6c453832ae61d Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
|
|
Date: Fri, 5 May 2023 17:53:11 +0200
|
|
Subject: [PATCH] Adjust the setup.py install deprecation message and URL
|
|
|
|
But only when building RPM packages.
|
|
---
|
|
setuptools/command/install.py | 10 ++++++++--
|
|
1 file changed, 8 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/setuptools/command/install.py b/setuptools/command/install.py
|
|
index dec4e32..704a317 100644
|
|
--- a/setuptools/command/install.py
|
|
+++ b/setuptools/command/install.py
|
|
@@ -1,6 +1,7 @@
|
|
from distutils.errors import DistutilsArgError
|
|
import inspect
|
|
import glob
|
|
+import os
|
|
import platform
|
|
import distutils.command.install as orig
|
|
|
|
@@ -36,8 +37,13 @@ class install(orig.install):
|
|
Please avoid running ``setup.py`` directly.
|
|
Instead, use pypa/build, pypa/installer, pypa/build or
|
|
other standards-based tools.
|
|
- """,
|
|
- see_url="https://blog.ganssle.io/articles/2021/10/setup-py-deprecated.html",
|
|
+ """
|
|
+ + ("""
|
|
+ Follow the current Python packaging guidelines when building
|
|
+ Python RPM packages.
|
|
+ """ if "RPM_BUILD_ROOT" in os.environ else ""),
|
|
+ see_url=("https://blog.ganssle.io/articles/2021/10/setup-py-deprecated.html" +
|
|
+ ("\nand https://docs.fedoraproject.org/en-US/packaging-guidelines/Python/" if "RPM_BUILD_ROOT" in os.environ else "")),
|
|
# TODO: Document how to bootstrap setuptools without install
|
|
# (e.g. by unziping the wheel file)
|
|
# and then add a due_date to this warning.
|
|
--
|
|
2.40.0
|
|
|