import python-setuptools-39.2.0-6.el8
This commit is contained in:
parent
3526e9e10f
commit
e4b1c3a079
17
SOURCES/create-site-packages.patch
Normal file
17
SOURCES/create-site-packages.patch
Normal file
@ -0,0 +1,17 @@
|
||||
diff --git a/setuptools/command/easy_install.py b/setuptools/command/easy_install.py
|
||||
index 91c48b3..0c9b0f4 100755
|
||||
--- a/setuptools/command/easy_install.py
|
||||
+++ b/setuptools/command/easy_install.py
|
||||
@@ -446,6 +446,12 @@ class easy_install(Command):
|
||||
instdir = normalize_path(self.install_dir)
|
||||
pth_file = os.path.join(instdir, 'easy-install.pth')
|
||||
|
||||
+ if not os.path.exists(instdir):
|
||||
+ try:
|
||||
+ os.makedirs(instdir)
|
||||
+ except (OSError, IOError):
|
||||
+ self.cant_write_to_target()
|
||||
+
|
||||
# Is it a configured, PYTHONPATH, implicit, or explicit site dir?
|
||||
is_site_dir = instdir in self.all_site_dirs
|
||||
|
@ -35,7 +35,7 @@
|
||||
|
||||
Name: python-setuptools
|
||||
Version: 39.2.0
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
Summary: Easily build and distribute Python packages
|
||||
|
||||
Group: Applications/System
|
||||
@ -43,6 +43,12 @@ License: MIT
|
||||
URL: https://pypi.python.org/pypi/%{srcname}
|
||||
Source0: https://files.pythonhosted.org/packages/source/s/%{srcname}/%{srcname}-%{version}.zip
|
||||
|
||||
# In Fedora, sudo setup.py install installs to /usr/local/lib/pythonX.Y/site-packages
|
||||
# But pythonX doesn't own that dir, that would be against FHS
|
||||
# We need to create it if it doesn't exist
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1576924
|
||||
Patch0: create-site-packages.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
BuildRequires: gcc
|
||||
@ -136,7 +142,7 @@ A Python wheel of setuptools to use with venv.
|
||||
%endif #with bootstrap
|
||||
|
||||
%prep
|
||||
%setup -q -n %{srcname}-%{version}
|
||||
%autosetup -p1 -n %{srcname}-%{version}
|
||||
|
||||
# We can't remove .egg-info (but it doesn't matter, since it'll be rebuilt):
|
||||
# The problem is that to properly execute setuptools' setup.py,
|
||||
@ -298,7 +304,11 @@ PYTHONDONTWRITEBYTECODE=1 PYTHONPATH=$(pwd) py.test-%{python3_version} --ignore=
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Apr 17 2019 Petr Viktorin <pviktori@redhat.com> - 39.0.1-10
|
||||
* Wed Mar 25 2020 Charalampos Stratakis <cstratak@redhat.com> - 39.2.0-6
|
||||
- Create /usr/local/lib/pythonX.Y when needed
|
||||
Resolves: rhbz#1808301
|
||||
|
||||
* Wed Apr 17 2019 Petr Viktorin <pviktori@redhat.com> - 39.2.0-5
|
||||
- Add subpackages with wheels
|
||||
Resolves: rhbz#1718032
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user