diff --git a/.cvsignore b/.cvsignore
index 7fa0695..a505f45 100644
--- a/.cvsignore
+++ b/.cvsignore
@@ -1 +1 @@
-distribute-0.6.10.tar.gz
+distribute-0.6.13.tar.gz
diff --git a/distribute-0.6.13-tests.patch b/distribute-0.6.13-tests.patch
new file mode 100644
index 0000000..3da1be7
--- /dev/null
+++ b/distribute-0.6.13-tests.patch
@@ -0,0 +1,25 @@
+diff -uNr distribute-0.6.13.pristine/MANIFEST.in distribute-0.6.13/MANIFEST.in
+--- distribute-0.6.13.pristine/MANIFEST.in 2009-12-28 13:44:40.000000000 -0500
++++ distribute-0.6.13/MANIFEST.in 2010-06-10 19:43:39.508527227 -0400
+@@ -1,5 +1,6 @@
+ recursive-include setuptools *.py *.txt *.exe
+ recursive-include tests *.py *.c *.pyx *.txt
++recursive-include setuptools/tests *.html
+ recursive-include docs *.py *.txt *.conf *.css *.css_t Makefile indexsidebar.html
+ include *.py
+ include *.txt
+diff -uNr distribute-0.6.13.pristine/setuptools/tests/indexes/test_links_priority/external.html distribute-0.6.13/setuptools/tests/indexes/test_links_priority/external.html
+--- distribute-0.6.13.pristine/setuptools/tests/indexes/test_links_priority/external.html 1969-12-31 19:00:00.000000000 -0500
++++ distribute-0.6.13/setuptools/tests/indexes/test_links_priority/external.html 2010-06-10 19:40:53.190527048 -0400
+@@ -0,0 +1,3 @@
++
++bad old link
++
+diff -uNr distribute-0.6.13.pristine/setuptools/tests/indexes/test_links_priority/simple/foobar/index.html distribute-0.6.13/setuptools/tests/indexes/test_links_priority/simple/foobar/index.html
+--- distribute-0.6.13.pristine/setuptools/tests/indexes/test_links_priority/simple/foobar/index.html 1969-12-31 19:00:00.000000000 -0500
++++ distribute-0.6.13/setuptools/tests/indexes/test_links_priority/simple/foobar/index.html 2010-06-10 19:40:53.187526243 -0400
+@@ -0,0 +1,4 @@
++
++foobar-0.1.tar.gz
++external homepage
++
diff --git a/python-setuptools.spec b/python-setuptools.spec
index 7555599..3c34ac2 100644
--- a/python-setuptools.spec
+++ b/python-setuptools.spec
@@ -7,8 +7,8 @@
%global srcname distribute
Name: python-setuptools
-Version: 0.6.10
-Release: 3%{?dist}
+Version: 0.6.13
+Release: 2%{?dist}
Summary: Easily build and distribute Python packages
Group: Applications/System
@@ -17,10 +17,11 @@ URL: http://pypi.python.org/pypi/%{srcname}
Source0: http://pypi.python.org/packages/source/d/%{srcname}/%{srcname}-%{version}.tar.gz
Source1: psfl.txt
Source2: zpl.txt
+Patch0: distribute-0.6.13-tests.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
-BuildRequires: python-devel
+BuildRequires: python2-devel
%if 0%{?with_python3}
BuildRequires: python3-devel
%endif # if with_python3
@@ -54,6 +55,8 @@ execute the software that requires pkg_resources.py.
%prep
%setup -q -n %{srcname}-%{version}
+%patch0 -p1
+
find -name '*.txt' | xargs chmod -x
%if 0%{?with_python3}
@@ -81,7 +84,7 @@ rm -rf %{buildroot}
# to be the default for now).
%if 0%{?with_python3}
pushd %{py3dir}
-%{__python3} setup.py install --skip-build --root $RPM_BUILD_ROOT
+%{__python3} setup.py install --skip-build --root %{buildroot}
rm -rf %{buildroot}%{python3_sitelib}/setuptools/tests
@@ -91,7 +94,7 @@ chmod +x %{buildroot}%{python3_sitelib}/setuptools/command/easy_install.py
popd
%endif # with_python3
-%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
+%{__python} setup.py install --skip-build --root %{buildroot}
rm -rf ${buildroot}%{python_sitelib}/setuptools/tests
@@ -128,6 +131,13 @@ rm -rf $RPM_BUILD_ROOT
%endif # with_python3
%changelog
+* Thu Jun 10 2010 Toshio Kuratomi - 0.6.13-2
+- Include data that's needed for running tests
+
+* Thu Jun 10 2010 Toshio Kuratomi - 0.6.13-1
+- Update to upstream 0.6.13
+- Minor specfile formatting fixes
+
* Thu Feb 04 2010 Toshio Kuratomi - 0.6.10-3
- First build with python3 support enabled.
diff --git a/sources b/sources
index ad05ccb..534461e 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-99fb4b3e4ef0861bba11aa1905e89fed distribute-0.6.10.tar.gz
+43460b429e86bf0da2bb18574d63ec0c distribute-0.6.13.tar.gz
diff --git a/svn_versioning_4.patch b/svn_versioning_4.patch
deleted file mode 100644
index 175f9ae..0000000
--- a/svn_versioning_4.patch
+++ /dev/null
@@ -1,217 +0,0 @@
-Index: setuptools/svn_util.py
-===================================================================
---- setuptools/svn_util.py (revision 0)
-+++ setuptools/svn_util.py (revision 0)
-@@ -0,0 +1,109 @@
-+import os
-+import re
-+
-+def get_entries_files(base, recurse=True):
-+ for base,dirs,files in os.walk(os.curdir):
-+ if '.svn' not in dirs:
-+ dirs[:] = []
-+ continue # no sense walking uncontrolled subdirs
-+ dirs.remove('.svn')
-+ f = open(os.path.join(base,'.svn','entries'))
-+ yield f.read()
-+ f.close()
-+
-+class SVNEntries(object):
-+ def __init__(self, data):
-+ self.data = data
-+
-+ @classmethod
-+ def load(class_, base):
-+ filename = os.path.join(base, '.svn', 'entries')
-+ f = open(filename)
-+ result = SVNEntries.read(f)
-+ f.close()
-+ return result
-+
-+ @classmethod
-+ def read(class_, file):
-+ data = file.read()
-+ is_xml = data.startswith('revision_line_number
-+ and section[revision_line_number]
-+ ]
-+ return rev_numbers
-+
-+ def get_undeleted_records(self):
-+ undeleted = lambda s: s and s[0] and (len(s) < 6 or s[5] != 'delete')
-+ result = [
-+ section[0]
-+ for section in self.get_sections()
-+ if undeleted(section)
-+ ]
-+ return result
-+
-+class SVNEntriesXML(SVNEntries):
-+ def is_valid(self):
-+ return True
-+
-+ def get_url(self):
-+ "Get repository URL"
-+ urlre = re.compile('url="([^"]+)"')
-+ return urlre.search(self.data).group(1)
-+
-+ def parse_revision_numbers(self):
-+ revre = re.compile('committed-rev="(\d+)"')
-+ return [
-+ int(m.group(1))
-+ for m in revre.finditer(self.data)
-+ ]
-+
-+ def get_undeleted_records(self):
-+ entries_pattern = re.compile(r'name="([^"]+)"(?![^>]+deleted="true")', re.I)
-+ results = [
-+ unescape(match.group(1))
-+ for match in entries_pattern.finditer(self.data)
-+ ]
-+ return results
-
-Property changes on: setuptools/svn_util.py
-___________________________________________________________________
-Name: svn:keywords
- + Id Rev Author Date
-Name: svn:eol-style
- + native
-
-Index: setuptools/command/egg_info.py
-===================================================================
---- setuptools/command/egg_info.py (revision 72970)
-+++ setuptools/command/egg_info.py (working copy)
-@@ -8,6 +8,7 @@
- from distutils.errors import *
- from distutils import log
- from setuptools.command.sdist import sdist
-+from setuptools import svn_util
- from distutils.util import convert_path
- from distutils.filelist import FileList
- from pkg_resources import parse_requirements, safe_name, parse_version, \
-@@ -205,30 +206,20 @@
-
- def get_svn_revision(self):
- revision = 0
-- urlre = re.compile('url="([^"]+)"')
-- revre = re.compile('committed-rev="(\d+)"')
-
- for base,dirs,files in os.walk(os.curdir):
- if '.svn' not in dirs:
- dirs[:] = []
- continue # no sense walking uncontrolled subdirs
- dirs.remove('.svn')
-- f = open(os.path.join(base,'.svn','entries'))
-- data = f.read()
-- f.close()
--
-- if data.startswith('9') or data.startswith('8'):
-- data = map(str.splitlines,data.split('\n\x0c\n'))
-- del data[0][0] # get rid of the '8' or '9'
-- dirurl = data[0][3]
-- localrev = max([int(d[9]) for d in data if len(d)>9 and d[9]]+[0])
-- elif data.startswith('"), (""", '"'), ("'", "'"),
-@@ -80,24 +81,11 @@
- yield joinpath(dirname, parts[0])
-
-
--entries_pattern = re.compile(r'name="([^"]+)"(?![^>]+deleted="true")', re.I)
-
- def entries_finder(dirname, filename):
-- f = open(filename,'rU')
-- data = f.read()
-- f.close()
-- if data.startswith('9') or data.startswith('8'): # subversion 1.5/1.4
-- for record in map(str.splitlines, data.split('\n\x0c\n')[1:]):
-- if not record or len(record)>=6 and record[5]=="delete":
-- continue # skip deleted
-- yield joinpath(dirname, record[0])
-- elif data.startswith('