diff --git a/distribute-0.6.13-tests.patch b/distribute-0.6.13-tests.patch
deleted file mode 100644
index 3da1be7..0000000
--- a/distribute-0.6.13-tests.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -uNr distribute-0.6.13.pristine/MANIFEST.in distribute-0.6.13/MANIFEST.in
---- distribute-0.6.13.pristine/MANIFEST.in 2009-12-28 13:44:40.000000000 -0500
-+++ distribute-0.6.13/MANIFEST.in 2010-06-10 19:43:39.508527227 -0400
-@@ -1,5 +1,6 @@
- recursive-include setuptools *.py *.txt *.exe
- recursive-include tests *.py *.c *.pyx *.txt
-+recursive-include setuptools/tests *.html
- recursive-include docs *.py *.txt *.conf *.css *.css_t Makefile indexsidebar.html
- include *.py
- include *.txt
-diff -uNr distribute-0.6.13.pristine/setuptools/tests/indexes/test_links_priority/external.html distribute-0.6.13/setuptools/tests/indexes/test_links_priority/external.html
---- distribute-0.6.13.pristine/setuptools/tests/indexes/test_links_priority/external.html 1969-12-31 19:00:00.000000000 -0500
-+++ distribute-0.6.13/setuptools/tests/indexes/test_links_priority/external.html 2010-06-10 19:40:53.190527048 -0400
-@@ -0,0 +1,3 @@
-+
-+bad old link
-+
-diff -uNr distribute-0.6.13.pristine/setuptools/tests/indexes/test_links_priority/simple/foobar/index.html distribute-0.6.13/setuptools/tests/indexes/test_links_priority/simple/foobar/index.html
---- distribute-0.6.13.pristine/setuptools/tests/indexes/test_links_priority/simple/foobar/index.html 1969-12-31 19:00:00.000000000 -0500
-+++ distribute-0.6.13/setuptools/tests/indexes/test_links_priority/simple/foobar/index.html 2010-06-10 19:40:53.187526243 -0400
-@@ -0,0 +1,4 @@
-+
-+foobar-0.1.tar.gz
-+external homepage
-+
diff --git a/distribute-b045d0750c13.diff b/distribute-b045d0750c13.diff
deleted file mode 100644
index c7147d4..0000000
--- a/distribute-b045d0750c13.diff
+++ /dev/null
@@ -1,66 +0,0 @@
-# HG changeset patch -- Bitbucket.org
-# Project distribute
-# URL http://bitbucket.org/tarek/distribute/overview
-# User David Cournapeau
-# Date 1274351504 -32400
-# Node ID b045d0750c13d83ef577593b8bb267a10e803aca
-# Parent ab666b0eacbb5523ffb42a412451550f55347fcc
-BUG: Fix #142 - easy_install ignore locally installed packages.
-
-Backport from setuptools 0.6c10.
-
---- a/setuptools/command/easy_install.py
-+++ b/setuptools/command/easy_install.py
-@@ -565,7 +565,8 @@ Please make the appropriate changes for
-
- self.check_editable(spec)
- dist = self.package_index.fetch_distribution(
-- spec, tmpdir, self.upgrade, self.editable, not self.always_copy
-+ spec, tmpdir, self.upgrade, self.editable, not self.always_copy,
-+ self.local_index
- )
-
- if dist is None:
-
---- a/setuptools/package_index.py
-+++ b/setuptools/package_index.py
-@@ -418,7 +418,8 @@ class PackageIndex(Environment):
-
-
- def fetch_distribution(self,
-- requirement, tmpdir, force_scan=False, source=False, develop_ok=False
-+ requirement, tmpdir, force_scan=False, source=False, develop_ok=False,
-+ local_index=None
- ):
- """Obtain a distribution suitable for fulfilling `requirement`
-
-@@ -440,11 +441,14 @@ class PackageIndex(Environment):
- # process a Requirement
- self.info("Searching for %s", requirement)
- skipped = {}
-+ dist = None
-
-- def find(req):
-+ def find(req, env=None):
-+ if env is None:
-+ env = self
- # Find a matching distribution; may be called more than once
-
-- for dist in self[req.key]:
-+ for dist in env[req.key]:
-
- if dist.precedence==DEVELOP_DIST and not develop_ok:
- if dist not in skipped:
-@@ -461,8 +465,11 @@ class PackageIndex(Environment):
- if force_scan:
- self.prescan()
- self.find_packages(requirement)
-+ dist = find(requirement)
-
-- dist = find(requirement)
-+ if local_index is not None:
-+ dist = dist or find(requirement, local_index)
-+
- if dist is None and self.to_scan is not None:
- self.prescan()
- dist = find(requirement)
diff --git a/distribute-tests-race.patch b/distribute-tests-race.patch
deleted file mode 100644
index d2dd2aa..0000000
--- a/distribute-tests-race.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-# HG changeset patch
-# User Toshio Kuratomi
-# Date 1276227950 14400
-# Branch 0.6-maintenance
-# Node ID ce279b5609b90c55c365043db02bfaa3b305d1ce
-# Parent 99b0b605bfbd00f0752da34cfa15bb2eddfbf302
-Fix race condition with the http server used in unittests
-
-diff -r 99b0b605bfbd -r ce279b5609b9 setuptools/tests/server.py
---- a/setuptools/tests/server.py Thu Jun 10 19:47:48 2010 -0400
-+++ b/setuptools/tests/server.py Thu Jun 10 23:45:50 2010 -0400
-@@ -32,7 +32,10 @@
- def stop(self):
- """self.shutdown is not supported on python < 2.6"""
- self._run = False
-- urllib2.urlopen('http://127.0.0.1:%s/' % self.server_port)
-+ try:
-+ urllib2.urlopen('http://127.0.0.1:%s/' % self.server_port, None, 5)
-+ except urllib2.URLError:
-+ pass
- self.thread.join()
-
- def base_url(self):
diff --git a/python-setuptools.spec b/python-setuptools.spec
index 2a8136e..9d65af8 100644
--- a/python-setuptools.spec
+++ b/python-setuptools.spec
@@ -7,8 +7,8 @@
%global srcname distribute
Name: python-setuptools
-Version: 0.6.13
-Release: 7%{?dist}
+Version: 0.6.14
+Release: 1%{?dist}
Summary: Easily build and distribute Python packages
Group: Applications/System
@@ -17,9 +17,6 @@ URL: http://pypi.python.org/pypi/%{srcname}
Source0: http://pypi.python.org/packages/source/d/%{srcname}/%{srcname}-%{version}.tar.gz
Source1: psfl.txt
Source2: zpl.txt
-Patch0: distribute-0.6.13-tests.patch
-Patch1: distribute-tests-race.patch
-Patch2: http://bitbucket.org/tarek/distribute/changeset/b045d0750c13/raw/distribute-b045d0750c13.diff
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -60,9 +57,6 @@ execute the software that requires pkg_resources.py.
%prep
%setup -q -n %{srcname}-%{version}
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
find -name '*.txt' | xargs chmod -x
find . -name '*.orig' -exec rm \{\} \;
@@ -139,6 +133,10 @@ rm -rf %{buildroot}
%endif # with_python3
%changelog
+* Thu Jul 22 2010 Thomas Spura - 0.6.14-1
+- update to new version
+- all patches are upsteam
+
* Wed Jul 21 2010 David Malcolm - 0.6.13-7
- generalize path of easy_install-2.6 and -3.1 to -2.* and -3.*