Update to 69.0.3

This commit is contained in:
Karolina Surma 2024-02-06 12:29:19 +01:00
parent 13ffb76d61
commit 8223f24e00
3 changed files with 2 additions and 35 deletions

View File

@ -1,30 +0,0 @@
From 29f052da470ac281f15d87d4a40511b5cd1e4834 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
Date: Thu, 26 Oct 2023 14:55:12 +0200
Subject: [PATCH] Fix setuptools.depends:get_module_constant() on Python
3.13.0a1
Don't hardcode opcode numbers, look them up instead.
Fixes https://github.com/pypa/setuptools/issues/4090
---
setuptools/depends.py | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/setuptools/depends.py b/setuptools/depends.py
index 180e820459..42907d9bd4 100644
--- a/setuptools/depends.py
+++ b/setuptools/depends.py
@@ -142,9 +142,9 @@ def extract_constant(code, symbol, default=-1):
name_idx = list(code.co_names).index(symbol)
- STORE_NAME = 90
- STORE_GLOBAL = 97
- LOAD_CONST = 100
+ STORE_NAME = dis.opmap['STORE_NAME']
+ STORE_GLOBAL = dis.opmap['STORE_GLOBAL']
+ LOAD_CONST = dis.opmap['LOAD_CONST']
const = default

View File

@ -18,7 +18,7 @@
Name: python-setuptools Name: python-setuptools
# When updating, update the bundled libraries versions bellow! # When updating, update the bundled libraries versions bellow!
Version: 68.2.2 Version: 69.0.3
Release: %autorelease Release: %autorelease
Summary: Easily build and distribute Python packages Summary: Easily build and distribute Python packages
# setuptools is MIT # setuptools is MIT
@ -52,9 +52,6 @@ Patch: Adjust-the-setup.py-install-deprecation-message.patch
# away from pkg_resources. # away from pkg_resources.
Patch: Remove-warning-from-pkg_resources.patch Patch: Remove-warning-from-pkg_resources.patch
# Fix setuptools.depends:get_module_constant() on Python 3.13.0a1
Patch: https://github.com/pypa/setuptools/pull/4094.patch
BuildArch: noarch BuildArch: noarch
BuildRequires: python%{python3_pkgversion}-devel BuildRequires: python%{python3_pkgversion}-devel

View File

@ -1 +1 @@
SHA512 (setuptools-68.2.2.tar.gz) = ed3138a39e8ae47d695e71835024d66d63b8de51aa336bd8524de81a5036aa26cf587caca5d6b46c833f77a6e9c8c1ae6b64e8310f712bd9c4e760196778b2ca SHA512 (setuptools-69.0.3.tar.gz) = 11df934931f4b73f7e07ea5713479593c6baa134d423556b2ae7aff0f1e5bdbdee1f5b516131adb169c838231ceb0293441fbf275ef7030dabecf74122565b6d