Update to 18.7.1. Fixes bug #1287372
This commit is contained in:
parent
d428811407
commit
77b3af5d8d
1
.gitignore
vendored
1
.gitignore
vendored
@ -31,3 +31,4 @@
|
||||
/setuptools-18.4.tar.gz
|
||||
/setuptools-18.5.tar.gz
|
||||
/setuptools-18.6.1.tar.gz
|
||||
/setuptools-18.7.1.tar.gz
|
||||
|
@ -1,30 +0,0 @@
|
||||
# HG changeset patch
|
||||
# User Robert Kuska <rkuska@redhat.com>
|
||||
# Date 1446653216 -3600
|
||||
# Node ID f73f1baac78107dd49a5d18b6e43a40baf509d3e
|
||||
# Parent 4ce518784af886e6977fa2dbe58359d0fe161d0d
|
||||
AttributeError: cant set attribute
|
||||
|
||||
with the recent transformation of self.test_args into
|
||||
property self.test_args doesnt accept assignation
|
||||
when test class is subclassed. This PR adds setter
|
||||
for the new property.
|
||||
|
||||
diff --git a/setuptools/command/test.py b/setuptools/command/test.py
|
||||
--- a/setuptools/command/test.py
|
||||
+++ b/setuptools/command/test.py
|
||||
@@ -80,8 +80,14 @@
|
||||
|
||||
@property
|
||||
def test_args(self):
|
||||
+ if hasattr(self, '_test_args_var'):
|
||||
+ return self._test_args_var
|
||||
return list(self._test_args())
|
||||
|
||||
+ @test_args.setter
|
||||
+ def test_args(self, value):
|
||||
+ self._test_args_var = value
|
||||
+
|
||||
def _test_args(self):
|
||||
if self.verbose:
|
||||
yield '--verbose'
|
@ -26,7 +26,7 @@
|
||||
%endif
|
||||
|
||||
Name: python-setuptools
|
||||
Version: 18.6.1
|
||||
Version: 18.7.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Easily build and distribute Python packages
|
||||
|
||||
@ -36,8 +36,6 @@ URL: https://pypi.python.org/pypi/%{srcname}
|
||||
Source0: https://pypi.python.org/packages/source/s/%{srcname}/%{srcname}-%{version}.tar.gz
|
||||
Source1: psfl.txt
|
||||
Source2: zpl.txt
|
||||
# add-setter-for-test_args.patch
|
||||
Patch1: add-setter-for-test_args.patch
|
||||
# WIP patch for #1271776
|
||||
Patch2: setuptools-18.5-disable-zip-safe.patch
|
||||
|
||||
@ -111,7 +109,6 @@ execute the software that requires pkg_resources.py.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{srcname}-%{version}
|
||||
%patch1 -p1
|
||||
|
||||
# We can't remove .egg-info (but it doesn't matter, since it'll be rebuilt):
|
||||
# The problem is that to properly execute setuptools' setup.py,
|
||||
@ -221,6 +218,9 @@ popd
|
||||
%endif # with_python3
|
||||
|
||||
%changelog
|
||||
* Fri Dec 04 2015 Kevin Fenzi <kevin@scrye.com> - 18.7.1-1
|
||||
- Update to 18.7.1. Fixes bug #1287372
|
||||
|
||||
* Wed Nov 25 2015 Kevin Fenzi <kevin@scrye.com> - 18.6.1-1
|
||||
- Update to 18.6.1. Fixes bug #1270578
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user