Upgrade to 46.1.3
Resolves https://bugzilla.redhat.com/show_bug.cgi?id=1815796 Resolves https://bugzilla.redhat.com/show_bug.cgi?id=1817189 The create-site-packages.patch was merged upstream.
This commit is contained in:
parent
437aba975c
commit
1bbe4f8488
@ -1,17 +0,0 @@
|
|||||||
diff --git a/setuptools/command/easy_install.py b/setuptools/command/easy_install.py
|
|
||||||
index 91c48b3..0c9b0f4 100755
|
|
||||||
--- a/setuptools/command/easy_install.py
|
|
||||||
+++ b/setuptools/command/easy_install.py
|
|
||||||
@@ -446,6 +446,12 @@ class easy_install(Command):
|
|
||||||
instdir = normalize_path(self.install_dir)
|
|
||||||
pth_file = os.path.join(instdir, 'easy-install.pth')
|
|
||||||
|
|
||||||
+ if not os.path.exists(instdir):
|
|
||||||
+ try:
|
|
||||||
+ os.makedirs(instdir)
|
|
||||||
+ except (OSError, IOError):
|
|
||||||
+ self.cant_write_to_target()
|
|
||||||
+
|
|
||||||
# Is it a configured, PYTHONPATH, implicit, or explicit site dir?
|
|
||||||
is_site_dir = instdir in self.all_site_dirs
|
|
||||||
|
|
@ -13,7 +13,7 @@
|
|||||||
|
|
||||||
Name: python-setuptools
|
Name: python-setuptools
|
||||||
# When updating, update the bundled libraries versions bellow!
|
# When updating, update the bundled libraries versions bellow!
|
||||||
Version: 46.0.0
|
Version: 46.1.3
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Easily build and distribute Python packages
|
Summary: Easily build and distribute Python packages
|
||||||
# setuptools is MIT
|
# setuptools is MIT
|
||||||
@ -25,12 +25,6 @@ License: MIT and (BSD or ASL 2.0)
|
|||||||
URL: https://pypi.python.org/pypi/%{srcname}
|
URL: https://pypi.python.org/pypi/%{srcname}
|
||||||
Source0: %{pypi_source %{srcname} %{version} zip}
|
Source0: %{pypi_source %{srcname} %{version} zip}
|
||||||
|
|
||||||
# In Fedora, sudo setup.py install installs to /usr/local/lib/pythonX.Y/site-packages
|
|
||||||
# But pythonX doesn't own that dir, that would be against FHS
|
|
||||||
# We need to create it if it doesn't exist
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1576924
|
|
||||||
Patch0: create-site-packages.patch
|
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -178,8 +172,13 @@ PYTHONDONTWRITEBYTECODE=1 PYTHONPATH=$(pwd) pytest-%{python3_version} \
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 26 2020 Miro Hrončok <mhroncok@redhat.com> - 46.1.3-1
|
||||||
|
- Upgrade to 46.1.3 (#1817189)
|
||||||
|
- https://setuptools.readthedocs.io/en/latest/history.html#v46-1-3
|
||||||
|
|
||||||
* Tue Mar 10 2020 Miro Hrončok <mhroncok@redhat.com> - 46.0.0-1
|
* Tue Mar 10 2020 Miro Hrončok <mhroncok@redhat.com> - 46.0.0-1
|
||||||
- Upgrade to 46.0.0 (#1811340)
|
- Upgrade to 46.0.0 (#1811340)
|
||||||
|
- https://setuptools.readthedocs.io/en/latest/history.html#v46-0-0
|
||||||
|
|
||||||
* Tue Feb 11 2020 Miro Hrončok <mhroncok@redhat.com> - 45.2.0-1
|
* Tue Feb 11 2020 Miro Hrončok <mhroncok@redhat.com> - 45.2.0-1
|
||||||
- Upgrade to 45.2.0 (#1775943)
|
- Upgrade to 45.2.0 (#1775943)
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (setuptools-46.0.0.zip) = 3d398a69d4b3cceac33c3ecb36c7bfdc5e11160b5179e2097e75527cb2e50e2baed649ccfde3967330806d62726092de29cc572d0bb213691aa43a665ca6efa5
|
SHA512 (setuptools-46.1.3.zip) = 7f8f99313ce2af2cbfa86ff9a3135bc3445804e9323a375b498d20dad7f8fc819481da0c2a057160397e98b6178c1eb453a093652cfdfe7896c9d31732f7ad8c
|
||||||
|
Loading…
Reference in New Issue
Block a user