diff --git a/tests/tests.yml b/tests/tests.yml
new file mode 100644
index 0000000..c846c48
--- /dev/null
+++ b/tests/tests.yml
@@ -0,0 +1,17 @@
+---
+- hosts: localhost
+  roles:
+  - role: standard-test-basic
+    tags:
+    - classic
+    repositories:
+    - repo: "https://src.fedoraproject.org/rpms/pyproject-rpm-macros.git"
+      dest: "pyproject-rpm-macros"
+    tests:
+    - mockbuild_cryptography:
+        dir: pyproject-rpm-macros/tests
+        # note: this always builds from the rawhide branch, no idea how to reference the target branch of the test
+        run: fedpkg clone -a python-cryptography && cd python-cryptography && fedpkg sources && ../mocktest.sh python-cryptography
+    required_packages:
+    - fedpkg
+    - mock