import python-ruamel-yaml-0.16.6-7.el9
This commit is contained in:
commit
df2921525f
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/ruamel-yaml-0.16.6.tar.gz
|
1
.python-ruamel-yaml.metadata
Normal file
1
.python-ruamel-yaml.metadata
Normal file
@ -0,0 +1 @@
|
||||
c30a00468467ce71752aab302ab826a3aca10c42 SOURCES/ruamel-yaml-0.16.6.tar.gz
|
63
SOURCES/python-ruamel-yaml-pathlib.patch
Normal file
63
SOURCES/python-ruamel-yaml-pathlib.patch
Normal file
@ -0,0 +1,63 @@
|
||||
diff --git a/_doc/conf.py b/_doc/conf.py
|
||||
--- a/_doc/conf.py
|
||||
+++ b/_doc/conf.py
|
||||
@@ -75,7 +75,10 @@
|
||||
if False:
|
||||
try:
|
||||
from ryd.__main__ import RYDCmd
|
||||
- from ruamel.std.pathlib import Path
|
||||
+ try:
|
||||
+ from pathlib import Path
|
||||
+ except ImportError:
|
||||
+ from pathlib2 import Path
|
||||
|
||||
oldargv = sys.argv
|
||||
for fn in Path('.').glob('*.ryd'):
|
||||
diff --git a/_test/roundtrip.py b/_test/roundtrip.py
|
||||
--- a/_test/roundtrip.py
|
||||
+++ b/_test/roundtrip.py
|
||||
@@ -7,7 +7,11 @@
|
||||
"""
|
||||
import sys
|
||||
import textwrap
|
||||
-from ruamel.std.pathlib import Path
|
||||
+try:
|
||||
+ from pathlib import Path
|
||||
+except ImportError:
|
||||
+ from pathlib2 import Path
|
||||
+
|
||||
|
||||
enforce = object()
|
||||
|
||||
diff --git a/_test/test_api_change.py b/_test/test_api_change.py
|
||||
--- a/_test/test_api_change.py
|
||||
+++ b/_test/test_api_change.py
|
||||
@@ -9,7 +9,10 @@
|
||||
import sys
|
||||
import textwrap
|
||||
import pytest
|
||||
-from ruamel.std.pathlib import Path
|
||||
+try:
|
||||
+ from pathlib import Path
|
||||
+except ImportError:
|
||||
+ from pathlib2 import Path
|
||||
|
||||
|
||||
class TestNewAPI:
|
||||
diff --git a/_test/test_z_data.py b/_test/test_z_data.py
|
||||
--- a/_test/test_z_data.py
|
||||
+++ b/_test/test_z_data.py
|
||||
@@ -6,7 +6,11 @@
|
||||
import pytest # NOQA
|
||||
import warnings # NOQA
|
||||
|
||||
-from ruamel.std.pathlib import Path
|
||||
+try:
|
||||
+ from pathlib import Path
|
||||
+except ImportError:
|
||||
+ from pathlib2 import Path
|
||||
+
|
||||
|
||||
base_path = Path('data') # that is ruamel.yaml.data
|
||||
PY2 = sys.version_info[0] == 2
|
||||
|
18
SOURCES/python-ruamel-yaml-pytest27.patch
Normal file
18
SOURCES/python-ruamel-yaml-pytest27.patch
Normal file
@ -0,0 +1,18 @@
|
||||
diff -u ruamel-yaml-ff02b83b8f91/_test/test_anchor.py.pytest27 ruamel-yaml-ff02b83b8f91/_test/test_anchor.py
|
||||
--- ruamel-yaml-ff02b83b8f91/_test/test_anchor.py.pytest27 2019-08-27 10:59:01.756747586 +0100
|
||||
+++ ruamel-yaml-ff02b83b8f91/_test/test_anchor.py 2019-08-27 11:00:15.929713043 +0100
|
||||
@@ -7,6 +7,7 @@
|
||||
"""
|
||||
|
||||
import pytest
|
||||
+from distutils.version import LooseVersion
|
||||
from textwrap import dedent
|
||||
import platform
|
||||
|
||||
@@ -248,6 +249,7 @@
|
||||
)
|
||||
|
||||
# this is an error in PyYAML
|
||||
+ @pytest.mark.skipif(LooseVersion(pytest.__version__) < LooseVersion("2.8"), reason="Need pytest 2.7")
|
||||
def test_reused_anchor(self):
|
||||
from ruamel.yaml.error import ReusedAnchorWarning
|
170
SPECS/python-ruamel-yaml.spec
Normal file
170
SPECS/python-ruamel-yaml.spec
Normal file
@ -0,0 +1,170 @@
|
||||
%global pypi_name ruamel.yaml
|
||||
%global pname ruamel-yaml
|
||||
%global commit 44504659794e
|
||||
%global debug_package %{nil}
|
||||
|
||||
Name: python-%{pname}
|
||||
Version: 0.16.6
|
||||
Release: 7%{?dist}
|
||||
Summary: YAML 1.2 loader/dumper package for Python
|
||||
|
||||
License: MIT
|
||||
URL: https://bitbucket.org/ruamel/yaml
|
||||
# Use bitbucket sources so we can run the tests
|
||||
Source0: https://bitbucket.org/ruamel/yaml/get/%{version}.tar.gz#/%{pname}-%{version}.tar.gz
|
||||
# Works with pytest 2.7
|
||||
Patch0: python-ruamel-yaml-pytest27.patch
|
||||
|
||||
# Don't require ruamel.std.pathlib, but use stdlib's pathlib on py3, pathlib2 on py2
|
||||
Patch1: python-ruamel-yaml-pathlib.patch
|
||||
|
||||
|
||||
%description
|
||||
ruamel.yaml is a YAML 1.2 loader/dumper package for Python.
|
||||
It is a derivative of Kirill Simonov’s PyYAML 3.11
|
||||
|
||||
%package -n python%{python3_pkgversion}-%{pname}
|
||||
Summary: YAML 1.2 loader/dumper package for Python
|
||||
BuildRequires: python%{python3_pkgversion}-devel
|
||||
BuildRequires: python%{python3_pkgversion}-setuptools
|
||||
# For tests
|
||||
BuildRequires: python%{python3_pkgversion}-pytest
|
||||
# typing was added in Python 3.5
|
||||
%if %{python3_pkgversion} == 34
|
||||
BuildRequires: python%{python3_pkgversion}-typing
|
||||
%endif
|
||||
%{?python_provide:%python_provide python%{python3_pkgversion}-%{pypi_name}}
|
||||
|
||||
Requires: python%{python3_pkgversion}-ruamel-yaml-clib
|
||||
Requires: python%{python3_pkgversion}-setuptools
|
||||
%if %{python3_pkgversion} == 34
|
||||
Requires: python%{python3_pkgversion}-typing
|
||||
%endif
|
||||
|
||||
%description -n python%{python3_pkgversion}-%{pname}
|
||||
ruamel.yaml is a YAML 1.2 loader/dumper package for Python.
|
||||
It is a derivative of Kirill Simonov’s PyYAML 3.11
|
||||
|
||||
%prep
|
||||
%autosetup -n %{pname}-%{commit} -p1
|
||||
rm -rf %{pypi_name}.egg-info
|
||||
|
||||
%build
|
||||
%py3_build
|
||||
|
||||
%install
|
||||
%{__python3} setup.py install --single-version-externally-managed --skip-build --root $RPM_BUILD_ROOT
|
||||
|
||||
%check
|
||||
PYTHONPATH=$(echo build/lib) py.test-%{python3_version} _test/test_*.py
|
||||
|
||||
%files -n python%{python3_pkgversion}-%{pname}
|
||||
%license LICENSE
|
||||
%doc README.rst
|
||||
%{python3_sitelib}/ruamel
|
||||
%{python3_sitelib}/%{pypi_name}-%{version}-py%{python3_version}-*.pth
|
||||
%{python3_sitelib}/%{pypi_name}-%{version}-py%{python3_version}.egg-info
|
||||
|
||||
%changelog
|
||||
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 0.16.6-7
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 0.16.6-6
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.16.6-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.16.6-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 0.16.6-3
|
||||
- Rebuilt for Python 3.9
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.16.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Mon Jan 20 2020 Jason Montleon <jmontleo@redhat.com> - 0.16.6-1
|
||||
- Update to 0.16.6
|
||||
|
||||
* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 0.16.5-3
|
||||
- Rebuilt for Python 3.8.0rc1 (#1748018)
|
||||
|
||||
* Fri Aug 30 2019 Chandan Kumar <raukadah@gmail.com> - 0.16.5-2
|
||||
- Added ruamel-yaml-clib as Requires
|
||||
|
||||
* Tue Aug 27 2019 Chedi Toueiti <chedi.toueiti@gmail.com> - 0.16.5-1
|
||||
- Update to 0.16.5
|
||||
|
||||
* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 0.15.41-6
|
||||
- Rebuilt for Python 3.8
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.15.41-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.15.41-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Mon Jan 14 2019 Miro Hrončok <mhroncok@redhat.com> - 0.15.41-3
|
||||
- Subpackage python2-ruamel-yaml has been removed
|
||||
See https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.15.41-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Fri Jun 29 2018 Miro Hrončok <mhroncok@redhat.com> - 0.15.41-1
|
||||
- Update to 0.15.41
|
||||
- Add patch not to require ruamel.std.pathlib
|
||||
|
||||
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 0.13.14-4
|
||||
- Rebuilt for Python 3.7
|
||||
|
||||
* Fri Feb 09 2018 Iryna Shcherbina <ishcherb@redhat.com> - 0.13.14-3
|
||||
- Update Python 2 dependency declarations to new packaging standards
|
||||
(See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.14-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Aug 9 2017 Orion Poplawski <orion@nwra.com> - 0.13.14-1
|
||||
- Update to 0.13.14
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.13-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.13-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Mon Feb 13 2017 Jan Chaloupka <jchaloup@redhat.com> - 0.13.13-3
|
||||
- The ruamel.yaml needs at least typing >= 3.5.2.2
|
||||
related: #1386563
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.13-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Tue Jan 31 2017 Orion Poplawski <orion@cora.nwra.com> - 0.13.13-1
|
||||
- Update to 0.13.13
|
||||
|
||||
* Tue Jan 31 2017 Orion Poplawski <orion@cora.nwra.com> - 0.12.14-7
|
||||
- Add patch to support pytest 2.7 in EPEL7
|
||||
|
||||
* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 0.12.14-6
|
||||
- Rebuild for Python 3.6
|
||||
|
||||
* Wed Oct 26 2016 Orion Poplawski <orion@cora.nwra.com> - 0.12.14-5
|
||||
- Require python34-typing on EPEL
|
||||
- Ignore python2 test failure due to old pytest on EPEL7
|
||||
|
||||
* Wed Oct 26 2016 Orion Poplawski <orion@cora.nwra.com> - 0.12.14-4
|
||||
- Build python3 package
|
||||
- Run tests
|
||||
|
||||
* Tue Oct 25 2016 Chandan Kumar <chkumar@redhat.com> - 0.12.14-3
|
||||
- Disabling python3 as python3-ruamel-ordereddict not available
|
||||
|
||||
* Mon Oct 24 2016 Chandan Kumar <chkumar@redhat.com> - 0.12.14-2
|
||||
- Fixed python2-typing runtime dependency issue
|
||||
|
||||
* Fri Oct 14 2016 Chandan Kumar <chkumar@redhat.com> - 0.12.14-1
|
||||
- Initial package.
|
Loading…
Reference in New Issue
Block a user