Update to 0.17.21

Related: BZ#2042422
This commit is contained in:
Jakub Čajka 2022-05-12 13:51:02 +02:00
parent 74c70736bb
commit d16edee2ef
No known key found for this signature in database
GPG Key ID: 48DAAF91F61E4F5D
4 changed files with 11 additions and 72 deletions

1
.gitignore vendored
View File

@ -6,3 +6,4 @@
/ruamel-yaml-0.16.5.tar.gz
/ruamel-yaml-0.16.6.tar.gz
/ruamel-yaml-code-44504659794e463523ff8d0b40bac18dfe3b52f8.zip
/ruamel-yaml-code-c887dfe19e2f01b770a2b4b04163a01e00a33f85.zip

View File

@ -1,63 +0,0 @@
diff --git a/_doc/conf.py b/_doc/conf.py
--- a/_doc/conf.py
+++ b/_doc/conf.py
@@ -75,7 +75,10 @@
if False:
try:
from ryd.__main__ import RYDCmd
- from ruamel.std.pathlib import Path
+ try:
+ from pathlib import Path
+ except ImportError:
+ from pathlib2 import Path
oldargv = sys.argv
for fn in Path('.').glob('*.ryd'):
diff --git a/_test/roundtrip.py b/_test/roundtrip.py
--- a/_test/roundtrip.py
+++ b/_test/roundtrip.py
@@ -7,7 +7,11 @@
"""
import sys
import textwrap
-from ruamel.std.pathlib import Path
+try:
+ from pathlib import Path
+except ImportError:
+ from pathlib2 import Path
+
enforce = object()
diff --git a/_test/test_api_change.py b/_test/test_api_change.py
--- a/_test/test_api_change.py
+++ b/_test/test_api_change.py
@@ -9,7 +9,10 @@
import sys
import textwrap
import pytest
-from ruamel.std.pathlib import Path
+try:
+ from pathlib import Path
+except ImportError:
+ from pathlib2 import Path
class TestNewAPI:
diff --git a/_test/test_z_data.py b/_test/test_z_data.py
--- a/_test/test_z_data.py
+++ b/_test/test_z_data.py
@@ -6,7 +6,11 @@
import pytest # NOQA
import warnings # NOQA
-from ruamel.std.pathlib import Path
+try:
+ from pathlib import Path
+except ImportError:
+ from pathlib2 import Path
+
base_path = Path('data') # that is ruamel.yaml.data
PY2 = sys.version_info[0] == 2

View File

@ -1,22 +1,19 @@
%global pypi_name ruamel.yaml
%global pname ruamel-yaml
%global commit 44504659794e463523ff8d0b40bac18dfe3b52f8
%global commit c887dfe19e2f01b770a2b4b04163a01e00a33f85
%global debug_package %{nil}
Name: python-%{pname}
Version: 0.16.6
Release: 9%{?dist}
Version: 0.17.21
Release: 1%{?dist}
Summary: YAML 1.2 loader/dumper package for Python
License: MIT
URL: https://sourceforge.net/projects/ruamel-yaml
# Use bitbucket sources so we can run the tests
# https://sourceforge.net/code-snapshots/hg/r/ru/ruamel-yaml/code/ruamel-yaml-code-58889c2d944d5d0b22948a15d6fcb97c68d599de.zip
Source0: https://sourceforge.net/code-snapshots/hg/r/ru/ruamel-yaml/code/%{pname}-code-%{commit}.zip
# Don't require ruamel.std.pathlib, but use stdlib's pathlib on py3, pathlib2 on py2
Patch1: python-ruamel-yaml-pathlib.patch
%description
ruamel.yaml is a YAML 1.2 loader/dumper package for Python.
It is a derivative of Kirill Simonovs PyYAML 3.11
@ -54,7 +51,7 @@ rm -rf %{pypi_name}.egg-info
%{__python3} setup.py install --single-version-externally-managed --skip-build --root $RPM_BUILD_ROOT
%check
PYTHONPATH=$(echo build/lib) py.test-%{python3_version} _test/test_*.py
%pytest _test/test_*.py
%files -n python%{python3_pkgversion}-%{pname}
%license LICENSE
@ -64,6 +61,10 @@ PYTHONPATH=$(echo build/lib) py.test-%{python3_version} _test/test_*.py
%{python3_sitelib}/%{pypi_name}-%{version}-py%{python3_version}.egg-info
%changelog
* Tue May 10 2022 Jakub Čajka <jcajka@redhat.com> - 0.17.21-1
- Update to 0.17.21
- Related: BZ#2042422
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.16.6-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (ruamel-yaml-code-44504659794e463523ff8d0b40bac18dfe3b52f8.zip) = 920c1a41a94d55fe1e0598fe5b8d15a45342a37ed30c1b671d22579d88369b77ff9b6422200bc2106b28056962610149c5e899c68bbd096ea940800dc7ad560d
SHA512 (ruamel-yaml-code-c887dfe19e2f01b770a2b4b04163a01e00a33f85.zip) = cace08dd32b7794d390b493ad2f0d3824d01d55212cdecc9f5ae515fb12fa815ae81fb2df66221470bcd21d8d540556ff9df5f0c366142328ba567d06085ae71