Initial commit
This commit is contained in:
commit
709624288a
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
/rpmautospec-*.tar.gz
|
3
README.md
Normal file
3
README.md
Normal file
@ -0,0 +1,3 @@
|
||||
# python3.11-rpmautospec
|
||||
|
||||
The python3.11-rpmautospec package
|
9
python3.11-rpmautospec-0.6.5-no-pytest-cov.patch
Normal file
9
python3.11-rpmautospec-0.6.5-no-pytest-cov.patch
Normal file
@ -0,0 +1,9 @@
|
||||
diff -up rpmautospec-0.6.5/pyproject.toml.no-pytest-cov rpmautospec-0.6.5/pyproject.toml
|
||||
--- rpmautospec-0.6.5/pyproject.toml.no-pytest-cov 2024-06-18 14:25:58.620784500 +0200
|
||||
+++ rpmautospec-0.6.5/pyproject.toml 2024-06-26 18:05:30.891827296 +0200
|
||||
@@ -76,5 +76,4 @@ select = ["E", "F", "W", "I"]
|
||||
allowed-confusables = ["’"]
|
||||
|
||||
[tool.pytest.ini_options]
|
||||
-addopts = "--cov --cov-config .coveragerc --cov-report term --cov-report xml --cov-report html"
|
||||
tmp_path_retention_policy = "failed"
|
64
python3.11-rpmautospec.spec
Normal file
64
python3.11-rpmautospec.spec
Normal file
@ -0,0 +1,64 @@
|
||||
%global python3_pkgversion 3.11
|
||||
|
||||
%global srcname rpmautospec
|
||||
|
||||
Name: python%{python3_pkgversion}-%{srcname}
|
||||
Version: 0.6.5
|
||||
Release: %autorelease
|
||||
Summary: Package and CLI tool to generate release fields and changelogs
|
||||
License: MIT
|
||||
URL: https://github.com/fedora-infra/%{srcname}
|
||||
Source0: https://github.com/fedora-infra/%{srcname}/releases/download/%{version}/%{srcname}-%{version}.tar.gz
|
||||
Patch0: python3.11-rpmautospec-0.6.5-no-pytest-cov.patch
|
||||
|
||||
BuildArch: noarch
|
||||
BuildRequires: git
|
||||
# the langpacks are needed for tests
|
||||
BuildRequires: glibc-langpack-de
|
||||
BuildRequires: glibc-langpack-en
|
||||
BuildRequires: python%{python3_pkgversion}-devel
|
||||
BuildRequires: python%{python3_pkgversion}dist(babel)
|
||||
BuildRequires: python%{python3_pkgversion}dist(pygit2)
|
||||
BuildRequires: python%{python3_pkgversion}dist(pytest)
|
||||
BuildRequires: python%{python3_pkgversion}dist(pyyaml)
|
||||
BuildRequires: python%{python3_pkgversion}dist(rpm)
|
||||
BuildRequires: python%{python3_pkgversion}dist(rpmautospec-core)
|
||||
BuildRequires: python%{python3_pkgversion}dist(setuptools)
|
||||
%{?python_provide:%python_provide python%{python3_pkgversion}-%{srcname}}
|
||||
|
||||
%description
|
||||
A package and CLI tool to generate RPM release fields and changelogs.
|
||||
|
||||
%package -n %{srcname}
|
||||
Summary: CLI tool for generating RPM releases and changelogs
|
||||
Requires: python%{python3_pkgversion}-%{srcname} = %{version}-%{release}
|
||||
|
||||
%description -n %{srcname}
|
||||
CLI tool for generating RPM releases and changelogs
|
||||
|
||||
%prep
|
||||
%autosetup -n %{srcname}-%{version} -p1
|
||||
|
||||
%build
|
||||
%py3_build
|
||||
|
||||
%install
|
||||
%py3_install
|
||||
|
||||
# The macro file is contained in epel-rpm-macros
|
||||
# mkdir -p %%{buildroot}%%{rpmmacrodir}
|
||||
# install -m 644 rpm/macros.d/macros.rpmautospec %%{buildroot}%%{rpmmacrodir}/
|
||||
|
||||
%check
|
||||
%pytest -v
|
||||
|
||||
%files
|
||||
%doc README.rst
|
||||
%{python3_sitelib}/%{srcname}/
|
||||
%{python3_sitelib}/*.egg-info/
|
||||
|
||||
%files -n %{srcname}
|
||||
%{_bindir}/rpmautospec
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in New Issue
Block a user