From 39d6d62db6e9bbcf3c1d7d6fb729eca4cccf7e75 Mon Sep 17 00:00:00 2001
From: Gwyn Ciesla <gwync@protonmail.com>
Date: Fri, 30 Aug 2019 11:29:49 -0500
Subject: [PATCH] Path fixes.

---
 python-qt5.spec | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/python-qt5.spec b/python-qt5.spec
index d7a109e..a1dfe79 100644
--- a/python-qt5.spec
+++ b/python-qt5.spec
@@ -82,7 +82,7 @@ BuildRequires: pkgconfig(Qt5Xml) pkgconfig(Qt5XmlPatterns)
 BuildRequires: pkgconfig(Qt5WebChannel)
 BuildRequires: pkgconfig(Qt5WebSockets)
 %if 0%{?with_python2}
-BuildRequires: python2-devel python2
+BuildRequires: python27
 BuildRequires: python2-enum34
 %if 0%{?fedora} > 27
 %global python2_dbus python2-dbus
@@ -115,7 +115,7 @@ Obsoletes: python-qt5 < 5.5.1-10
 %package -n python2-qt5
 Summary: Python 2 bindings for Qt5
 Requires: python2-qt5-base%{?_isa} = %{version}-%{release}
-BuildRequires: qt5-qtbase-private-devel
+BuildRequires: qt5-qtbase-private-devel python27
 Requires: python2-enum34
 Provides: python2-PyQt5 = %{version}-%{release}
 Provides: python2-PyQt5%{?_isa} = %{version}-%{release}
@@ -286,7 +286,7 @@ pushd %{_target_platform}
   --sip-incdir %{_prefix}/include/python%{python2_version}/ \
   --dbus=/usr/include/dbus-1.0/ \
   QMAKE_CFLAGS_RELEASE="%{optflags}" \
-  QMAKE_CXXFLAGS_RELEASE="%{optflags} -I%{_libdir}/dbus-1.0/include/" \
+  QMAKE_CXXFLAGS_RELEASE="%{optflags} -I/usr/%{_lib}/dbus-1.0/include/" \
   QMAKE_LFLAGS_RELEASE="%{?__global_ldflags}"
 
 %make_build
@@ -306,10 +306,10 @@ pushd %{_target_platform}-python3
   %{?py3_sip:--sip=%{_bindir}/python3-sip} \
   %{?py3_sipdir:--sipdir=%{py3_sipdir}} \
   --verbose \
-  --sip-incdir %{_prefix}/include/python%{python3_version}m/ \
+  --sip-incdir %{_prefix}/include/python%{python3_version}/ \
   --dbus=/usr/include/dbus-1.0/ \
   QMAKE_CFLAGS_RELEASE="%{optflags}" \
-  QMAKE_CXXFLAGS_RELEASE="%{optflags} -I%{_libdir}/dbus-1.0/include/" \
+  QMAKE_CXXFLAGS_RELEASE="%{optflags} -I/usr/%{_lib}/dbus-1.0/include/" \
   QMAKE_LFLAGS_RELEASE="%{?__global_ldflags}"
 
 %make_build